Browser - Desktop Integration Vivaldi on Linux Doesn't Work

jbhardmanjbhardman
Community Member

I use Vivaldi for my work browser and MS Edge for my personal browser. On my work Mac, both browsers integrate as expected with the desktop app for automatic unlocking, etc. On Linux, only Edge does (and Firefox I tested it). Vivaldi on Linux expects me to login separately as if I don't have the desktop app running. I do have the NativeMessagingHosts file in the .config directory for vivaldi.

Anything else I could check?


1Password Version: 8.7.0
Extension Version: 2.3.3
OS Version: Fedora 36 (also in 35)

Comments

  • mdanielmdaniel
    Community Member

    I'm grateful for your comment, as it lead me to a successful outcome for my similar question about firefox. I wanted to report back in case it works for you, too:

    It is very likely that your MS Edge works because msedge is 0:0:

    $ ls -l /opt/microsoft/msedge/msedge
    -rwxr-xr-x 1 root root 219534296 May  4 17:30 /opt/microsoft/msedge/msedge*
    

    whereas your firefox-bin is likely owned by your current user, or a uid that they otherwise deem "unacceptable."

    If that's true of your circumstance, I'd suggest changing the ownership of at least firefox-bin and possibly all of the firefox files to 0:0 and see if it starts to work for you

    The tie-breaker is if your $HOME/.config/1Password/logs/BrowserSupport/1Password_rCURRENT.log contains "Failed to verify browser permissions", in case you wanted to have a look before going to the trouble of running the chown

  • PeterG_1PPeterG_1P

    Team Member

    Hi @jbhardman, thanks for raising this issue.

    "Vivaldi isn't on our list of browsers that we support by default on the Linux platform. That means you'll need to do a few things to get it working with 1Password.

    1. Ensure that 1Password for Linux is installed along with 1Password in your browser, and that browser integration is enabled from Settings → Browser within 1Password for Linux.
    2. Close 1Password completely.
    3. Pop open a terminal, and run sudo mkdir /etc/1password.
    4. Run cd /etc/1password.
    5. Run sudo gedit custom_allowed_browsers.
    6. Paste in the appropriate browser code - such as opera or vivaldi-bin. (the binary name)
    7. Save the file.
    8. In terminal, run sudo chown root:root /etc/1password/custom_allowed_browsers && sudo chmod 755 /etc/1password/custom_allowed_browsers
    9. Run 1Password - it will read our new config file and make the appropriate connections.
    10. Launch your browser. 👍

    I hope this is helpful - let me know if this resolves the issue for you!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file