1Password 8 crashes immediately every time I try to autofill in Safari.

Community Member

macOS Catalina 10.15.7 (19H1824)
MacBook Pro (Retina, Mid 2012)

Safari 15 Version 15.4 (15613., 15613)

Happens with Safari only. Happens with command-\ only. Happens with the new Safari extension from the Mac App Store installed and without it installed.

I deleted 1Password 8, all traces of past versions of 1Password, and every trace of any file and directory containing the strings 'agilebits' '1password' 'onepassword' everywhere on the system including everything in /Library/ and ~/Library, containers, preferences, extensions in other browsers, etc. then restarted then searched for any remainders and then reinstalled 1Password 8 again and reproduced the problem immediately.

Crash report:
Process: 1Password [749]
Path: /Applications/1Password.app/Contents/MacOS/1Password
Identifier: com.1password.1password
Version: 8.7.0 (
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: 1Password [749]
User ID: 501

Date/Time: 2022-05-11 16:09:57.083 -0400
OS Version: Mac OS X 10.15.7 (19H1824)
Report Version: 12
Anonymous UUID: 728F2C38-1C12-7564-757C-499C87E63251

Time Awake Since Boot: 370 seconds

System Integrity Protection: enabled

Crashed Thread: 46 tokio-runtime-worker

Exception Codes: 0x0000000000000001, 0x0000000000000000

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [749]

Application Specific Information:
BUG IN CLIENT OF LIBDISPATCH: Assertion failed: Block was expected to execute on queue [com.apple.main-thread]

Thread 0:: CrBrowserMain Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x00007fff6988edea mach_msg_trap + 10
1 libsystem_kernel.dylib 0x00007fff6988f160 mach_msg + 60
2 com.apple.CoreFoundation 0x00007fff3061d387 __CFRunLoopServiceMachPort + 247
3 com.apple.CoreFoundation 0x00007fff3061be41 __CFRunLoopRun + 1329
4 com.apple.CoreFoundation 0x00007fff3061b2b3 CFRunLoopRunSpecific + 466
5 com.apple.HIToolbox 0x00007fff2f288aad RunCurrentEventLoopInMode + 292
6 com.apple.HIToolbox 0x00007fff2f2887c5 ReceiveNextEventCommon + 584
7 com.apple.HIToolbox 0x00007fff2f288569 _BlockUntilNextEventMatchingListInModeWithFilter + 64
8 com.apple.AppKit 0x00007fff2d8d1659 _DPSNextEvent + 883
9 com.apple.AppKit 0x00007fff2d8cfea0 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1352
10 com.apple.AppKit 0x00007fff2d8c1bae -[NSApplication run] + 658
11 com.github.Electron.framework 0x000000010ca524c6 node::AsyncResource::get_async_id() const + 8884774
12 com.github.Electron.framework 0x000000010ca50d92 node::AsyncResource::get_async_id() const + 8878834
13 com.github.Electron.framework 0x000000010ca12efa node::AsyncResource::get_async_id() const + 8625242
14 com.github.Electron.framework 0x000000010c9dcc01 node::AsyncResource::get_async_id() const + 8403297
15 com.github.Electron.framework 0x000000010bce5e04 v8::internal::SetupIsolateDelegate::SetupHeap(v8::internal::Heap*) + 5185764
16 com.github.Electron.framework 0x000000010bce7742 v8::internal::SetupIsolateDelegate::SetupHeap(v8::internal::Heap*) + 5192226
17 com.github.Electron.framework 0x000000010bce3510 v8::internal::SetupIsolateDelegate::SetupHeap(v8::internal::Heap*) + 5175280
18 com.github.Electron.framework 0x0000000109e9b6e5 v8::internal::ExternalReference::fast_c_call_caller_pc_address(v8::internal::Isolate*) + 1957
19 com.github.Electron.framework 0x0000000109e9c8b3 v8::internal::ExternalReference::fast_c_call_caller_pc_address(v8::internal::Isolate*) + 6515
20 com.github.Electron.framework 0x0000000109e9c331 v8::internal::ExternalReference::fast_c_call_caller_pc_address(v8::internal::Isolate*) + 5105
21 com.github.Electron.framework 0x0000000109e9a8ed v8::internal::compiler::BasicBlock::set_loop_header(v8::internal::compiler::BasicBlock*) + 12173
22 com.github.Electron.framework 0x0000000109e9b223 v8::internal::ExternalReference::fast_c_call_caller_pc_address(v8::internal::Isolate*) + 739
23 com.github.Electron.framework 0x0000000109bcd568 ElectronMain + 152
24 libdyld.dylib 0x00007fff6974dcc9 start + 1

[abridged due to length constraint]

1Password Version: 8
Extension Version: Not Provided
OS Version: macOS 10.15.7


  • Hi @sunnykoala8229:

    Thanks for reporting this. This is something we're aware of and investigating, and hope to know more soon. I've added you as an affected user, and we'll be sure to follow up as soon as we've got more to share.


    ref: dev/core/core#15005

  • theengine
    Community Member
    edited May 2022

    Me too, same system and versions, only late 2013 Mac.

  • Sorry to learn of this, @theengine. I have added you to our list of affected customers and our developers are continuing to make this a priority. We'll hope to have more for you soon!

  • liteman94
    Community Member

    I'm having the same issue. Performed the same wipe clean and reinstall 1Password 8 as the original post and it still crashes.

  • randian
    Community Member
    edited May 2022

    Glad to know I'm not the only person experiencing this. It only happens to me when command-\ forces a search, which occurs when it's first unlocked. That in itself is bad behavior, 1P should check if the current website is a match, and then fill if it is, before popping up a search window.

  • Hi @randian:

    As I mentioned above, we're actively investigating this issue. In the meantime, using the in-line menu or the 1Password pop-up in your browser will allow you to fill as expected, rather than using ⌘+.


  • smithsonian
    Community Member

    I've had the exact same experience. 1password 8 is unusable with Safari.

  • @smithsonian

    Have you tried the steps Jack put forth? Do they help?

  • smithsonian
    Community Member

    @ag_tommy I did yes. No success. Running Catalina 10.15.7 on an old 2012 MacBook Pro.

    Not sure it has any correlation, but I had a local vault on my machine before the upgrade. I don’t see it anywhere on my machine any more as I anticipated based on the warning during the install. I mention it in case 1P is looking for the old vault and crashing when it can’t find it.

  • Hey @smithsonian:

    We've recently made some improvements to this in 1Password 8.7.1. If you check for updates and try to use Universal Autofill again, does that improve your state of play? Let me know!


  • qrs136
    Community Member

    This is happening to me as well. I only recently installed v8. It crashes in both browsers I use - Safari and Chrome.

    I tried completely uninstalling v7. No joy.

    Can I delete v8 and reinstall v7?

  • Dave_1P
    edited September 2022


    I'm sorry to hear that 1Password is crashing in both Safari and Chrome. So that we can investigate further, I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    The report will be in zip format. Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

    edit: Fixed the link so that it linked directly to your comment. 🙂

  • qrs136
    Community Member

    Here 'tis:

    Sorry for the delay. I thought I had pushed "go" a few days ago.

  • @qrs136

    Thank you for the Support ID. I see that you're already discussing the issue with one of my colleagues and I recommend continuing the conversation over email. 🙂

    ref: FZA-94675-891

  • randian
    Community Member

    I'm not sure if it's the same bug, but I've been seeing 1P crash on autofill (any browser) for a very long time now, but only if you needed to type your password to unlock 1P after typing Command-. It crashes immediately after your password is entered. If 1P is already open when you typed Command-\ there is no crash.

  • Hi @randian

    This thread is a few months old now, so I'd like to understand more about your specific case. I'd like to ask you to create a diagnostics report from your Mac:

    How to send a 1Password diagnostics report

    Attach the diagnostics to an email message addressed to [email protected].

    ⚠️ Do not post your diagnostics report here!

    With your email please include:

    • A link to your post: https://1password.community/discussion/comment/683407/#Comment_683407
    • Your forum username: randian

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here.  Thanks very much! :)

    — Grey

This discussion has been closed.