"Fill in Browser" option fails

jackbrannenjackbrannen
Community Member
in Mac

Previously, if I hit the shortcut (⌘) in my browser when 1Password was locked, it would activate and give me the option to unlock. This has suddenly stopped working.


1Password Version: 8.7.0
Extension Version: 2.3.3
OS Version: 12.3.1

Comments

  • Alvin.L_1PAlvin.L_1P

    Team Member

    Hey @jackbrannen:

    Can you let me know which browser you're using? Also, can you check the following setting for the browser extension?

    1. Open a browser window.
    2. Right-click on the 1Password icon located in the browser's toolbar, and select Settings.
    3. For the shortcut, "Open with Shortcut", what is it currently set to?

    I look forward to your reply.

    Alvin

  • jackbrannenjackbrannen
    Community Member

    Hey Alvin, thanks.

    Safari 15.4

    I don't have a Shorcuts area under Settings:

  • DavidBDavidB Senior Member
    Community Member
    edited June 7

    Hi @jackbrannen,

    I have the same setup as you and get the same behavior as you show in your screen shot.

    I could be wrong, but I think the setting to do what you want is in 1Password > Preferences > General > Keyboard Shortcuts > Show 1Password.

    By the way, that preference is blank for me, but if I am in Safari and 1Password is locked, pressing Shift-Command-X lets me unlock 1Password with Touch ID and opens the browser extension window ("pop-up").

    Or, pressing Shift-Command-Space also lets me unlock 1Password with Touch ID and opens Quick Access.

    David

  • DavidBDavidB Senior Member
    Community Member
    edited June 7

    Additional:

    In order for Shift-Command-X to work as described in my previous message, a browser window must first be open. (Not necessary for Shift-Command-Space though.)

    David

  • Alvin.L_1PAlvin.L_1P

    Team Member

    Thanks so much for your help @DavidB!

    Are you able to unlock the Safari browser extension by pressing the keyboard shortcut, Shift -Command - X @jackbrannen ?

  • jackbrannenjackbrannen
    Community Member

    @Alvin.L_1P Yes, that works. Where should I have seen that shortcut? It's not in my 1PW preferences.

    Also feedback from a UX perspective. If a user tries to the fill command and 1PW is locked, it seems obvious that it should ask if the user wants to unlock. Not simply do nothing.

  • Jack.P_1PJack.P_1P

    Team Member

    Hey @jackbrannen:

    ⌘+Shift+X is a default shortcut for 1Password for Safari and isn't configurable anywhere at the moment. Just to confirm, you're pressing ⌘+\ and aren't prompted to unlock 1Password? Let me know!

    Jack

  • jackbrannenjackbrannen
    Community Member

    @Jack.P_1P Yes, that's correct. ⌘\ does nothing when 1PW is locked.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file