Safari browser extension won't unlock...

I've recently installed the app/browser combo (using a family subscription) on a microsoft surface laptop, an ipad, 2 iphones and a mac. All are working fine - except the Safari browser extension for Mac. It remains locked and the 'Open 1Password' button seems dead. The only times it seems active is after I have uninstalled/reinstalled the extension to try to fix it - and then the 'installing' wheel keeps spinning but never opens. This is a real problem as it means we can't open/update sites or passwords that are specific to the member of my family who uses the Mac. I've tried everything I can think of to fix it (closed down / reinstalled both the 1Password for Mac 8 and the Safari browser extension a couple of times, rebooted many times, etc). Please help a new user...! Thanks


1Password Version: 8.8.0
Extension Version: 2.3.5
OS Version: macOS Big Sur 11.6.8
Browser:_ Safari

Comments

  • ag_tommyag_tommy

    Team Member

    @brendanj

    You indicated you were using 2.3.5 I would suggest quitting 1Password and quitting Safari, then check for updates to 1Password for Safari from the Mac App Store. The latest I see available is 2.3.7 I have a feeling you might be caught between updates.

    It's great to have you with us. We'll get you sorted.

  • BrendanJBrendanJ
    Community Member

    Hi Tommy - thanks for the reply. I checked and was in fact using 2.3.7. I’ve now deleted and reinstalled both the app and the browser extension for the Mac. On one occasion the browser opened for a password but would only take mine (master password) not my family member’s. I have tried everything I can think of to fix this but now am guessing that I might have gotten caught somehow: I did lots of the 1Password membership set-up and also importing of iCloud Keychain passwords on the Mac THEN I set up the account for my family member subordinately to mine. Is it possible that the Mac app and the Safari extension are looking for different account holders or something? I have tried to go in and adjust the accounts but I suspect I’m getting something wrong. Otherwise, 1Password is working fine across several other devices but not the Mac user - which, as life has it, is the one I needed it for most…

  • ag_tommyag_tommy

    Team Member

    @BrendanJ

    On one occasion the browser opened for a password but would only take mine (master password) not my family member’s.

    1Password is on a per user account (machine os user account) basis. You cannot sign into multiple accounts in the same installation, from the same family. That might explain the unlocking behavior.

    Switch quickly between users on Mac - Apple Support

    Is it possible that the Mac app and the Safari extension are looking for different account holders or something?

    This is possible if you do not share the lock state between 1Password and 1Password for Safari. If you right-click on the safari toolbar icon for 1Password and select settings do you see integrate with the app selected, in the general section?

  • BrendanJBrendanJ
    Community Member

    Hi Tommy. Thanks for the note (and sorry for the delay responding). I've now checked closely and it turns out I can log in (using my master password) on the Mac via BOTH the App and the Safari extension - but my family member can only log into the App using his password, NOT the Safari extension. (I've checked and the 'Integrate with the 1Password app' is selected.) Is there any way that I can change the settings so that he can use his password for both the App and the Safari extension on his Mac? I don't use the Mac at all and it was mainly for him that I subscribed. By the look of things, he's not having problems with his iphone, just the Mac - though the latter is what he uses mostly.

  • dpmeneghettidpmeneghetti
    Community Member

    Hi BrendanJ
    I had a scenario very similar to yours: family account, shared passwords and only one family member could not log in with his password in the Safari extension (on a macOS with all software in the latest versions).
    Your post about being able to log into the extension with the master password made me understand what was happening here: the Safari extension was connected to my 1P login, not my family member's –– he was also able to log into the Safari extension with the master password when 'Integrate with the 1Password app' was disabled in the app.
    I fixed it this way: in Safari, right click on the 1P extension icon > Settings. On the screen that opens, extension options, scroll down to "Accounts and Vaults" and notice the login entered. In my case, it was my email, not my family member's. So I logged out of that account and entered my family member's login.

    Now, macos app and Safari extension have the same login again, and I was able to re-enable the "Integrate with the 1Password app" option.

    Good luck!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file