Safari for Mac extension doesn't support unlock with Apple Watch

Options

I use my Apple Watch to unlock 1Password, but every time the Safari extension logs out it forces me to type in my password. This does not happen in Chrome; I simply use my watch to click it unlocked. This lack of feature parity is problematic. Also, I like to use the keyboard shortcut Command + \ to autofill. This works in Chrome, via a modal, much like it did in 1P 7. But in Safari, a message appears telling me to click the icon in the browser first. Then I makes me fill in the password. This really is unacceptable and makes the 1Password extension almost unusable in Safari.

Comments

  • Joy_1P
    Joy_1P
    1Password Alumni
    Options

    Hey @chadbush, it's possible that the 1Password for Safari extension may be having a hard time communicating with the 1Password app in order to unlock your account with Touch ID. To fix that, let us try the following:

    1. Right-click the 1Password icon in your browser toolbar and choose Settings.
    2. Under General, disable "Integrate with 1Password app".
    3. Fully quit 1Password app and browser.
    4. Restart the 1Password app and then open browser.
    5. Right-click the 1Password icon in your browser toolbar and choose Settings.
    6. Under General, re-enable "Integrate with 1Password app".
    7. Test things out with the extension.

    Let me know how that goes.

  • chadbush
    chadbush
    Community Member
    Options

    Hi @Joy_1P, I was unaware that there was a menu under there. This solution worked. Thank you!

  • On behalf of Joy, you're welcome.

This discussion has been closed.