1password 8 is a disaster. How do I revert to 7?

lrdlrd
Community Member

1password 8 is a disaster. How do I revert to 7 on a Mac laptop?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided
Referrer: forum-search:1password 8 is a disaster. How do I revert to 7?

Comments

  • pixelkatpixelkat
    Community Member

    I would prefer to revert to 1Password 7 as well. There are quite a number of aspects of 1Password 8 which feel like a downgrade and not an improvement.

  • pineconepinecone
    Community Member

    This comes up frequently now. The folks at 1PW don't seem to respond to these requests. But when I asked, another user provided steps in this thread:

    https://1password.community/discussion/comment/655052

  • ag_tommyag_tommy

    Team Member

    Thanks for pointing the direction @pinecone.

  • lrdlrd
    Community Member

    I started the thread. Thanks for confirming that 1Password 7 is still available and the process to reinstall it. It works. Here is what Walkingplaces described so you do not have to search.

    Go to safari and uninstall the browser extension
    Quit safari
    delete 8 from applications (your account will still be linked in ~/Library)
    Install 7 from the App Store
    you can now open safari and if necessary turn on the 1Password extension in safari prefs
    Don’t install 1Password browser extension standalone in the App Store there’s a version integrated in 1P7

  • juanmirocksjuanmirocks
    Community Member

    For the record, 1Password 7 is also available to be installed via homebrew:

    brew info 1password7
    ==> 1password7: 7.9.6 (auto_updates)
    https://1password.com/
    
  • c4jeffc4jeff
    Community Member
    edited October 3

    EDIT nevermind, a reboot and reinstall of the app and turning on extension seems to have solved it for now. Really hoping the disasterous search implementation of v8 gets changed back to what v7 had, otherwise we'll never be able to upgrade to 8...

    Can someone help, I followed the steps to revert back to v7, but now the extension won't work in Safari. When I go to preferences and click the checkbox to turn it on, it flashes in the toolbar but disappears. I'm unable to click on it or use it and it doesn't show up in the customize toolbar options. I've tried various attempts at unchecking the box and restarting safari, etc. but so far I can't get the extension back on Safari. I need to get this working since v8 is unusable for our team, appreciate any help you can give!

  • GreyM1PGreyM1P

    Team Member

    @c4jeff

    Try the following steps and let me know if they help:

    1. Open and unlock 1Password.
    2. Click the Help menu > Troubleshooting > Fix Missing Safari Extension
    3. Restart your Mac.

    If you're still having trouble after trying those steps, let me know and I'll be able to help out.

  • skofgarskofgar
    Community Member

    I also uninstalled 1Password 8 and the Safari Extension and re-downloaded 1Password 7.

    • I agree that the browser extension is much less intuitive than in version 7.
    • Also it happens a lot, that when I sign up to a new site and have 1Password fill, that it either does not fill the password (I know sometimes the websites are a problem here) NOR does it save the password it generated... so too often I have to go back and reset my password on a freshly created account 🤦‍♂️
    • Sometimes 1Password 8 also seems to freeze or be unresponsive for a few seconds...
    • I found the new 1Password mini less helpful to see login information or passwords, requiring way too many additional steps.

    Might try it again in a year or two...

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file