1Password seems to auto lock itself quickly despite my setting

loyed256
loyed256
Community Member

I'm trying to figure out why 1Password seems to lock itself quite quickly on my Mac despite my Auto-lock Security preference being set on Lock after the computer is idle for 8 hours. It feels like every time I initiate a quick access either in the browser or in the Finder I have to enter my password again each time. I'd like to enter in the morning and be able to get to it quickly.

My Apple Watch unlock isn't working either but that might be more system-related so first things first.


1Password Version: 8.9.4
Extension Version: Not Provided
OS Version: MacOS 12.5
Browser:_ Safari and Chrome

Comments

  • Hi @loyed256:

    Would you mind sharing a screenshot of your auto-lock preferences? Additionally, do you have 1Password configured to stay in your menu bar? That setting is in Preferences > General. Let me know!

    Jack

  • loyed256
    loyed256
    Community Member

    Yes I do keep 1Password in the menubar.

  • Hey @loyed256:

    Thanks for following up. Just to confirm, when you notice 1Password is locked, you haven't slept your Mac, switched users, or started the screensaver, right?

    Jack

  • loyed256
    loyed256
    Community Member

    No. I don’t think so.

  • asrosen5
    asrosen5
    Community Member

    I am having the same problem as @loyed256. I don't see a solution posted and would appreciate getting one. I also have the same answers to the questions - I do have 1Password configured to stay in my menu bar and when I notice 1Password is locked, I haven't slept my Mac, switched users, or started the screensaver. This never used to happen, but it has been occurring for some months now.

  • @loyed256 (apologies for the late response) and @asrosen5

    When you notice that 1Password is locked is it locked in the browser, in the menubar, or both? Can you also tell me if you use the Shift-Command-L shortcut for any of your other apps? That shortcut manually locks 1Password.

    I look forward to hearing from you. 🙂

    -Dave

  • asrosen5
    asrosen5
    Community Member

    Hi @Dave_1P. I believe it's locked in all locations (browser, dock, and menu bar), but it's certainly locked in the browser, which is where I almost always open it from. The next time it happens, I will check in all locations. I don't use the Shift-Command-L shortcut at all.

  • @asrosen5

    Thank you for the reply. The next time that you notice that 1Password is locked please note the time and whether 1Password is locked in the browser, the menubar, or both. Then, I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    The report will be in zip format. Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

  • asrosen5
    asrosen5
    Community Member

    As requested: [#ZRN-79561-646]

  • Thanks @asrosen5, I can confirm we've received it. We'll take a look and get back to you as soon as possible. 🙂

    ref: ZRN-79561-646

  • asrosen5
    asrosen5
    Community Member

    Thank you, @andrew.l_1P !

  • Happy to help! 😊

  • JimMxxx
    JimMxxx
    Community Member
    edited January 2023

    Any answer on this yet? I've just moved from LastPass to 1Password, and I feel too like I'm continually having to login to the extension in the browser. I just did an experiment where I found that if I closed my Macbook lid I have to sign back in the next time I use the extension. I assumed with me not having enabled the autolock setting that it would honor my 4 hour request.

  • Hi @JimMxxx,

    If you're noticing this with the browser extension specifically, I recommend checking if your browser extension and Mac app are set to integrate with one another. In the app settings, look for this option:

    image

    In the browser extension settings, which you can access by right-clicking the 1Password icon in your browser's toolbar, you can enable this option:

    image

    If these aren't set or you'd prefer not to set them, you can still adjust the auto-lock settings for the browser extension itself:

    image

    Give these a try and let me know how it goes or if you have any questions. 🙂

  • JimMxxx
    JimMxxx
    Community Member

    Thanks. All of those options were already set. What I've found that shutting the lid on my laptop is what is causing me to have to login again after I reopen the lid. I guess that makes perfect sense and I can live with that now that I know what causes it.

  • DavidB
    DavidB
    Community Member

    If these aren't set or you'd prefer not to set them, you can still adjust the auto-lock settings for the browser extension itself:

    @andrew.l_1P, what version are you using?

    With my setup (1Password 8.9.13, 1Password for Safari 2.5.1, macOS 13.1), in the browser extension Security settings, I don't have the same options you do, as in this screen shot:

  • @JimMxxx,

    Happy to help! 😊

    @DavidB,

    Those settings will appear once integration with the app is disabled, you can give it a try by turning off the "Integrate with 1Password app" option in your screenshot! We generally recommend keeping integration turned on for a more fluid experience between the two though. 🙂

  • DavidB
    DavidB
    Community Member
    edited January 2023

    Those settings will appear once integration with the app is disabled, you can give it a try by turning off the "Integrate with 1Password app" option in your screenshot! We generally recommend keeping integration turned on for a more fluid experience between the two though. 🙂

    Thanks for the tip.

  • loyed256
    loyed256
    Community Member

    @andrew.l_1P and @Dave_1P ... sorry the slow follow up as the OP. I have checked those settings you recommend and all seem correct. But still both lock seemingly quickly despite having lock times set for 4, 8 hours later. And the Safari 1Password unlock doesn't use Touch ID while the main one does.

  • @loyed256

    I'm sorry to hear that auto-lock is still not working correctly. I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    The report will be in zip format. Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

    -Dave

  • Ellee H.
    Ellee H.
    Community Member

    Auto-lock threshold is not being honored; I have come to this forum to find what I am doing wrong.

    Instead, I find that my frustrating user experience could be by design. I am far from alone in my state of disbelief.

    Can anyone confirm/dispel/answer these?

    1. if Autofill feature is enabled, 1Password will require master password on each use (ARGGHHH)
    2. I must enable Mac OS app integration with the Chrome browser extension (WHY?) for auto-lock to work?
    3. Does anyone else feel like the Mac OS app is deprecated, and complete migration to 1P.com was strongly encouraged? I thought I didn't have a choice (see #4), so #2 is especially confounding.
    4. Multi-device sync with a single vault requires 1p.com to be the "master."
    5. What is the precedence of the various auto-lock time/ threshold settings? The max is 300 minutes on 1p.com and 8 hours on the Chrome browser extension. Neither works as I expected.

    My devices: MacBook Pro M1 with touch ID upgraded to Ventura last night. iPad Pro 2021. iPhone 13 Pro Max. Human brain age 58.

  • Ellee H.
    Ellee H.
    Community Member

    I just thought of another variable (perhaps) in the undesired auto-lock functionality... I use an external monitor (modified cinema display) and move the Chrome browser window between my laptop and the cinema display, and often pull out a tab into another window. Do those window state changes force the extension to require master password?

  • ag_tommy
    edited March 2023

    @Ellee H.

    1. This sounds like a configuration issue. Possibly you are only using the 1Password in the browser.
    2. Touch ID would require the use of the desktop application as it communicates directly with the Secure Enclave where the extension does not.
    3. 1Password.com houses all of your data. You can use 1Password in the browser or 1Password for Mac if you like. I recommend both for the most flexibility. It sounds as if you might be in the same group.
    4. Yes, 1Password.com is the source of all truth, if you prefer to look at it that way.

    Do you have 1Password > Preferences (Settings) > General - Keep 1Password in the menu bar enabled? If not, please try that.

    Moving windows between displays should not cause the trouble you're having. Please check the setting above.

This discussion has been closed.