1password safari extension doesn't work

1Password for Safari extension is not working. When I click to unlock it in the browser toolbar I get a dropdown screen with a blue button that says "Open 1Password" and the 1Password app opens automatically so I can unlock it. After unlocking when I click on the browser toolbar icon I get the same dropdown prompting me to open 1Password. When I click the button nothing happens. Also, if I go to a website and try clicking the "Use 1Password" prompt/icon that is in the login box I get a similar issue. If the 1Password app is locked, that pops open so I can unlock it, but once it is unlocked nothing happens.

I have tried removing and reinstalling the extension. Everything is up to date. I tried quitting all applications and restarting the computer, no luck. Thanks for the help.


1Password Version: 8.9.4
Extension Version: 2.3.8
OS Version: 12.6
Browser:_ Safari 16.0
Referrer: forum-search:1password safari extension doesn't work

Comments

  • cortigcortig
    Community Member

    I've had similar issues for like… ever (over a year).
    The problem apparently is that the communication between the extension and the app is super slow. If you wait long enough, they eventually talk to one another and the extension will get the data from the app as it should, but the process is extremely frustrating.
    I eventually had to give up on the integration: I went to the settings and disabled the communication between the extension and the app.
    The extension then pulls all the data from the 1Password server directly and it works somewhat better (at least it's more responsive). It's still not perfect though as the extension doesn't respect all its settings and trends to lock itself up after only a few minutes regardless of my preferences (see this other thread).

    Corentin

  • XErAsErXErAsEr
    Community Member

    Hey guys, I have the same problem, watch here https://1password.community/discussion/comment/664727#Comment_664727

    There is a solution at he end of the rainbow, that is quick and dirty, but it works fine for a while. Quit and restart 1password and browser.

  • cortigcortig
    Community Member

    Hi @XErAsEr,

    I suspect your issue might be different. The extension is working for me, but it's locking itself up after 5 minutes no matter the settings in its preferences.
    I also disabled the integration with the 1Password app itself, so deleting the app would have no impact.

    Corentin

  • XErAsErXErAsEr
    Community Member
    edited November 23

    That could be the same problem. As you can see, the icon is locked and i cannot log in. Maybe the automatic locking function does not work properly together with the plugin.

  • Joy_1PJoy_1P

    Team Member

    Hey @XErAsEr, do you regularly clear your cache, cookies, or history? If not, I'd like to investigate things further. Please produce the issue and then send us the following:

    Attach the logs and diagnostics to an email message addressed to [email protected]

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file