1pw keeps lock itself

Hi,

latest beta on Firefox (2.4.6) keeps lock itself after unlocking so it is unusable at this time.

behavior :

  • unlock 1pw
  • go to a website to login
  • try to fill with 1pw extension (either by choosing via drop-down menu or use auto-fill button)
  • 1pw extension locks itself (the 1pw app is still unlocked)
  • happened either with "integrate with the app" or not

Cheers


1Password Version: 8.9.6
Extension Version: 2.4.6
OS Version: win 11
Browser:_ Firefox

Comments

  • Edison517Edison517
    Community Member

    I was just going to report the same issue. I hope it gets fixed soon, I can't live without 1P!

  • Edison517Edison517
    Community Member

    @Ben any update on this issue?

  • Edison517Edison517
    Community Member

    @Ashokleyland I removed the 1P extension and reinstalled it and now it seems to work properly.

  • AshokleylandAshokleyland
    Community Member

    @Edison517 Yep it works fine. Thanks for the tip. Something is wrong though

  • slickslick
    Community Member

    This is actually happening to me as well even after reinstalling the 1password extension.

    It could be because I'm using LibreWolf (a Firefox based browser). I don't have the integration with the Windows application turned on as recommended in an earlier thread about LibreWolf support and turning it on seems to cause no difference anyhow.

  • Jack.P_1PJack.P_1P

    Team Member

    Hey @Ashokleyland / @Edison517 / @slick:

    This is something we're aware of, and hopefully should be fixed soon. Keep an eye out for updates!

    Jack

    ref: dev/core/core#17935

  • peejaybeepeejaybee
    Community Member

    Just adding information, I have this problem with Chrome 106.0.5249.119

  • slickslick
    Community Member

    @Jack.P_1P Understood, thanks for the update.

  • iwaddoiwaddo
    Community Member

    The 1P Safari extension on my iPad seems to want the password frequently, it is not every time, but it certainly feels like it could be daily, despite the lock being set to weekly.

    Is this the same problem as mentioned above?

  • k3cua8k3cua8
    Community Member

    I'm using the browser extension (v2.4.x) with the latest Brave Browser on macos. The extension locks much more frequently than previous versions and seems to ignore whatever value I put into "Lock after system is idle for".

  • iwaddoiwaddo
    Community Member

    @k3cua8

    I agree, it is still a problem.

    This thread is very quiet so not sure if it is only impacting a few people and or whether 1P are struggling to get it fixed.

  • k3cua8k3cua8
    Community Member

    @Jack.P_1P do you know if there is an issue we can track anywhere on this?

  • Joy_1PJoy_1P

    Team Member

    @k3cua8 just to check, do you also have the 1Password app installed on your Mac? Are you able to send over a screenshot of your auto-lock settings?

    Here's how to find those settings:

    1. Right-click on the 1Password icon and select Settings.
    2. Go to Security and take a screenshot from there.

    Once we get the info above, we'll be able to help further. Talk to you again soon.

  • k3cua8k3cua8
    Community Member

    Hi @Joy_1P thank you for reaching out. I do not use the 1Password app on macos, I only use the extension for Brave Browser.

    Brave Browser version info: Release Notes v1.45.133 (Nov 25th, 2022) Upgraded Chromium to 107.0.5304.141. (#26965) (Changelog for 107.0.5304.141)
    Extension info: I just now upgraded the 1Password Brave Browser extension from 2.4.3 to 2.5.0.
    Here is the url for the extension: https://chrome.google.com/webstore/detail/1password-–-password-mana/aeblfdkhhhdcdjpifhhbdiojplfjncoa
    Here is a link to changes in version 2.5.0: https://releases.1password.com/b5x/stable/#whats-new
    One of the changes looks like it might be related: "Fixed over-aggressive locking behavior in Safari on macOS." So I'll see if the behavior improves.

    Finally, what you asked for, here is a screen shot of my lock settings: https://imgur.com/a/FFn8F4c

  • Joy_1PJoy_1P

    Team Member

    @k3cua8 Thanks for the info. Based on your description, it sounds like you have encountered a known issue with the auto-lock settings in the extension. The good news is that our developers have come up with a solution for the issue. However, the solution is not available yet. Hopefully it will be available soon.

    When the solution is available, it will be present in the beta version of the extension first. You can get that here: https://support.1password.com/betas/#install-a-beta-release-of-the-1password-extension

    Until then, I recommend downloading and installing the 1Password app. With that installed, the auto-lock security for the browser extension will controlled from the app and the issue that you've encountered will not be present. If you'd like to get the app, here are a couple links to get started:

    Download 1Password 8

    How to set 1Password to lock automatically

    Let us know if you have any other questions!

  • k3cua8k3cua8
    Community Member

    Thanks for the info @Joy_1P

  • Joy_1PJoy_1P

    Team Member

    @k3cua8 You are welcome!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file