Read first: Previous version support information


1password 6 - mac OS Ventura compatibility

gurchinaus7gurchinaus7
Community Member
edited November 17 in 1Password 3 – 6 for Mac

Hi guys,

Can anyone please tell me if 1password 6 is working with the new mac OS - Ventura? I have been checking roaringapps and forums since launch but there is no information out there.

Has anyone actually tried running 1password 6 on Ventura or if anyone is running Ventura is there any chance you could try installing 1password 6 and see if it runs ok? I dont want to upgrade my OS and find that I can no longer use 1password.

Really appreciate any feedback,

Thanks


1Password Version: 6
Extension Version: Not Provided
OS Version: macOS 13
Browser:_ Not Provided

Comments

  • Dave_1PDave_1P

    Team Member

    Hello @gurchinaus7! 👋

    1Password 6 for Mac is no longer supported and hasn't been tested on macOS Ventura. I personally haven't used this version in many years, while it's possible that it runs fine on Ventura it's also possible that you may run into unforeseen issues.

    We strongly encourage you to update to 1Password 8 as soon as you have the chance to take advantage of the latest features and updates.

    We're currently offering generous discounts on 1Password memberships to users who have been using our licensed version of 1Password. It you're interested then send in an email to [email protected] so that our billing team can offer you a heavily discounted 1Password membership. 😊

    -Dave

  • gurchinaus7gurchinaus7
    Community Member

    Thanks for the response Dave, i appreciate it. However, if anyone has actually tried running 1password 6 on ventura i'd still like to hear from you. I really don't need any other features from my password manager than was offered in this version and I'm not a fan of subscription models, so if it's not working, I'll either hold off upgrading mac OS or look for a different solution.

    I do think the 1password team should just test older versions at a basic level on new operating systems, I know it's not supported anymore and they are obviously encouraging people to upgrade, but I'm sure it wouldn't take long to simply see if the programme runs to support the users who have supported the brand for years.

    Thanks again for the response.

  • Dave_1PDave_1P

    Team Member
    edited November 24

    @gurchinaus7

    Thank you for your perspective. Since 1Password 6 hasn't been updated for many years, and macOS has gone through substantial changes since it was last updated, my recommendation would be to update to a later version when you can.

    I'm not on the QA team myself but I hear that the testing process is quite intensive for each version of 1Password and macOS. It's not limited just to making sure that the app opens without crashing. We wouldn't want to do a basic test, tacitly encouraging users to update to Ventura, only for an unexpected issue to occur that our basic testing didn't catch. We also don't want 1Password to be the reason why you don't update to macOS Ventura since we recommend always using the latest version of macOS. Since our attention is now focused on 1Password 8, it's unlikely that we'll return to working on 1Password 6 in the future.

    That being said, I hope that someone in the community can weigh in with their experiences if they're using 1Password 6 on macOS Ventura. 🙂

    -Dave

  • BaracCudaxBaracCudax
    Community Member

    @gurchinaus7 , I keep seeing “1Password failed to connect to 1Password mini” when trying to open 1Password. Maybe 1Password6 is not compatible with MacOS Ventura? Let me know if you're experiencing the same.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file