"Copy" Button Still Doesn't Work In 1Password Safari Extension (For iOS)

nimvionimvio
Community Member

Hello, whenever I tap on a field to copy its contents (such as a password, etc.), within the 1Password Safari extension, nothing gets copied. (I've included a picture to show what/where I'm talking about.) This issue has been going on for some time, and I believe I submitted a post on it, but I'm not 100% sure. The problem occurs within the regular, most recent, 1Password version, as well as the TestFlight beta version. If I can provide any other details, I'd be happy to.

Link to screenshot: https://imgur.com/a/gHdSpJ1


1Password Version: 8.9.7 (and 8.9.9)
Extension Version: Latest
OS Version: Not Provided
Browser:_ Not Provided

Comments

  • Dave_1PDave_1P

    Team Member

    Hello @nimvio! 👋

    I'm sorry that you're running into trouble copying passwords from 1Password in Safari. The issue seems to be that the copy function permissions get confused after an update, our team is investigating the issue. Some users report that the following steps help:

    1. Open the Settings app.
    2. Tap Safari.
    3. Tap Extensions.
    4. Tap 1Password.
    5. Tap Other Websites.
    6. Tap/select Ask.
    7. Switch back to Safari (the app).
    8. Tap the aA / puzzle piece icon.
    9. Tap 1Password.
    10. Tap Allow.

    Are you now able to copy from within the Safari extension? Let me know if you still aren't and I'll let our developers know that the steps didn't work for you.

    -Dave

    ref: dev/core/core#9820

  • nimvionimvio
    Community Member

    Hello, @Dave_1P , it appears to have solved the problem, as far as I can tell. Thank you for the help and response.

  • Dave_1PDave_1P

    Team Member

    @nimvio

    I'm happy that the copy feature is working again. 🙂

    -Dave

  • nimvionimvio
    Community Member

    @Dave_1P , I hate to be a bother, but it's not working again -- "copy" doesn't successfully copy a field when using the 1Password mobile Safari extension (note: I'm using the latest TestFlight beta).

  • Dave_1PDave_1P

    Team Member

    @nimvio

    I'm sorry to hear that the issue returned, did using the same steps as before help gets things working again? Or is the copy function still not working after trying those steps again? Let me know and I'll pass along your report to our developers. 🙂

    -Dave

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file