SSH agent error - failed to start ssh config file watcher

Community Member
edited December 2022 in SSH

I have a fresh install of ubuntu 22.04LTS and I've noticed that the SSH agent is not showing during ssh login.
I've installed 1Password using package manager.

I've found these errors:
$ cat ~/.config/1Password/logs/1Password_r00000.log | grep "ssh" ERROR 2022-11-30T22:12:51.215 ThreadId(22) [1P:ssh/op-ssh-config/src/] Could not open ssh config file in ~/.ssh/config ERROR 2022-11-30T22:12:51.215 ThreadId(22) [1P:/builds/dev/core/core/ssh/op-ssh-config/src/] Failed to start ssh config file watcher: Io(Os { code: 2, kind: NotFound, message: "No such file or directory" }) INFO 2022-11-30T22:16:03.505 tokio-runtime-worker(ThreadId(3)) [1P:ssh/op-agent-controller/src/] SSH Agent has started.

I've also followed this guide and tried troubleshooting with the aid of "Get help" section. Could you please help me?

1Password Version: 8.9.8
Extension Version: Not Provided
OS Version: ubuntu 22.04LTS
Browser:_ Not Provided


  • Hi @smoxy:

    Thanks for reaching out. Just to confirm, have you followed all the steps on the Get Started page?

    Get started | SSH Agent

    After the agent is enabled in 1Password, it's still necessary to configure SSH to use it, either with an environment variable, or a setting in ~/.ssh/config. Let me know how you get on with that, or if you run into trouble along the way.


  • smoxy
    Community Member
    edited December 2022

    Hi @Jack.P_1P, I fixed it after a couple of hours enabling TPM from bios, but I still get some errors:

    1. every time I have to make an SSH login 1password asks me for the password
    2. addons both on chromium and on firefox are not bound with the 1password app.

    Do I have to open another thread or could you help me from here?

  • Hi @smoxy:

    In that case, I'd like to ask you to create a diagnostics report from your Linux computer:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

This discussion has been closed.