1Password on Mastodon

Reporting biometric auth nearly every use

jkane001jkane001
Community Member

I have the security settings set to enable fingerprint lock, to never require password, and to auto-lock after 8 hours. And yet, nearly every time I go to a site or an app that needs a password, after I select the site from the gboard suggestions, 1Password requires I auth with my fingerprint. If I do 2 in rapid succession, it usually doesn't require it on the second use, but within a few minutes, it's back to asking.


1Password Version: 8.9.12
Extension Version: Not Provided
OS Version: Android 13
Browser:_ Chrome

Comments

  • ag_timothyag_timothy

    Team Member

    Hi @jkane001, thanks for writing in and letting us know about this issue.

    Behavior like this is typically caused by inadvertently locking the app, battery optimization or a few other device factors locking 1Password silently in the background.

    Do you typically unlock 1Password for Android directly or primarily through Autofill prompts? Do you typically keep multiple apps open in the background?

    Thanks again!

  • jkane001jkane001
    Community Member

    I typically unlock through autofill prompts.

    I don't specifically run apps in the background, but I also don't force close apps, and I am a pretty prolific user of apps, so there probably are a bunch open in the background at any given time. I did have a pixel 6 pro (just switched it out for a 7 pro), so I don't tend to think of resources as particularly stretched.

    Side note - in setting up my new device, I noticed that there's a number of apps that don't cause the prompt in any way in Gboard, and almost every time, selecting "autofill" in the context menu didn't really in anything happening. Sometimes I'd get a toast telling me it couldn't autofill, but mostly just nothing happened at all.

    Examples: Starbucks & Zaxby's. Also apps that have login ID on one screen and password on the next seemed universally bad WRT autofill.

  • ag_timothyag_timothy

    Team Member

    Thanks for following up with me @jkane001, my apologies for the delay in reply.

    I'd like to ask you to set battery optimization (device settings > Apps > 1Password > Battery) to unrestricted for 1Password then check for a difference in locking behavior.

    I did some testing with the Starbucks and Zaxby's app and found they were both more responsive with prompts below fields. You can change that setting with these steps:
    1. Open and unlock 1Password for Android.
    2. Tap the account or collection icon.
    3. Tap Settings > Autofill.
    4. Tap Display Autofill prompts > Below the fields they relate to.

    Let me know if you see an improvement with that change.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file