1Password on Mastodon

Apple Watch focus mode

SystemSystem

Team Member
This discussion was created from comments split from: Watch not prompting for authorization.

Comments

  • shazronshazron Junior Member
    Community Member

    I have my Apple Watch to unlock my macOS desktop 1Password, and it works great, especially with the SSH agent when I am developing and pushing some code.

    However, working late at night, I have the Sleep focus mode turned on (automatically), which obviously will suppress all notifications, including 1Password. However, I do allow some apps to have notification exceptions in the Sleep focus mode, like other auth apps like Okta Verify, or my banking app.

    So I thought that I can add the 1Password app as an exception on my iPhone, however it is not listed as one of the apps. How do I add the 1Password app as a focus mode exception? I think it's not listed as an app because it does not have any notifications, not sure.

    The workaround for me is to turn off the Sleep focus mode when I am working but that often is dangerous if I don't turn it back on before I go to sleep (usually groggy), since that is tied to my alarm in the morning, so sometimes I miss my morning alarm because of it.

  • Dave_1PDave_1P

    Team Member

    Hello @shazron! 👋

    As far as I'm aware, 1Password 8 doesn't use notifications on macOS. Can you tell me a little more about what it is that you're trying to do? Are you running into an issue when unlocking 1Password 8 for Mac using your Apple Watch?

    I look forward to hearing from you. 🙂

    -Dave

  • shazronshazron Junior Member
    Community Member

    No, I outlined the scenario exactly above.

    My Apple Watch is in a Sleep focus mode. I can't get any notifications on my Apple Watch when in this mode (to unlock 1Password, especially to unlock it for SSH key requests), naturally, because it stops all notifications, except if you allow apps to bypass it, which I allow with my banking app and Okta Verify (it's a focus mode setting via the iPhone). I want to allow 1Password as an exception, but it is not available in the list it provides.

    1. Allow 1Password to unlock using your Apple Watch
    2. Set up SSH agent on 1Password (make sure it works well)
    3. Put your Apple Watch in Sleep Focus mode
    4. Try to do a git pull or something which will trigger a request to unlock on your Apple Watch
    5. It won't show the notification of course, and "goes away" quickly on the Watch, because it is in Sleep Focus Mode (as expected)
    6. Workaround is to allow the app to bypass the focus mode setting, but the app is not available to be selected (it is not in the list of apps)
  • Dave_1PDave_1P

    Team Member
    edited January 12

    @shazron

    Thank you for the clarification. I can indeed confirm that I'm not only able to reproduce the same behaviour on my own Apple Watch, but that we're already tracking the issue internally to see if there's something that we can improve here or if this is a macOS/watchOS issue. I've added your notes to our internal tracking item for the issue so that our developers are aware.

    Hopefully this can get fixed in the future. I'm sorry for the frustration that the issue is causing, thank you for reporting it.

    -Dave

    ref: dev/core/core#19161

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file