1Password on Mastodon

Firefox integration with desktop app not working

I have recently switched to Firefox (from Edge) on my Linux machine. Previously, biometric unlock unlock worked when I pressed the unlock shortcut, but now in FIrefox it doesn't seem to work for me. I found a similar topic where the option to enable integration with the desktop app was mentioned. I checked and this setting is enabled for me. I tried disabling and re-enabling it.

The unlock keyboard shortcut (Ctrl+Shift+period) also doesn't seem to work.

I have uninstalled the firefox snap and installed it from a deb package, in case the snap confinement was the root cause, but that didn't make a difference.

How can I fix this?

1Password Version: 8.9.14
Extension Version: 2.5.1
OS Version: Ubuntu 22.10
Browser:_ Firefox


  • minttamasminttamas
    Community Member

    It looks like the shortcut not working was temporary, but the integration with the desktop app is still not working.

  • steph.gilessteph.giles

    Team Member

    Hey @minttamas,

    I'm sorry for the trouble you are having with 1Password in your browser. I think it would be useful if we could take a closer look at some logs and what may be going wrong.

    I'd like to ask you to send over a console log from your browser as well as a diagnostics report:

    Please attach the reports to an email message addressed to [email protected] with a link to this thread.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

  • minttamasminttamas
    Community Member

    To help anyone else stumbling upon this later: with the help of 1pw support, it was found that the issue was AppArmor rules blocking Firefox from accessing the 1pw process. This is how:

    sudo dmesg | grep apparmor | grep firefox | grep 1Password

    This revealed plenty of denials.

    Then I did the following:

    sudo ln -s /etc/apparmor.d/usr.bin.firefox /etc/apparmor.d/disable/ 
    sudo apparmor_parser -R /etc/apparmor.d/usr.bin.firefox

    This wholesale disables AppArmor for the Firefox process, which might not be desirable in all situations. I'm sure a more refined solution is possible where only the access to 1pw is allowed, but I was OK with disabling it fully in my case.

  • ag_tommyag_tommy

    Team Member

    Thanks for sharing @minttamas

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file