1Password on Mastodon

Unable to copy suggested passwords from Safari on the Mac

This discussion was created from comments split from: Unable to copy generated passwords in iOS 16.1.1.


  • ozguneozgune
    Community Member

    I ran into this problem twice as well. I can see the suggested password, but I can't copy it in.

    The first time, I restarted Safari and 1Password and it fixed the problem.

    Now, I restarted Safari 16.1, Chrome 109.0.5414.119, and 1Password 8.10 on my MacOS 13.0, and I keep running into the same issue. This issue happens when I try to generate a security passphrase on gitter.im.

  • steph.gilessteph.giles

    Team Member

    Hey @ozgune,

    It sounds like there might be an issue with the extension syncing to our server. Could you try the following to re-sync your account and see if it helps?

    1. Right click the 1Password icon in your browser toolbar and choose Settings.
    2. Under General, disable "Integrate with 1Password app".
    3. Under Accounts & Vaults, sign out of your account.
    4. Sign back into your account.

    If you use the 1Password desktop app on your computer, please go back and re-enable "Integrate with 1Password app". If you do not use the 1Password desktop app, then please leave it off.

    Let us know if this improves things!

  • ozguneozgune
    Community Member

    Thank you for the reply.

    I ran through the four steps that you've shared. I can now copy the suggested password in most other websites. Sadly, gitter.im still doesn't work.

    When I try to reset my security passphrase in gitter.im, I can't copy in 1Password's suggested password. When I enter a password myself and try to have 1Password copy it, it doesn't work either.

  • Joy_1PJoy_1P

    Team Member

    Hey @ozgune, just to clarify, are you running into this issue while trying to reset your account password? Is that what you mean by your security catchphrase? Or is your security catchphrase something separate that you need to also use when signing in?

    If your security catchphrase is not your account password, then the suggested password should not appear in the field. Are you seeing a suggestion and then trying to click on it? If not, are you using the password generator to copy and paste a custom password to the security catchphrase field?

    I just want to get a better understanding of what's going on. Hope to hear from you again soon.

  • ozguneozgune
    Community Member

    Hi there,

    Thank you for the post.

    I've uploaded a screenshot to help clarify (I've added the black bar myself. 1Password displays the generated password.).

    In summary, the security passphrase is a second password that gitter.im uses for decryption. When I set it up, 1Password would show a generated password, but when I clicked on the generated password, it wouldn't be filled in. So, I manually picked a password.

    I ran through @steph.giles's steps. Now, I'm trying to reset my security passphrase and I'm running into the same issue.

  • Joy_1PJoy_1P

    Team Member

    @ozgune thanks for all those details. Since the issue doesn't occur on other sites, I suspect that the inability to fill the suggested password for your security phrase on gitter.im is a bug. To report the bug, I'd like to ask you to grab the following for us:

    1. Sign in to your website and navigate to the form where you can reset your security phrase.
    2. On that page, right click the 1Password icon in your browser toolbar.
    3. Click Help and choose Collect Page Structure.
    4. 1Password will save a .json file to your "Downloads" folder.
    5. Attach the downloaded .json file to your next reply.

    In the meantime, I recommend using the password generator in the extension as a workaround. You should be able to copy the new password from there and fill it on your website. Here's how to do it: https://support.1password.com/getting-started-browser/#create-a-custom-password

    I hope the workaround helps!

  • ozguneozgune
    Community Member

    Hi there,

    Thank you for the workaround. It worked for me.

    If I have time, I'll also run through your steps and share them in a follow-up reply. Thanks again!

  • ag_tommyag_tommy

    Team Member

    On behalf of Joy, you're welcome. We look forward to hearing from you.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file