Using Passkey on Synology NAS

Community Member
edited September 21 in 1Password in the Browser

I was wondering if Synology NAS works with 1Password's Passkey feature through the new browser beta.

Has anyone tried it ?

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided


  • Hi @dwk

    Are you asking if you're able to sign in to a Synology NAS itself with a passkey or to Synology's website? For the latter, my testing seems to indicate that they support signing in to their website with a passkey and you can configure this by heading to your Synology's account settings > Security > Hardware Key.

    I don't have a Synology NAS available, but if you head to the NAS' settings do you see anything mentioning hardware keys/passkeys/biometrics unlock anywhere?

  • Hi @OlivierP

    Could you test this out in Chrome on your device and see if you're able to get the passkey stored in 1Password to sign in to your NAS? From taking a look at their documentation, you may also have better luck choosing the hardware security key option here too.

  • dwk
    Community Member

    Hi, @jac.pd_1p

    Thanks for the tip, I managed to get synology website to work with passkey.
    And as for the NAS it seems that Synology does not yet officially support passkey in contrast to their website login.

    Just an idea though,
    it would be awesome if 1password forum supported passkey as well.

  • Dave_1P
    edited June 15

    @dwk and @OlivierP

    Thank you for the update! Hopefully passkeys are supported across more and more services as time goes on.

    Just an idea though, it would be awesome if 1password forum supported passkey as well.

    I would love for us to support passkeys for the forum. I've shared your request with the team. 🙂


    ref: dev/web/

  • pleasant1
    Community Member
    edited September 19

    It does NOT work properly at this time, at least with Safari and a Mac.
    The Synology website works just fine, but attempting to use a 1p passkey with the NAS itself does not.
    It will save the generated passkey in 1p, but any attempt to login using that passkey will instead bring up the Safari-iCloud passkey dialog (if present) or request insertion of a usb key et al.
    This bug has been reported to agilebits, support ticket [#PSB-67195-311]

  • Hey @pleasant1,

    I have located your support ticket, let's continue this conversation with our team over email.

    Thanks for your patience.

    ref: PSB-67195-311

  • jmartindf
    Community Member

    I've been having a similar issue with my Synology and passkeys as well. I can provide more info, if it helps to debug the issue.

  • @jmartindf Thank you, we would really appreciate any information or feedback you can provide!

    If the information contains any personal details, please could you send an email addressed to [email protected] with a link to this thread.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. We look forward to hearing from you!

  • michaelyork
    Community Member

    Having the same issue as well. Happy to provide debug info as helpful.

  • Hey @michaelyork,

    Can you provide the steps you are taking so I can try to replicate it on my end?

    Are you trying to sign in to a Synology NAS with a passkey or Synology's website?

    Any details on the behaviour you are seeing would be really helpful!

  • michaelyork
    Community Member

    Hey @steph.giles – happy to help reproduce!

    • Set up your DSM account for passkey authentication

    • Try either of the two key types (one is U2F, one is actual Passkey – both should be compatible with 1Password's implementation from what I've observed with other websites)

    • 1Password extension will correctly offer to save the passkey for either key type you choose
    • Log out of DSM and try logging back in. When DSM prompts for the passkey, 1Password doesn't pick it up and it falls back to the OS implementation (in my case, the iCloud Keychain prompt)
  • rmnelson
    Community Member
    edited October 27

    I have a similar issue with my Synology NAS attempting to use Safari and 1Password to login. I setup the key after picking the USB Key/Passkey option. Logged out, then at the prompt picked "use a different method of login" and was presented with the "use your iPhone to login" and the QR code. Scanned QR code and was able to login by authorizing on the iPhone. Same process using Chrome browser. Passkey login does work, but apparently Synology won't use a Passkey that isn't in the iCloud Keychain. I am able to use other passkeys to login to other sites on both Safari and Chrome, so I know that Passkeys can work with my setup. I have iCloud sync off for "passwords and Keychain" with all passwords and passkeys only in 1Password. I restarted my computer with no change noted.

  • Hi @michaelyork and @rmnelson,

    I was able to successfully use a passkey to sign in to the Synology DSM website with the latest beta version of 1Password in your browser paired with the latest beta version of 1Password 8.

    I'd like to ask you to update to the latest versions of both betas and attempt to use your passkey to sign in. If that is not successful, I'd like to ask you to recreate the passkey and attempt once more.

    Let me know how that goes or if you have any further questions.


  • michaelyork
    Community Member

    @FrankyO1P Are you referring to Or an actual DiskStation appliance’s control panel (DSM) you’re trying to log into? also supports Passkeys and that’s always worked great with 1P. DSM (local appliance login) does not work properly.