Always asking for a password, when macbook in a clamshell mode

Community Member
in Mac

1Password for Mac 8.10.7 (81007041)

MacOS Ventura 13.4 (22F66)

I have a MPB M1 Pro 16" (2021)

Every time i open 1Password it asks for my master password, even though i'm closing it using CMD+W, not CMD+Q, it happened when i updated to 1Password 8 if i not mistaken.

As you can see, i disabled auto-lock completely. I guess, it's happening because my MBP lid is closed and i'm connected to external non-touch id keyboard + display.

1Password Version: 8.10.7
Extension Version: 2.11.0
OS Version: MacOS 13.4
Browser:_ Chrome


  • Hello @heihachi88! 👋

    I'm sorry that you're being asked to unlock 1Password more often than expected. As a start, can you check to see if you have the option to keep 1Password's icon in the menubar turned on:

    1. Open and unlock 1Password for Mac.
    2. Click on 1Password next to the  in the menu bar.
    3. Click on Settings.
    4. Click on General.
    5. Turn "Keep 1Password in the menu bar" on.

    The menu bar icon has to be turned on in order for 1Password's processes to continue running when you close the main window. If the menu bar icon is turned off then 1Password will completely close and lock when you close the main window.

    If the icon is already turned on and you're still seeing the same issue then let me know. 🙂


    ref: dev/core/core#9557

  • heihachi88
    Community Member

    @Dave_1P it's indeed was turned off! Thanks! I just enabled it and now even closing it with CMD+Q and its not asking for a password!

    Is it 1Password 8 feature?

  • @heihachi88

    I'm happy that turning on that option resolved the issue. When using 1Password 8, you do indeed have to turn on the "Keep 1Password in the menu bar" option so that 1Password can stay running and unlocked in the background after you close the main window.