Autofill with Gboard

This discussion was created from comments split from: 1Password Keyboard for the smartphone.


  • FrankBreech
    Community Member

    Anyone exploring Gboard compatibility with 1PW Autofill? I'm trying to move away from bitwarden to 1PW, I really am! But it just seems to come down to one or two seemingly major sticking points, autofill being one of them.

    Any updates?

  • Hi @FrankBreech, thanks for writing in.

    Inline filling suggestions from 1Password work consistently with Gboard. I will note that information copied to the clipboard when using Gboard can block the suggestion strip. This can be resolved by pasting the information from Gboard, using below field filling prompts, or turning "Show recently copied text and images in suggestions bar" off from Gboard settings.

    Are you referring to a different aspect of Gboard compatibility?

  • PeterH999
    Community Member

    GBoard does not work with 1Password on my Samsung s23 Ultra. As soon as I change to the Samsung keyboard everything works.

    I really want to use GBoard but this fault is a deal breaker.

  • loggor
    Community Member
    edited July 2023

    I use GBoard and 1Password on my S23 Ultra and haven't had any issues with the autofill prompt. I only noticed that the prompt was showing up on almost every text field (which is a known issue).

    Edit: One thing I did though, was to turn off the Google Autofill. I don't know if it interferes with something, because I never set it up.

  • Hi @PeterH999, thanks for writing in.

    I'm not seeing any issues with Gboard on my S22. I'd like to ask you to temporarily change clipboard setting in Gboard settings then check for a change in behavior:
    1. Open device settings.
    2. Select General management > Gboard settings (Gboard will need to be set as the default keyboard to see this option).
    3. Select Clipboard then turn "Show recently copied text and images in suggestions bar" off.

    If you still do not see prompts from 1Password, I'd like to ask you to try setting prompts below fields as well:
    1. Open and unlock 1Password for Android.
    2. Tap the account or collection icon.
    3. Tap Settings > Autofill.
    4. Tap Display Autofill prompts > Below the fields they relate to.

    Let us know if you're now seeing prompts with Gboard set as the keyboard. Thanks again!

    Thanks for your input @loggor!

    Google's Autofill and other built-in password managers certainly can interfere with Autofill and it can be helpful to confirm those are set off.

    The issue you mentioned with prompts in text fields has been resolved with today's beta release to version 8.10.9-29. However, I'll note that we've found a regression that causes updating to the beta to reset Biometric unlock. So, if the update is installed please keep in mind your password will be required.

This discussion has been closed.