How to completely disable 2FA prompting

I keep my 2FA codes separate from 1Password. As such, I never, ever want 1Password's autofill popup to come up on a 2FA field. (Or anything that looks like a 2FA field, like a postcode field. But that's a separate gripe.) But as far as I can tell, there's no way to globally disable this behaviour without also disabling password autofill.

Am I missing something? If not, please consider adding this feature.

1Password Version: 8.10.7 (81007041)
Extension Version: 2.10.0
OS Version: Not Provided
Browser:_ Not Provided


  • Hey @ideabucket,

    There isn't a way to stop 1Password from appearing in 2FA fields. It shows up on these fields as it can fill them in for you. Here's how: Use 1Password as an authenticator for sites with two-factor authentication.

    If you would like to quickly dismiss 1Password in a field you can hit the ESC key on your keyboard or click on the 1Password icon in the field.

    I hope this helps.

  • modjeska
    Community Member
    edited October 27

    I second the request above. There should be a way to stop 1Password from appearing in 2FA fields. This is inherently a customer option, not a vendor marketing opportunity.

  • Hey @modjeska,

    Thank you for your feedback, I have passed it on to our product team.

    Let us know if there is anything else we can help with at all.

    ref: PB36539084