1Password extension not honoring the Request Password setting

Community Member
edited February 27 in 1Password in the Browser

Once again I am finding that I need to enter my password to access the 1Password extension much more often than the 2 weeks I have the desktop app set to use in place of my biometrics.

AM I misunderstanding how the feature is implemented? If I do understand the expected behaviors, what must I do, assuming I can do anything, to get this to stop?

A few more thoughts:

  • I do find it confusing that the desktop app has a setting to control this feature but the extension does not seem to have a similar control.
  • I also find the setting to enable integrating the extension with the desktop app to be confusing and to not work well.
    • When enabled there are times when the extension will not unlock, or require manual entry of the password, even though the desktop app is open. Of course the app may not be unlocked even though it is open. But there is nothing to tell me the state.

FYI I find this is happening on iPadOS as well but I do not need it as often on iPad so I am not 100% certain if the issues match up.

Also as a feature request, can the app and the extension maintain logs of the date and time when the app or extension are unlocked and the mechanism used to unlock them? This could help unravel exactly what is going on. Speaking for myself I would find them to be helpful.

1Password Version: 8.10.26
Extension Version: 2.20
OS Version: macOS 14.3.1
Browser: Safari


  • Hello @gct3o! 👋

    I'm sorry that you're being prompted for your account password more often than expected, that definitely isn't right. The extension doesn't have its own setting for this since it will share the setting, and lock state, with the 1Password for Mac desktop app if it's installed.

    It sounds like communication between the 1Password extension in your browser and the 1Password for Mac app has broken down. As a first steps, try the following:

    1. Close all open web browsers.
    2. Right-click on the 1Password icon at the top of your Mac's screen and then click Quit. Wait until the icon disappears.
    3. Double-click on 1Password from your Mac's Applications folder.
    4. Open your web browser.

    If you still see the issue then can you tell me if you see a message saying [Status:Connected🟢] when you right click on the 1Password icon in your browser and then click Settings? Or do you see a different message or coloured circle?