Autofill stopped working in Samsung Internet Browser

Options
xiscosc
xiscosc
Community Member
edited May 30 in Android

1Password suggestions or the 1password button stopped appearing on top of the keyboard in browsers. This is happening on my Galaxy S23 Ultra with Android 14 / One UI 6.1 and on my tablet Galaxy Tab S9 FE with Android 14 / One UI 6.0.

I tried different combinations of browsers and keyboards with no results at all:

  • Samsung Keyboard
  • Gboard
  • Samsung Internet
  • Google Chrome

I also disabled and re-enabled autofill, I unset and re-set 1Password as the preferred service for Passwords, passkeys and autofill in Android Settings.

If I try to log in to an app directly that does not have an in-app browser it works as expected, the suggestion appears on top of the keyboard.


1Password Version: 8.10.30
Extension Version: Not Provided
OS Version: Android 14
Browser: Samsung Internet 25.0.0.41

Comments

  • mattwright
    mattwright
    Community Member
    Options

    I have the exact same problem on the s24 ultra.. it started sometime last couple of days.. Ive tried the same.. it randomly started working for a couple hours last night and nothing today.. it must be a bug

  • cataclisma
    cataclisma
    Community Member
    edited April 30
    Options

    Same here on my Pixel 8 Pro.
    Seems like the last 1Password update broke Autofill on Android devices

    UPDATE:
    So just found out, it is a Samsung Internet Issue. The current Version 25.00.41 broke the 1Password integration.
    When I use Chrome, then 1Password Autofill works as intended.

  • Nige
    Nige
    Community Member
    edited April 30
    Options

    Until today, I was on the latest version of 1P7 on Samsung S21 Ultra and it worked great in terms of Autofill in Samsung Internet Browser (25.00.41). Installed 1P8 and Autofill still worked, or I thought, but after removing 1P7 found the Autofill was only working still due to 1P7 being installed.
    No way I could get it working with 1P8. I have had to remove both 1P8 and reinstall 1P7 to regain Auto fill - note: in 1P7 Autofill setting, strangely I have to turn it off & leverage Accessibility only.

    Seems 1P8 has broken Autofill in Samsung Internet Browser. Hope this can be resolved.

  • xiscosc
    xiscosc
    Community Member
    Options

    For me its broken everywhere, I can not make it work with chrome either.

  • leekyo87
    leekyo87
    Community Member
    Options

    I am using Samsung S23 Plus device. After updating Samsung Internet Browser to version 25.0.0.41, 1Password was corrupted and did not work.

  • jazzlaw
    jazzlaw
    Community Member
    Options

    Same on galaxy fold 5. Works with Chrome but not Samaung Internet.

  • leekyo87
    leekyo87
    Community Member
    Options

    I am using Samsung S23 Plus device, Android 13. After updating Samsung Internet Browser to version 25.0.0.41, 1Password was corrupted and did not work.

  • xiscosc
    xiscosc
    Community Member
    Options

    I can confirm that it's an issue with Samsung internet, it works well on Edge

  • Nige
    Nige
    Community Member
    Options

    Did anyone have 1P8 autofill (latest or earlier version) working in Samsung Browser v25.0.0.41 or earlier?

    1P7 autofill appears to still work as it uses Android Accessibility but that's not available as an option in latest 1P8.

  • teoZ
    teoZ
    Community Member
    Options

    Same issue on my Galaxy S24 Ultra. I've tried everything including reinstalling, and clearing cache but it doesn't seem to work. Chrome works fine.

  • imhotep
    imhotep
    Community Member
    edited May 3
    Options

    Same issue here, using Google Chrome on a Samsung Galaxy S23. 1Password just closes, asking for a restart, but no autofill. I've already cleared cache, but without solution.

  • Ozarks
    Ozarks
    Community Member
    Options

    Samsung browser v25.0.0.41 will not allow 1Password to work in it. 1Password still works fine in chrome, Firefox & Edge for Android. Now, I get prompts to store my passwords with Samsung, which I have no intention of doing. This really angers me because the Samsung's Browser worked so much better in my Pixel phone than any other browser I've used.

  • xiscosc
    xiscosc
    Community Member
    Options

    It's fixed on the new samsung internet version

  • BrendanR1P
    Options

    Hi all,

    Just to add additional information into this issue that was occurring. This issue appeared to be a bug that was occurring after an update to Samsung Internet Browser in which autofill suggestions from any password manager wouldn't appear in Samsung Internet Browser.

    This was reported within the Samsung Community on this link - https://eu.community.samsung.com/t5/mobile-apps-services/autofill-with-third-party-password-managers-no-longer-working-in/td-p/9772564/page/4

    While there has been no official confirmation from Samsung that the issue has been resolved, some posts in that thread on Samsung Community indicate the issue has been resolved in the latest update released for Samsung Internet Browser. With that said, some users have also mentioned the issue is still occurring for them after updating to the latest version of Samsung Internet Browser.

    In my own experience, to resolve this issue I had to install an update for Samsung Core Services and Samsung Internet Browser that were available in the Galaxy Store. If anyone is continuing to have this issue on their end, it's worth checking if these pending updates are appearing on your devices in the Galaxy Store and installing the updates to see if they resolve the issue.

    I hope this helps.

    -- Brendan

  • Nige
    Nige
    Community Member
    Options

    Thanks Brendan. I already had the latest Samsung Browser but with no luck. I had a few pending Galaxy store updates including Samsung Core Services so that may have been what did the trick for me too.

  • Dave_1P
    Options

    @Nige

    I'm glad that installing the pending updates resolved the issue for you. 🙂

    -Dave