New autofill automation disconcerting

Options

Sometime recently autofill behavior changed for me. It used to be that autofill would populate username/password then I could click "login" or the equivalent and I would login or fail. With that behavior I could manually change a password or username or ask for a password reset. Now, autofill also submits the login automatically. Much of the time this is very convenient, but even when it is convenient it is disconcerting to me. It is inconvenient when the login fails as trouble shooting becomes significantly more difficult. Is there a setting to go back to the older behavior?


1Password Version: 8.10.34
Extension Version: 2.24.2
OS Version: macOS14.4
Browser: Brave 1.67.116

Comments

  • ag_tommy
    Options

    @aag1944

    Yes, you can use the previous settings.

    1. Right-click on the 1Password in the browser toolbar icon.
    2. Select settings.
    3. Select Autofill & Save.
    4. Disable the following option.

    Sign in automatically after autofill

    • 1Password will automatically submit forms after filling logins.
  • aag1944
    aag1944
    Community Member
    edited June 16
    Options

    Thank you for your help. I did as you said and changed the "AutoFill & Save" setting. For the test case I had, it did not change anything. (That was after logging off and logging on again, just in case that mattered.) Oddly, logging into THIS community discussion it worked as I wish! OTOH, I tried a couple of other web sites and had the same result, namely: as soon as I selected the 1password prompt on the username, both username and password were filled in and the page logged in. EDIT: Sorry, I changed the wrong option! What you suggested worked perfectly! Thank-you!

  • Dave_1P
    Options

    @aag1944

    I'm happy that Tommy's steps helped. 🙂

    -Dave

  • luckman212
    luckman212
    Community Member
    Options

    Regarding this: I found a site that doesn't work with autosubmit enabled (FreshDirect.com). Instead of pressing the submit button, it was actioning the "Forgot my password" link every time.

    So it would be nice if this feature could be disabled on a case-by-case basis instead of globally all or nothing. Generally it's a very nice and timesaving feature, but I had to disable it because this one site out of 1,000 did not work...

  • ag_tommy
    Options

    Thanks @luckman212

    I've filed that report with the team.

    ref: dev/core/core#30763

  • luckman212
    luckman212
    Community Member
    Options

    Great! Appreciate that.

  • Dave_1P
    Options

    Thanks again for reporting the issue! 🙂

    -Dave

  • Swerve
    Swerve
    Community Member
    Options

    I mentioned it in another thread, but I'm not sure if anyone saw it: this login automation should be opt-in, not opt-out. It's not good to hijack a browser's behaviour by default. Users should be asked to consent to that.

    And, as @luckman212 suggested, even when users opt in, they should be able to choose which websites the functionality is applied to. Because inevitably, it will cause problems with some websites.

  • excession
    excession
    Community Member
    Options

    I have the same issue with several websites including the Google login (accounts.google.com) : with the new autofill feature, the "forgot email" link would be activated instead of the "next" button.

  • ag_tommy
    Options

    @Swerve

    Please report those sites here and we'll file bug reports as quickly as possible. I also put in a feature request for an ability to exclude sites in a listing which I can add your voice to. I see your other post. Thanks for mentioning it. I'll get something before the team around that one as well.

  • ag_tommy
    Options

    @excession

    What browser are you using? I had no trouble on the page. Please let me know more. Thanks.

  • dragon1
    dragon1
    Community Member
    Options

    Same for me.

    Issues with:

    • GMail (using other languages than English)
    • Reddit (general login issues - esp. with 2FA)
    • Peplink.com Login (same as reddit and looping)
  • excession
    excession
    Community Member
    Options

    What browser are you using? I had no trouble on the page. Please let me know more. Thanks.

    I am using Chrome on Linux in French (latest version).

    I also had the issue on fdj.fr (national French lottery) where the first link is activated instead of the submit button.

  • EvonG1P
    Options

    @dragon1,

    I'm sorry about the trouble you're experiencing on Reddit. I've been able to reproduce the same issue and have added your report to an internal work item that our developers have open.

    In the meantime, I'd suggest dragging and dropping the one-time password into the field from the 1Password extension pop-over in your browser's toolbar. I realize this isn't ideal, and I appreciate your patience while we work to improve the behaviour on this page.

    As for the other two websites, I've replied to you in the other forum thread here -> https://1password.community/discussion/comment/713188/#Comment_713188.


    @excession,

    I appreciate the additional details. I can reproduce the issue on Google's sign-in page if the page is in French. I created an issue for our development team for further investigation and added you as an affected user.

    As for https://www.fdj.fr, I cannot navigate to the sign-in page due to my location. I'd like to request that you send me a collected page structure to support+forum@1Password.com from the website for further investigation. I can then report the behaviour to our development team. Here's how to collect the page structure:

    1. Navigate to the page exhibiting the behaviour.
    2. Right-click the problematic field and select 1Password > Help > Collect Page Structure.
    3. 1Password will save a .json file to your "Downloads" folder.

    After that, attach the file to your email.

    I look forward to your reply.

    -Evon

    ref: dev/core/core#24532
    ref: dev/core/core#30816