Chrome extension says Connecting 1, 2, 3

jsm253jsm253
edited November 2013 in 1Password 3 – 6 for Mac

I am running version 3.9.19.90 in Google Chrome on OS X Mavericks with my 1Password data stored in Dropbox. However, when I click the browser extension to enter my master password, it says Connecting and starts counting 1, 2, 3, etc. What is the problem?

Comments

  • MeganMegan

    Team Member

    Hi @jsm253,

    I'm sorry to hear that you're having trouble with the Chrome extension. I'd like to know a bit more information about the situation to see if we can't track down what's going on here:

    • Are you seeing the same behaviour in Firefox and Safari?
    • Is the main app locked on unlocked when you notice this?
  • I do not use Firefox or Safari on this computer. The 1Password extension has always worked on this machine with Chrome until recently. The main app is unlocked when I notice this. Thank you, Megan.

  • MeganMegan

    Team Member

    Hi @jsm253,

    Thanks for confirming that for me. It sounds like you might be running into a firewall issue. Please have a look at our Configuring Proxy Settings article here and see if any of the steps help.

  • Hi @Megan, I have installed 1Password for the first time and having the same problem. I don't have a proxy. What can I do?

  • MeganMegan

    Team Member

    Hi @akirau,

    Welcome to the 1Password family :) I'm sorry to hear that the Chrome extension is misbehaving for you. I'm going to need just a bit more information from you in order to get this properly sorted out:

    • Are you seeing this behaviour in any other browsers?
    • Is the main app locked or unlocked when you notice this?

    I'd also like to see a Diagnostics Report from your computer.

    If you are using OS X 10.8 Mountain Lion or OS X 10.7 Lion: Download the 1Password Troubleshooting utility and follow the instructions to generate the report.

    If you are using OS X 10.9 Mavericks or OS X 10.6 Snow Leopard: Using your browser please download a small standalone tool from us that will run a networked copy of our diagnostics tool.

    http://i.agilebits.com/kyle/tools/1Password_diagnostics.zip

    After the download is complete, use Finder to locate it. It should be in your downloads folder. If the file ends in .zip then your browser has not already unzipped it. Please double click it to expand it.

    The expanded file will have a "Unix Executable File" named 1Password_diagnostics. Double-clicking this will cause a Terminal window to open and download some files it needs. (Note: If you use OS X Lion or Mountain Lion, you may need to right click the file, choose Open, and click Open on the dialog).

    Once it completes it should open a window in your browser with the results. Please click File->Save As to save this file to your computer. Please save it as "Page Source" or "HTML" if there are options for this.

    If you do not get a report created, please copy and paste the output from the Terminal window so we can take a look at the errors that were created. This will help us figure out where the problem is in creating the diagnostics report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Hi Megan,

    I was going to first install the extesion on firefox to try it out and it directed me to your extension download site where I saw that the extension version for Chrome is 4.0 and not 3.9 like the one I got from Chrome Store. Tried it our with your newest extension and now I can log in. :D Very happy now.

    Here is the link, https://agilebits.com/browsers I recommend everyone having this problem to download the extension from here instead of the Chrome store.

  • MeganMegan

    Team Member

    Hi @akirau,

    My apologies for misunderstanding your situation! Your post is in the 1Password 3 Extensions forum, so I thought that you were still using 1Password 3.

    You are correct, 1Password 4 requires the version 4 extension. I'm glad you were able to find it and get yourself all sorted out :)

  • I am now having this same problem running Chrome on Snow Leopard. I have been using 1Password for years with no problems. Today, I noticed that there was a red exclamation point on my 1Password icon in Chrome, and the extension had a message that said the extension was having problems. I downloaded the most recent extension 3.9.19 and installed it, and restarted Chrome. Now, when I try to use the extension, it says Connecting, and then starts counting up. It never connects. My desktop app still works fine. I also tried uninstalling 3.9.19 and installing the latest Beta version of the extension 3.9.20.4 and get the same result. I will try the diagnostic that you mentioned above and email the report.

  • By the way, I have left it counting as high as 150... I just emailed the diagnostic report.

  • Just tested it with Safari using 3.9.19 and it works fine there (although it also gets the red exclamation point, and the message is "Problem with 1Password Helper")

  • sjksjk oversoul 1Password Alumni

    Thanks for sending the report, @bhawthorne. We've received it okay and will follow up directly in email now so that things don't get confused between here and there! :)

  • Having the absolutely same problem with my chrome extension. Reinstalled chrome, reinstalled 1Password extension, however when i try to unlock it in browser, it starts counting up. Extremely crucial for me to resolve this issue as it effects my work. Desktop application works just fine. Just the chrome extension.

  • Hey guys, issue seems to be resolved. I updated my desktop app to the latest and it just worked.

  • MeganMegan

    Team Member

    Hi @PravinRajah,

    I'm so glad you managed to get things sorted out! It's always so nice when things "just work" - here's to hoping things continue that way :)

This discussion has been closed.