Read first: Previous version support information


Citicards login doesn't work

Rabbit32Rabbit32
Community Member
edited December 2014 in 1Password 4 for Windows

This is driving me nuts! I have both of the following URLs stored in 1P:
https://www.accountonline.com/cards/svc/Login.do?siteId=CB&langId=EN

https://www.citi.com/credit-cards/creditcards/CitiHome.do

Yet I can't get 1P to successfully log me in. Just tonight, I was on the 2nd URL and it doesn't work. I tried calling up their site using 1P and it doesn't work. I even switched the order of the 2 URLs and tried it, but no success.

There's got to be a way to make this work. I'm afraid I'll get locked out of my Citi account with too many failures.

I'm on 1P 4.1.0.530, Firefox 34.0, Windows 7.

By the way, you guys need to make it easier to get support. I looked all over your site and didn't find a single support phone # or email address.

And 1P for Windows should let you copy more kinds of text to the clipboard. Just to put these 2 URLs in this forum post, I had to go into 1P and edit the entry, then edit the URLs individually in order to copy them to the clipboard. And I had to manually type the 1P version number into this post, as there's no way to copy that to the clipboard either.

Very unhappy and frustrated....

Comments

  • RichardPayneRichardPayne
    Community Member

    Copying urls is a very unusual thing to do which is why, I suspect, there's no button to it.
    Same with the version, although I agree that there should be a way to do it.

    As for getting support, I used to agree with you. However, they have updated their support page which now reads as:

    Discussion Forums
    The AgileBits team is answering your questions 7 days a week. Get help fast!

    Seems fairly clear to me. Why would you need a phone number or email address?

    Anyway, on your problem:

    I have both of the following URLs stored in 1P: https://www.accountonline.com/cards/svc/Login.do?siteId=CB&langId=EN

    >

    >

    Yet I can't get 1P to successfully log me in. Just tonight, I was on the 2nd URL and it doesn't work. I tried calling up their site using 1P and it doesn't work. I even switched the order of the 2 URLs and tried it, but no success.

    Can you confirm what "doesn't work" means. Is it filling but not submitting? Is it filling wrongly? If is just no filling at all?

    Have you tried copying and pasting the username and password manually from the main 1Password app to confirm that your stored details are correct?

    I had a quick look at the site and it seems that they're doing funky JS processing on the username and password fields. I guess of the JS devs is going to need to take a look at this to see if they can work around Citibank's oddities.

  • svondutchsvondutch
    1Password Alumni
    edited December 2014

    @Rabbit32‌ My advice is to save a new Login item for these URLs manually:

    1. Start 1Password
    2. Unlock
    3. Click on: New Item > Login
    4. Should you see a warning, then you can ignore this (click on: "OK")
    5. Enter your User ID and your Password and https://www.accountonline.com/cards/svc/Login.do
    6. Click on: "OK"
    7. Double-click on your newly created Login item
    8. Check (enable) this setting: "Use Auto-Type in web browser"
    9. Click on: "OK"

    Here's how to test-drive your new Login item:

    1. Start Firefox
    2. Navigate to https://www.accountonline.com/cards/svc/Login.do
    3. Click inside the User ID field
    4. Click on the 1Password button
    5. Click on your new Login item (it should be somewhere at the top of the 1Password popup menu)

    Now repeat these steps for https://www.citi.com/credit-cards/creditcards/CitiHome.do

  • DBrownDBrown
    1Password Alumni
    edited December 2014

    Just for the record, my own Login item for CitiBank works at both those URLs (tested just now in Chrome) and does not have auto-type enabled.

  • RichardPayneRichardPayne
    Community Member

    @DBrown you might want to re-check in Firefox. Both @Rabbit32 and I were using that rather than Chrome.

  • DBrownDBrown
    1Password Alumni

    Ctrl+\ works as expected when I'm on the https://www.citi.com/credit-cards/creditcards/CitiHome.do page in Firefox 34.0.5.

  • svondutchsvondutch
    1Password Alumni

    @DBrown @RichardPayne The (web form) fields associated with your Login item might be different. In my testing, I couldn't get these Logins to work without Auto-Type. Oh well.

  • RichardPayneRichardPayne
    Community Member

    Neither could I @svondutch. @DBrown seems to be the only one with non-autotype logins.

    It's odd though. The username field has some funky javascript going on but that seems to fill. The password field appears to be standard but that's not filling. I really think that the JS team should take a look.

  • DBrownDBrown
    1Password Alumni

    In case it helps:

This discussion has been closed.