Firefox browser extension stopped working in 1Password 3

I still use OS 10.6.8, so can't upgrade to a more recent version of 1Password, but I am using the current version of Firefox (35.0.1). The browser extension has stopped automatically saving passwords for new sites, and does not enter passwords for saved sites. I need to copy and paste at each site, which is a drag. Any ideas why this is happening, and how it can be fixed? I only use 1Password on my Mac at this point, so syncing is not an issue.


  • Hi @SanFran,

    The first question I'd like to ask is what is the state of the vault when viewed from within the main application? I just want to verify that the extension and the 1Password 3 have been keeping themselves in sync as they actually keep separate databases.

    Next I'd like to ask what the current settings of the extension are.

    1. Click on the extension button in your browser and unlock your vault if required.
    2. Click on the cog icon to access the extension's settings.
    3. Click on the Login Settings button.

    What are the preferences set to?

    I've just tried Firefox 35.0.1 myself and it's working so I don't think we're looking at a fundamental compatibility issue with this version at least.

    Let us know the answers and we'll continue from there.

  • Hi Bobby,

    The main app and the extension appear to be in sync (e.g. a password I added manually using the extension is also in the vault). Under Login Settings, all 3 options are checked (e.g. automatically submit, ask to save, and animate filing)

  • If it matters, the main app version is 3.8.22 and the extension version is 3.9.20

  • Hi @SanFran,

    Those are the last versions so you are using the most up to date for 1Password 3. As the main application's vault is correct with nothing missing it can't do any harm to try uninstalling the browser extension and re-install it after a reboot.

    Here's a link on Uninstalling 1Password’s Firefox Extension for 1Password 3.

    Let us know if it makes any difference.

  • I keep losing my 1password icon to open the vault and would like to restore it to my bookmark toolbar.

    1Password Version: Not Provided
    Extension Version: Not Provided
    OS Version: Not Provided
    Sync Type: Not Provided
    Referrer: forum-search:Please tell me how to restore the 1password icon to my firefox bookmark toolbar.

  • Hi @greenmd,

    Can you tell us a little about your system please. The following information will allow us to better understand the issue.

    1. What operating system and version of operating system you are running?
    2. What version of 1Password are you running?
    3. What version of Firefox are you running?
    4. What version of the 1Password extension is installed?

    With that we will have a much better idea of what might have happened.

  • I've quite frustrated and not a little disappointed by the LACK of functionality of 1Password on Mac Firefox 40.0. I have the same software versions for the app and the extension as SanFran above.

    When will this be fixed? Or, how can I fix this?

  • Hi rdsherry:

    I got 1Password to work OK with Firefox 39.0.3, then flamed out when I upgraded to Firefox 40.

    As I suspected, we've reached the point where we need to upgrade our operating system and use a later version of 1Password or downgrade our version of Firefox back to 39.0.3. For the time being, I'm living with the cut/paste from 1Password until I can get my ducks in a row to upgrade to Yosemite and a later version of 1Password. It's time. I received a very prompt and helpful answer from Steve in Customer Service which I'll share here:

    It appears you're aware of the general issues, so unless you ask me for a complete and somewhat technical explanation, I'm going to cut to the chase and tell you what need to be done to get 1Password and Firefox working again.

    You're most likely running Firefox version 40 now. This is why you don't see the 1Password icon anymore. So you'll want to downgrade to Firefox version 39.0.3. Here's how:

    You'll need to stay with version Firefox 39.0.3 indefinitely since Firefox version 41, 42 and beyond will not allow the 1Password 3 extension to run. If you have a need to run a higher version than Firefox 39.0.3, you will not be able to use 1Password with Firefox. If you must use a higher version, then you'll either need to upgrade your Mac to Yosemite, if your Mac supports Yosemite and then upgrade to '1Password 5 for Mac'. If it doesn't, you'll need to acquire a new (or newer) Mac that supports at least 10.9 (Mavericks) or higher, and upgrade to '1Password 4 for Mac' or '1Password 5 for Mac'.

    I hope this helps. I'm sorry for the inconvenience, but technology moves as a crazy pace. :(

  • Very helpful, SanFran. Thanks!

  • And BINGO, there it is. Sigh, I guess an upgrade to my software is needed soon. Cheers

  • littlebobbytableslittlebobbytables

    Team Member
    edited September 2015

    Hi @rdsherry,

    For more on what happened along with the options available we would recommend checking out our article titled 1Password 3 extension missing in Firefox 40 or later. It will explain what happened in Firefox 40 that resulted in the extension breaking and what options are available. I originally did suggest reverting to Firefox 39 when this first came out but I have reconsidered and believe you're better off with Firefox ESR 38 as it still has the widgets module but will also receive security updates until around May of next year. That will give some breathing room while you consider what to do going forward.

  • That's very helpful. Thanks. Your suggestion about going back to FF ESR 388 seems well founded. Regards

  • MeganMegan

    Team Member

    Hi @rdsherry,

    I'm so glad to hear that you've found the answers you're looking for!

    I hope that 1Password behaves perfectly for you from now on, but if you have any other questions or concerns, we're here for you! :)

  • I am running an old version of Mac (I DO NOT want to upgrade this for fear of explosion), so I cannot upgrade to the latest version of 1Password. I do NOT want to downgrade my FF because I am a Web/software designer and need to have the most recent version of this browser. I do NOT want to use another browser, because I am most comfortable in FF when on my Mac.

    Please help me resolve this issue.

    1Password Version: 3.8.22
    Extension Version: 3.9.20
    OS Version: OS X v. 10.6.8
    Sync Type: Not Provided
    Referrer: kb:v3-extension-firefox

  • Drew_AGDrew_AG 1Password Alumni

    Hi @cbartell,

    Since you're using 1Password 3 for Mac, I've moved your message to our "1Password 3 for Mac" forum and merged it with an existing discussion for the same issue. I hope you don't mind!

    The problem is that, starting in Firefox 40, Mozilla removed something called the “widget module” which is used by some older extensions, including the 1Password 3 extension. Without that widget module in Firefox, the 1Password 3 extension can no longer work. You can find more information (including a few options) in this knowledgebase article:

    1Password 3 extension missing in Firefox 40 or later

    One of the options there is to upgrade to 1Password 5, but unfortunately you won't be able to do that on Mac OS X 10.6.8 because 1Password 5 requires OS X 10.10 or higher (and 1Password 4 requires OS X 10.8 or 10.9). So that leaves the other two options, which are to switch to a different supported browser, or switch to Firefox ESR (please see the above article for more information about those options).

    I'm sorry I don't have a better answer for you, but hopefully this helps to explain what happened and what your options are for using the 1Password extension. If you have more questions about that, please let us know!

  • Using Firefox 40.0.2

    I went through the extension installation steps you recommend several times but it didn't work. What can I do?

    1Password Version: 1Pass 3.8.22
    Extension Version: Not Provided
    OS Version: 10.7.5
    Sync Type: DropBox

  • MeganMegan

    Team Member

    Hi @bobbbbbb,

    I've merged your post with an existing discussion on the matter. Please see Drew's post above for an explanation and a link to our knowledgebase article on the subject.

  • c6zzc6zz
    edited August 2015

    Hello. I am using 1Password 3.8.21 on my new MacBook running OS X 10.10.5 Yosemite. I had no issues getting Safari to accept it but when I try & get Firefox (version 40.0) I get an error message. I have downloaded 1Password-3.xpi but my computer says that I can't open it & suggests going to the apple store to find an app that can.
    Thanks for the help.

    1Password Version: 3.8.21
    Extension Version: Not Provided
    OS Version: 10.10.5
    Sync Type: Not Provided

  • Take a look at this article about what is happening with Firefox with respect to 1Password 3.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @c6zz,

    Since you're using 1Password 3 for Mac, I've moved your message to our "1Password 3 for Mac" forum and merged it with an existing discussion for the same issue. The article from the link in hawkmoth's reply should explain the problem and your options. I also explained it in my reply above, but since your Mac is running OS X 10.10.5, you also have the option of upgrading to 1Password 5 if you want to.

    If you have more questions about that, please let us know! :)

  • Is it still not working? Mine is not working

  • sjksjk oversoul 1Password Alumni

    Hi @byrdmanlk,

    Could you provide us with some additional information to help us understand exactly what isn't working for you?

    • Which web browser and version of it? Sounds like some version Firefox and we want to make sure. :)
    • Which version of 1Password?
    • Which version of OS X?

    And what specifically doesn't work the way you expect it to? Are you getting any errors? The more details we know the sooner we'll be able to help you resolve this issue. :)

    Thanks in advance!

  • Which web browser and version of it? Firefox 40.0.3
    Which version of 1Password? Version 3.8.22 (build 32010)
    Which version of OS X? 10.8.5

    The browser extension is currently failing to install on firefox

    It has been working just fine then all of a sudden it is gone and when I try to reinstall the extension it does not show up. I even when back to the last version of firefox and still it does not show up.

    Thanks, Mike

  • sjksjk oversoul 1Password Alumni
    edited September 2015

    Those details are helpful, Mike ( @byrdmanlk ) – thanks!

    The answer to your question can be found in several spots in this 1Password 3 for Mac thread, where I've moved your first post and our replies to.

    hawkmoth's reply is one of them:

    Take a look at this article about what is happening with Firefox with respect to 1Password 3.

    Also, from Drew's reply right after that and before your first message:

    The article from the link in hawkmoth's reply should explain the problem and your options. I also explained it in my reply above

    This is the article they've both mentioned:

    1Password 3 extension missing in Firefox 40 or later

    Please let us know if you have any other questions and we'll be happy to answer!

  • Perfect Thank You

  • sjksjk oversoul 1Password Alumni

    You're welcome, Mike! :+1:

  • Mac OS X 109.5
    1 Password 3.8.22
    Firefox 40.0.3
    I don't know what version of 1Password extension. I just need the icon back on my title bar

  • Vee_AGVee_AG 1Password Alumni

    Hi @greenmd and @Deb,

    Our apologies for your trouble with the 1Password 3 extension in Firefox 40. I hope you don't mind, I've merged your thread into this existing conversation in the Legacy: 1Password 3 for Mac forum.

    You may find answers to your question in previous posts on this thread, for example this one from my AgileBits teammate, Drew_AG.

    For your options to work around this compatibility issue, please have a look at the article he linked to. And then we'll be happy to answer any follow-up questions you may have. Thanks!

This discussion has been closed.