1Password triggering 2011 MBP to switch to Discrete graphics

It looks like 1Password is forcing the 2011 MackBook Pro to switch to discrete graphics, even when the software isn't in use (but loaded). Since this causes a significant drain on the battery, and creates a lot of heat, is there a way of disabling the hardware acceleration requirement?

Comments

  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member
    edited March 2011
    Hi noobinator,

    noobinator wrote:

    It looks like 1Password is forcing the 2011 MackBook Pro to switch to discrete graphics, even when the software isn't in use (but loaded). Since this causes a significant drain on the battery, and creates a lot of heat, is there a way of disabling the hardware acceleration requirement?

    We haven't fully been able to determine exactly what is triggering this, but can you go to 1Password > Preferences > Advanced and check the box by "Disable Animations". Please report back to let us know if this resolves the issue.

    Thanks

    -j
  • Looks like that did the trick, thanks!
  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member
    Thanks for the update, noobinator. I'm glad that helped.

    Please continue to post about anything else that comes up.

    Cheers,

    -j
  • mikeboremikebore Junior Member
    jpgoldberg wrote:

    Thanks for the update, noobinator. I'm glad that helped.

    Please continue to post about anything else that comes up.

    Cheers,

    -j


    I have a late 2010 17 inch i7 MBP with auto switching graphics, and disabling animations has not stopped 1Password invoking the discrete graphics card.

    I am using 3.7.5 beta-3 (build 31103) in Lion 10.7.

    Any suggestions?

    Thanks
  • BenBen AWS Team

    Team Member
    Thanks Mike. As Jeff mentioned we haven't yet been able to track this down, but we're working on it.
  • I'm not even sure there's anything that can be done against this. Unfortunately Apple doesn't include a feature in the API to let developers tell the OS that discrete graphics are truly not needed for this operation. The same problem exist(ed/s) for MacHG. I tried a while back to figure it out but nothing...

    The OS just decides itself when it is time to switch the graphics and unless you use something like gfxCardStatus there's no real way to influence it. Imho that's a design flaw on Apple's side and working around it is not that easy...
  • khadkhad Social Choreographer

    Team Member
    edited August 2011
    Limitations in the OS have never stopped us before. <img class=" /> However, you make a good point, Daenney.

    Applications that use advanced graphics frameworks such as OpenGL, Core Graphics, Quartz Composer or others will cause the OS to trigger the discrete GPU. Those are Apple's rules. Disabling animations in 1Password's preferences eliminates the use of the technologies which trigger the discrete GPU. So unless there is a bug in OS X, disabling animations is the solution. <img class=" />
  • Same thing here for many months now with each version still switching my thunderbolt 15" MBP to discrete graphics every time 1password is loaded. Still does it even with disable animation selected in the prefs.
  • jrd4849jrd4849 Junior Member
    The gfxCardStatus app will allow you to force integrated graphics only while on battery. Other options available also.
  • BenBen AWS Team

    Team Member
    Thanks for that jrd4849, this may work for those who disabling animations does not.
  • jrd4849 wrote:

    The gfxCardStatus app will allow you to force integrated graphics only while on battery. Other options available also.

    That's right. But when you have a second monitor attached to your MBP, it switches to Discrete.
  • BenBen AWS Team

    Team Member
    Toon61 wrote:

    That's right. But when you have a second monitor attached to your MBP, it switches to Discrete.


    Just with 1Password, or in general?

    I'd imagine if you are running a 2nd monitor then you are running off AC power, and this is for the most part a non-issue?
  • According to http://codykrieger.com/gfxCardStatus 1password is forcing the use of the discrete graphics on my Macbook Pro running 10.7.1 which causes the battery to move quicker then needed. When I exit from 1password it goes back to the integrated processor. If you have not seen it you might look at http://developer.apple.com/library/mac/#qa/qa1734/_index.html#//apple_ref/doc/uid/DTS40010791

    which gives some docs on how to prevent this. Does not seem like 1password reality needs high performance graphics on a laptop 8-)

    Jeff
  • khadkhad Social Choreographer

    Team Member
    Hey Jeff,

    I merged your post with this existing thread. Please disable animations in 1Password's preferences on the Advanced pane.

    Please also note posts 7 and 8 above:

    http://forum.agilebits.com/index.php?/topic/4115-1password-triggering-2011-mbp-to-switch-to-discrete-graphics/page__view__findpost__p__38531

    If we can be further assistance, please let us know. We are always here to help!
  • I've run into the same problem on my Late 2011 MBP 15". As soon as I launch 1Password, the laptop switches to discrete graphics. It stays that way until I exit 1Password. I've tried disabling animations and it hasn't fixed the problem. For the time being, I can just use gfxCardStatus to force Integrated graphics if I need to, but if there's anything I can do to help you guys track down this issue, let me know.

    -Leigh
  • khadkhad Social Choreographer

    Team Member
    edited December 2011
    What version of OS X and 1Password are you using? I am not able to reproduce this in 10.7.2 running 1Password 3.9.2. I think the problem still exists using 1Password 3.8.x since it is using Snow Leopard dependencies but the bug has been fixed in the Lion-only APIs that we use in 3.9.x.
  • khad wrote:

    What version of OS X and 1Password are you using? I am not able to reproduce this in 10.7.2 running 1Password 3.9.2. I think the problem still exists using 1Password 3.8.x since it is using Snow Leopard dependencies but the bug has been fixed in the Lion-only APIs that we use in 3.9.x.


    OS X 10.7.2, 1Password Version 3.8.13 (build 31233). So you're saying I'll have to upgrade to 3.9.x to fix this issue? Can I do that without having to buy it from the App Store? I don't like the App Store and how it's pushing iPhone-like control onto a desktop computer, and I'd much rather avoid using it if I can.
  • khadkhad Social Choreographer

    Team Member
    1Password 3.9 is only available from the Mac App Store. I don't think that 1Password 3.8 will ever use the Lion-only APIs in which Apple has fixed their bug because 1Password 3.8 still needs to provide support for Snow Leopard. The issue is not in 1Password, but in the OS. The solution was to use the new Lion APIs which is exactly what we have done in 1Password 3.9.

    I'm sorry if that wasn't the answer you were looking for, but please let me know if there is anything else I can help with.
  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member
    I should say that if we can discover exactly what is triggering the graphics switch in 3.8, we will add an option (akin to "disable animations" option) to turn that off. However, we've been hunting for this for a while and still don't have a reliable thing.

    Leigh, it probably won't lead to much but in addition to disabling lock and unlock animations, can you try running 1Password with different layouts (View > Layout). It's a long shot, but it just might help us narrow figure out whether it is something in a particular layout that is getting the OS to think that we are calling for heavy duty graphics.

    Thanks

    -j
  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member
    Just an update. We have a fix in the current Beta (3.8.15 Beta-2) that should get this completely sorted out. I'd really like to hear from people whether this fixes things as well as we think it has.

    Cheers,

    -j
  • Unfortunately, a couple weeks ago I bit the bullet and just bought 1password from the app store, so I'm running 3.9 now. Sorry I didn't see your posts before now (I've been incredibly busy). I'm assuming there isn't an easy way to try downgrading to 3.8? Or can I uninstall 3.9 without it wiping my keychain from Dropbox?
    One small thing I've noticed about 3.9.. if I've already unlocked my keychain before I launch 1password, it doesn't trigger discrete graphics; however, if the keychain is locked when I launch it it will trigger the switch to discrete and won't switch back until I close 1password. This is with animations off.
  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member
    Hi Leigh,

    You can safely uninstall 3.9 and start using 3.8, particularly because you do keep your data in Dropbox. Within 3.8, please go to 1Password > Preferences > Updates and check the box for "include Beta version".

    Note that 3.8 isn't a "downgrade" from 3.9. Improvements in the 3.8 versions will make it into the 3.9 versions and vice versa (except where something is Lion dependent). It's just that 3.9, the Mac App Store version gets updated less frequently (as each update needs to go through an approval process.)

    After you remove 3.9 and install 3.8, 1Password should be able to automatically find your data in Dropbox, but if it doesn't just use the Finder to locate your 1Password.agilekeychain in your Dropbox folder and double click on that.

    I'm sorry for the extra trouble this has caused, but I do think that having made the purchase through the MAS will help you out in the long run.

    Cheers,

    -j
This discussion has been closed.