ReadItLater and 1Password AddOn for FF4 trouble

Hey guys,

I'm would like to use the ReadItLater (RIL) and the 1Password addon for Firefox 4. However only one of them works at a time. When both are running and I try to change anything in the setting of RIL, I get the following error msg:

Oh no! There was an error saving your settings.

You can get help at readitlaterlist.com/support/

Error: [Exception... "'[JavaScript Error: "domWin is not defined" {file: "chrome://osxform/content/onepasswd.js" line: 1046}]' when calling method: [nsIPromptService::alertCheck]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: jar:file:///Users/maehmann/Library/Application%20Support/Firefox/Profiles/0ml9i3wv.default/extensions/[email protected]!/components/RILdelegate.js :: <TOP_LEVEL> :: line 587"  data: yes]


It also seems that no articles can be synced until I turn off the 1Password addon.

From the error message I guess that it is rather a problem of 1Password than from RIL. How do you see that?

Any help is appreciated.

Cheers,

Christoph

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, Christoph. I'm sorry that you are having this problem.

    I am running the ReadItLater extension in Firefox without error, but I am also using the latest beta version of 1Password (3.6.0.BETA-2) which resolves some Firefox 4 issues for a small number of users.

    Please check the box to "Include Beta versions" in 1Password (Preferences > Updates), and then click the "Check Now" button.

    Once you have installed 1Password 3.6.0.BETA-2 and restarted, please let me know if the issue persists.

    Thanks!
  • khad wrote:

    Welcome to the forums, Christoph. I'm sorry that you are having this problem.

    I am running the ReadItLater extension in Firefox without error, but I am also using the latest beta version of 1Password (3.6.0.BETA-2) which resolves some Firefox 4 issues for a small number of users.

    Please check the box to "Include Beta versions" in 1Password (Preferences > Updates), and then click the "Check Now" button.

    Once you have installed 1Password 3.6.0.BETA-2 and restarted, please let me know if the issue persists.

    Thanks!


    Hey.

    I tried using the BETA-2 add-on but without success. I still have the same troubles as before. I tried to remove all settings from about:config for the RIL add-on, but also with no success.

    Maybe it has to do with the Master password of FF4. Since I'm still using my old passwords before 1Password.

    Christoph
  • khadkhad Social Choreographer

    Team Member
    To help us track down the issue more quickly, could you please email us your Diagnostics Report? To generate the report from 1Password on your Mac, open 1Password and select Help > Troubleshooting > Diagnostics Report. Then attach the entire file to an email to [email protected]

    Please include a link to this thread in order that we might more quickly "connect the dots" when we see your Diagnostics Report in our inbox.

    Please do not post your Diagnostics Report in the forums, though.
  • Hey.

    I did send you the diagnostics report. Let me know if you want me to test anything.
  • khadkhad Social Choreographer

    Team Member
    Thanks for sending that, Christoph!

    We will reply via email as soon as possible.
  • I tried the latest Beta too and the problem still exists. I played around a bit more and found out the following:

    The problem only is present if I use a Master password in FF. With no Master password it works. The other possibility to get it working is to disable the Maser passsword, go to the RIL setting under Advanced and disable „store password securly“ (which I actually don’t want) and then reenable the Master password in FF.

    So, I found a work around, which I’m not happy about. But it works for now.

    Please keep trying to find a solution for that. But with the latest developments I'm not sure any longer if this is really a 1Password problem.

    Christoph
  • khadkhad Social Choreographer

    Team Member
    Thanks for the update, Christoph. To keep us from duplicating efforts, we'll continue to reply via email until this is resolved. :-)
This discussion has been closed.