Checkbox "Automatically Submit Logins After Filling" doesn't stick

Options
raphaelschaad
raphaelschaad
Community Member

In the Mac app's preferences, the checkbox "Automatically Submit Logins After Filling" doesn't stick. Instead, when checking it I get following pop up (screenshot #2):

When 'Cancel'ing, the checkbox gets unchecked. What to do? Thanks!


1Password Version: 5.3
Extension Version: Not Provided
OS Version: OS X Yosemite
Sync Type: DB

Comments

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    Hi @raphaelschaad,

    I'm sorry you're having trouble enabling the "Automatically submit logins after filling" option. Thank you for the screenshots, they're really helpful for us!

    The reason you're being asked to select a script folder is because you're using the Mac App Store version of 1Password, and restrictions on the Mac App Store prevent us from automatically installing a script we use for the auto-submit feature.

    Normally you would need to select the folder shown in the path at the top of that window. However, it looks like your ~/Library/ folder is hidden on your Mac (which is the default setting in newer versions of Mac OS X). But don't worry, there's actually a trick to make this very easy:

    • Click Select Script Folder when asked to select a folder.
    • Click OK on the "Wrong Script Folder Selected" error.
    • Click Select Script Folder again.
    • If you get the error again, click OK and then click Select Script Folder one more time.

    The script folder should be created and selected for you, so when you click Select Script Folder the final time, it will give you a message saying "The auto submit script was installed successfully" and the option will be enabled in the 1Password settings.

    We're working on making this easier and clearer in the future. I'm sorry for the confusion about that! Hopefully this helps, but if you're still having trouble with that or have more questions, please let us know. :)

    ref: OPM-2999

  • raphaelschaad
    raphaelschaad
    Community Member
    Options

    Resolved my issue perfectly. Thank you!

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    You're very welcome! I'm glad that helped. If you need anything else, we're here for you!

This discussion has been closed.