1Password on Mastodon

1Password for iPhone: Dropbox sync stopped working

edited April 2011 in iOS
"Dropbox sync failed to obtain the list of remote data objects.
Recently my 1Password for iPhone stopped syncing with Dropbox. It errors out with the following error message:

Dropbox sync failed to obtain the list of remote data objects.

I noticed the issue today, but it probably stopped working a couple of days ago. Specs:

  • 1Password for iPhone 3.5.7.
  • 1Password for Mac 3.5.9.
  • iOS 4.3.2.

I tried the following:
  • Cleared the application cache
  • Removed 1Password for iPhone, rebuilt the data file on my Mac, reinstalled 1Password for iPhone
  • Restored data file to a backup date on which I am certain that syncing worked without a problem
  • Reset all data on 1Password for iPhone
  • Reset Dropbox syncing on 1Password for iPhone

None of this seems to work -- it keeps casting the same error message over and over again. I'm temporarily syncing my data files over WIFI, but I'd like to switch back to Dropbox syncing. Is there anyone who knows what happened?


  • edited April 2011
    I seem to have fixed the problem by removing the 1Password.agilekeychain file and creating a new one using 1Password for Mac. I reset the Dropbox sync on my iPhone afterwards, which worked: it started syncing back all my stored items to my Mac into my new keychain file.

    I'm still not sure what caused the syncing problems, but at least this is a "fix".
This discussion has been closed.