Can't disable auto submit

Options
rogued
rogued
Community Member

Hey there.

I am running 1Password Version 5.3 (530029) Mac App Store on 10.10.5, and despite disabling auto submit in the preferences screen, sometimes it still autosubmits. This is in Safari version 8.0.8 (10600.8.9)

Is there anything I can do?

This is happening on two of my systems, and the other is running 10.10.4.

Thanks in advance,
rogued


1Password Version: 5.3 (530029)
Extension Version: 4.4.2
OS Version: 10.10.5
Sync Type: Dropbox
Referrer: kb-search:auto submit

Comments

  • Stephen_C
    Stephen_C
    Community Member
    Options

    Are you sure it's 1P that's auto-submitting and not something previously saved in the OS X keychain by Safari?

    Stephen

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Greetings @rogued,

    Can I also enquire, how do you normally fill in 1Password and if it's by using a keyboard shortcut are you using the default keyboard shortcuts or have you tweaked them to a different combination better suited to your tastes?

  • rogued
    rogued
    Community Member
    Options

    @Stephen_C I do not let anything auto submit, but it could be a potential conflict.

    @littlebobbytables Yes, I usually press CMD-\ to fill it in, and that's the default.

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    Hi @rogued,

    Thanks for clarifying! So, if I understand, you go to a website with a login form in Safari, then you use the ⌘\ keyboard shortcut for the 1Password extension. The extension fills your username and password, and then it automatically submits the login form - but you don't want it to. Is that all correct?

    If so, can you please double-check a setting in 1Password:

    • Open the main 1Password app and go to 1Password > Preferences in the menu.
    • Click the Browser tab.
    • Make sure "Automatically submit logins after filling" is disabled (un-checked).

    If that setting is already disabled, there is another setting you can check:

    • In the main 1Password app, find one of the Login items that still auto-submits.
    • Click the Edit button for that item.
    • Change the "submit" setting (near the bottom of the item details) to Never submit.
    • Click Save.

    Now try using that Login item from your browser. Does it still automatically submit the login form after filling your username/password?

  • rogued
    rogued
    Community Member
    Options

    @Drew_AG it looks like I'm going to need to do some more detailed research to figure it out. Next time it happens, I'll note down which login it is and do testing on that.

    Thanks for all the help guys, I'll see if the issue crops up again then post back here.

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    You're very welcome @rogued! I hope this helps. It can be difficult to figure these things out when the problem doesn't consistently happen. Let us know when it happens again and how it all goes! :)

This discussion has been closed.