Sync broke on one of my Macs

Options
duetjohn
duetjohn
Community Member

Syncing for both of my vaults broke on OS X. Here are some log messages I see when I try to reenable syncing. I've got all my data on other systems, so I would just like to know how to get back to having this system get the current data—as well as provide any info to help if there's anything for you to debug.

9/14/15 12:41:05.014 PM sandboxd[192] ([9887]) QuickLookUIHelpe(9887) deny file-read-data /Users/john/Dropbox/1Password/1Password.agilekeychain
9/14/15 12:41:06.323 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] SQLite: database corruption at line 73972 of [2ef4f3a5b1]
9/14/15 12:41:06.323 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] SQLite: statement aborts at 12: [DELETE FROM sync_sources WHERE profile_id=? AND id <> ?]
9/14/15 12:41:06.323 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] 532001 [SQLITE:0x7fcfd12cacc0:] E update:error:applyBindings: | Update failed 'DELETE FROM sync_sources WHERE profile_id=? AND id <> ?': database disk image is malformed
9/14/15 12:41:06.323 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] SQLite: database corruption at line 62795 of [2ef4f3a5b1]
9/14/15 12:41:06.323 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] SQLite: statement aborts at 5: [INSERT INTO sync_sources (profile_id, location_type, keychain_type, remote_profile_uuid, remote_profile_timestamp, remote_profile_blob, local_profile_uuid, local_profile_timestamp, local_profile_blob, id) VALUES (?,?,?,?,?,?,?,?,?,?)] database disk image is malformed
9/14/15 12:41:06.323 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] 532001 [DATABASE:0x7fcfd12cacc0:] W txUpdateSyncSource:error: | Unable to delete sync sources: (null)
9/14/15 12:41:06.323 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] 532001 [SQLITE:0x7fcfd12cacc0:] E update:error:applyBindings: | Update failed 'INSERT INTO sync_sources (profile_id, location_type, keychain_type, remote_profile_uuid, remote_profile_timestamp, remote_profile_blob, local_profile_uuid, local_profile_timestamp, local_profile_blob, id) VALUES (?,?,?,?,?,?,?,?,?,?)': database disk image is malformed
9/14/15 12:41:06.325 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] SQLite: database corruption at line 62795 of [2ef4f3a5b1]
9/14/15 12:41:06.325 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] SQLite: statement aborts at 13: [SELECT id, profile_id, location_type, keychain_type, remote_profile_uuid, remote_profile_timestamp, remote_profile_blob, local_profile_uuid, local_profile_timestamp, local_profile_blob FROM sync_sources WHERE profile_id=?] database disk image is malformed
9/14/15 12:41:06.325 PM 2BUA8C4S2C.com.agilebits.onepassword4-helper[640] 532001 [HELPER:0x7fcfcd00cae0:] E profileSyncMustBeDisabled: | Disabling sync for because of the error: Error Domain=com.agilebits.onepassword.ErrorDomain Code=256 "1Password will no longer sync because no sync source was found for profile." UserInfo={NSLocalizedDescription=1Password will no longer sync because no sync source was found for profile.}


1Password Version: 5.3.2
Extension Version: 4.3.1
OS Version: 10.11
Sync Type: Dropbox

Comments

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    @duetjohn: That doesn't look good at all. The QuickLook errors indicate that there are permissions issues, and the 1Password errors indicate that the data is corrupt. Both may be caused by disk or file system issues, so be sure to back up your data before you do anything else. And then boot from the OS X recovery partition and repair the disk to see if that resolves the issue.

    If you're still having trouble, the best thing to do will be to generate a diagnostic report and send it to support+forums@agilebits.com so we can look at the logs to determine exactly what is happening:

    Sending Diagnostics Reports (Mac)

    Just be sure to include a link to this forum thread and your username in the email so we can 'connect the dots'. Thanks!

  • duetjohn
    duetjohn
    Community Member
    Options

    I ran Disk First Aid and also did the permissions repair in the troubleshooting tool. Problem still persists. I sent in a diagnostic report.

  • Vee_AG
    Vee_AG
    1Password Alumni
    Options

    Thanks, @duetjohn. Someone on our support team will look over the report and get back to you soon. :+1:

    ref: MWA-83592-626

  • duetjohn
    duetjohn
    Community Member
    Options

    Any update? I really want to just start over on this Mac and sync what's in the cloud.

  • Vee_AG
    Vee_AG
    1Password Alumni
    Options

    Hi @duetjohn,

    Yes, Laura replied to your email two days ago. Did you not receive it? She sent it to your @apple.com email address because that's the address your Diagnostics Report came from. I'll go ahead and forward her reply to the email address registered to your forum handle. Let us know if you still don't see it!

This discussion has been closed.