1Password has stopped recognising a special character in the master password.

Options
clanbrassil
clanbrassil
Community Member

I'm using 1Password 5.3.2 on an iMac, 27-inch, late 2013, 3.5GHz Intel Core i7, running 10.10.5 with 24GB memory. I have run the software successfully for over a month. Last week I changed the master password and kept a copy of it in a separate file. Not only do I have a problem with the special character, but pasting the password from the copy that I kept does not work either. I also have a MacBook Air (13 inch, mid-2011, 1.iGHz Intel Core i7, running 10.10.3 with 4GB memory. On the MacBook Air 1Password recognises the password, and will allow me open the app. But it does not recognise the same password when I type it in to reset the password. I thought I was being clever by choosing a password of characters all using the Option key. What happens now is that when I try to type the character Option-e, the iMac beeps, and does not add any character. The MacBookAir accepted the character and opened the app. But when I go to Preferences to change the password, even though I have successfully used the existing password to open the app, I get a beep when I'm typing in the app's Preferences. The issue may be related to the fact that I was out of town over the weekend, and working with the MacBook Air. The problem arose the first time I attempted to access 1Password on the iMac after my return. Any help would be greatly appreciated.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: kb:special-characters-in-master-password

Comments

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    @clanbrassil: 1Password won't cause your Mac to 'beep' as you describe. This is the OS itself telling you there is an input problem. You may simply have the wrong keyboard layout set, or some modifier key needs to be toggled. Your guess will be better than mine though, since it's your Mac!

    And this is also part of the reason that we recommend using only ASCII characters in your Master Password, because simply changing platforms — or even localization settings on the same system — can result in the inability to enter the Master Password correctly.

    Please try the steps in this guide to see if it helps with entering your Master Password, but failing that you may need to restore from a backup prior to your changing the Master Password to something difficult to enter. Difficult to guess is a much better target to shoot for. ;)

  • clanbrassil
    clanbrassil
    Community Member
    Options

    Thanks. I solved the problem. But it was a 1Password setting, not a system setting that made it possible. Toggling the "conceal passwords" option from on to off in 1Password's Security preferences allowed me to type the problem character successfully. Could this be a bug in 1Password? My recollection is that I had set "conceal passwords" to off on the iMac (on which I created the master password), and never touched it on the MacBook Air. Could the fact that I used the MacBook Air have caused the setting to revert on the iMac? And, if so, why wouldn't the iMac setting have affected the MacBook Air first?

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    Hi @clanbrassil,

    I'm glad to hear it's working for you now! However, the "Conceal Passwords" setting shouldn't have anything at all to do with typing your master password. The master password field is always concealed, regardless of the "Conceal Passwords" setting. That setting only applies to password fields in the items contained in your 1Password vault.

    The master password field is a standard NSSecureTextField, which we don't really have much control over. It's a feature provided by Apple, and is separate from our feature to conceal password fields in your vault items.

    Now, one thing you can do to test that is to re-enable the "Conceal Passwords" setting. When you do that, do you have the same problem typing your master password?

  • clanbrassil
    clanbrassil
    Community Member
    Options

    Hi Drew_AG Now that I've successfully changed to a non-problematic master password, I don't want to go through the whole rigmarole of changing back to a problematic one again. I did, however, try typing the old password into the change master password preferences pane. At the moment I can't type the original, offending password, no matter how the Conceal Passwords option is set. The problem could be to do with a system update. Updates seem to restore certain defaults without notice or even option. I used to be able to type the German character ß with Option-S. Now I have to do it IOS-style. I suspect the solution to the original problem is somewhere in that neck of the woods.

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    @clanbrassil: Indeed! I think you may be right about that. Unfortunately AgileBits as 3rd party developers doesn't have any real insight into Apple's iOS APIs, but we'll continue to investigate this and report any findings to Apple. iOS and OS X are generally good (as far I've seen) when it comes to international support, but there will always be room for improvement — and, of course, bugs. Thanks again for bringing this up!

  • @clanbrassil Would this sound happen to be your OS X alert sound? If it is, or maybe even if it isn't, try opening up Console, either by using Spotlight to search for it or by heading to /Applications/Utilities and double-clicking it in Finder. Then input the nefarious character into the 1Password field and check the Console for an error log or anything that happens when you type it. Let me know what the developments are. ;)

  • clanbrassil
    clanbrassil
    Community Member
    Options

    Hi Brenty & penderworth It gets curiouser and curiouser. There's no apparently related message on Console. I can try typing the letter any number of times and there will be no message. But . . . while doing the typing, I did try typing the original, offending password into the Password Hint box in 1Password's preferences, and I can type it there with no problems.

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    @clanbrassil: Very strange indeed. I wonder if another app might interfere with input. I use TextExpander and occasionally it gets hung up and causes some strange keyboard behaviour...but generally a relaunch or restart clears that right up. Apart from an input problem caused by another app or something in OS X itself causing a glitch I can't imagine what the cause could be. :unamused:

This discussion has been closed.