1PasswordAnywhere not working with Dropbox [Resolved: usage issues with Chrome 45, Firefox 41]

edited October 2015 in Lounge

Hello, all the problems mentioned in the post above are back since today. I cannot use 1PasswordAnywhere on my Chromebook. Just to let you know.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Version 45.0.2454.98 (64-bit) Platform 7262.57.0 (Official Build) stable-channel swanky Firmware Google Swanky.5216.238.5
Sync Type: Dropbox
Referrer: forum-search:1PasswordAnywhere not working with Dropbox [2015-08-07: working again; fix deployed by Dropbox]



  • brentybrenty

    Team Member

    @derkai3: Hmm...I just tried it here and it's working for me in Safari 8.0.8 on OS X Yosemite...but Firefox 41 and Chrome 45 have the issue you're describing for some reason. I'm sorry for the inconvenience. We'll investigate this to figure out what's going on there!

  • Good that you were able to reproduce the error and thank you for looking into it. And thanks a lot for the speedy reply. Great customer service!

  • sjksjk oversoul 1Password Alumni

    On behalf of @brenty, you're most welcome. And we appreciate your kinds words – thanks! :)

    Using 1PasswordAnywhere with Firefox 41 and Chrome 45 is still troublesome and we are continuing to investigate. Again, sorry for any inconvenience this is causing you!

  • I've been using 1Password Anywhere on my Chromebook for over a year. It's pretty awkward to use but it was the only rational way to access my passwords when I'm working.

    Sometime in the last few days it has stopped working altogether. I wondered if it was specific to the Chromebook so I tried accessing 1PA on my Mac using Chrome 45.0.2454.101 (64-bit) and got the same results.

    "A problem occurred when loading [full-web-path]/encryptionKeys.js"

    I repeated the test in Firefox 40.0.2 and Safari 8.0.8:

    Firefox - same problem loading keys.

    Safari - worked fine, loaded 1PA page and gave me access to passwords.

    Any thoughts on this?

    1Password Version: 5.3.2
    Extension Version:
    OS Version: OS X 10.10.5
    Sync Type: Not Provided

  • Drew_AGDrew_AG 1Password Alumni

    Hi @weavermedia,

    I've merged your post with an existing thread about this issue in our "Lounge" forum. I hope you don't mind!

    Thanks for taking the time to report this problem. As you can see from some previous replies here, we started hearing about this issue today and we're currently investigating it. I'm afraid I don't really know anything more right now, but we'll try to post something here as soon as we have more information. I'm sorry for the inconvenience!

  • One month later the same issue again. WTF. So annoying.

    When are we getting GOOGLE DRIVE compatibility? Why am I paying for this software again?

    You guys posted about G Drive years ago, yet, no results. smh.

  • Thanks @Drew_AG, I did do a search before I posted but it didn't show any recent related entries.

    Just in case it helps - I also tried opening the 1Password.html Dropbox file locally from my file system.

    Failed in Chrome, freaked out in Firefox (that may be my insane privacy settings in FF), worked fine in Safari.

  • brentybrenty

    Team Member

    @weavermedia: Indeed, Firefox and Chrome are very strict in this regard and simply don't allow local filesystem access to webpages (such as 1PasswordAnywhere). I don't believe that Chrome and Firefox have received updates in this timeframe, and we certainly haven't updated 1PasswordAnywhere. But if it were a Dropbox issue, I'd expect it to be broken in Safari as well...

    We're looking into this, but frankly it doesn't make any sense that it would work in Safari but not Chrome or Firefox from the Dropbox website. Previously when Dropbox made some changes on the server side it predictably broke the ability for all browsers to load external files...and they were able to resolve this with a patch. Unfortunately I don't have anything new to report at this time, but we'll keep you posted.

  • brentybrenty

    Team Member

    When are we getting GOOGLE DRIVE compatibility? Why am I paying for this software again?

    @FA1LURE: To be clear, you didn't pay for Google Drive support (and there's absolutely no need to pay for 1Password on an ongoing basis; your existing license never expires). 1Password has never supported Google Drive, so in that regard it is working as intended. We may add that in the future, but until they improve their OS X client I won't be jumping back on that bandwagon myself. :lol:

    It sounds like the issue you're having is 1PasswordAnywhere being unable to access encryptionkeys.js in Dropbox using Chrome or Firefox. Is that correct?

    We're investigating that issue. Curiously, it's still working in Safari, so you can use that as a workaround in the mean time.

    edited September 2015

    Except I have to pay for upgrades. heh.

  • edited September 2015

    Thanks for the update @brenty.

    I've just been messing around with, waiting for dinner to cook :)

    Trying to access the keys file directly in the browser from Dropbox gives a 403 Forbidden error and suggests I sign in (I'm already signed in to Dropbox). Clicking on the file takes me to this address and the 403 page displays:

    If I copy the keys file to the top-level Dropbox folder via the Dropbox web interface I can access it and see the contents. Clicking on the copied file takes me to this address and shows the contents:

    Could this be something to do with the way Dropbox is allowing access to JS files in certain folders?

    The consistency with the way that browsers deal with local files seems interesting too. Chrome and Firefox both fail with local files and 1PA. Safari works with local files and 1PA.

    Could Dropbox be enforcing some kind of local-file-access parity with web files?

  • Now I'm really confused. Clicking on the keys file again takes me to a preview page this time, and shows the contents of the file.


    This URL is different to the one I got earlier from clicking on the same file.

    Maybe Dropbox are in the middle of something?

    Time for my dinner :)

  • HI Erin,

    I am having the same problem - "A problem occurred when loading the "https://dl-web.dropbox.com/get/1password/1Password.agilekeychain/data/default/encryptionKeys.js" file."

    I use 1password 4 on my MBP 15 running mountain lion - and using chrome browser ( also iphone 6).

    I have encryptionKeys.js file now and permissions is read write. But still get same encryptionKeys.js error message.

    i have done all the steps you suggested except the final one (deleting the agile keychain). I prefer to do that as a last resort.

    four things:

    1) i was reading a different thread for PC that said dropbox had an issue that caused the problem in august and last year but got resolved. Could that be my problem?

    2) has the final step resolved issues for everyone?

    3) if so,can we get a good step-by-step? (the fix pointed to when you try to use 1paswordanywhere is not good for the mac and it only has you check permissions)

    4) 1password is my life for about 10 years (or from way back when you started). I like how you used to be able to print an encrypted pdf of all your 1password content. How do we get an offline version we can use and store that on our dropbox for emergencies and for when we have the 1passwordanywhere access issues?

    thank you!

  • brentybrenty

    Team Member

    Except I have to pay for upgrades. heh.

    @FA1LURE: Nah. Upgrades are optional, and sometimes we don't even charge for them! ;)

  • brentybrenty

    Team Member

    If I copy the keys file to the top-level Dropbox folder via the Dropbox web interface I can access it and see the contents. Clicking on the copied file takes me to this address and shows the contents:

    @weavermedia: Definitely a bit confusing, but there's a simple explanation for this: the browser (and Dropbox) will always be okay with loading the encryptionkeys.js (or any) file directly, since that's just what browsers are for after all. However, where you run into issues (depending on the browser's security model) is when one file tries to load another — in this case 1Password.html needs to load encryptionkeys.js to be able to decrypt the items in your vault (which are themselves separate files). So it's expected that any individual file will load, but Dropbox has been unique in that their site would allow 1Password.html to load other files on the fly. And that's what makes it so perplexing that it would still work in Safari from the website but not the others... :(

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    We're in touch with Dropbox to see what they can do for us like last time but it is likely we might not be able to use 1PasswordAnywhere as it is anymore. If that is the case, we'll let you guys know.

    Note this is simply the CSP rule blocking unsafe scripts from running on the domain, Dropbox is in its right to ensure security on their site. If we can't get this working, we will need to work on a proper solution that complies with the security policies in place, which we plan to.

  • Hi @Dr_Wayne,

    I've just merged the thread with another as both were specifically about 1PasswordAnywhere and the current issues everybody is experiencing. We're in communication with Dropbox at the moment to try and better understand the complete picture. At that point we'll better understand and now how to proceed but it's hard to say anything concrete just yet.

  • Dr_WayneDr_Wayne
    edited September 2015

    Thanks for your quick post to this important issue Erin.

    I'm happy to see you'll be addressing this with Dropbox.

    In the interim - Can you address my 4th query?

    4) I like how you used to be able to print an encrypted pdf of all your 1password content. How do we get an offline version we can use and store that on our dropbox for emergencies and for when we have the 1passwordanywhere access issues?

  • Btw - it does not work with safari either - at least for me.

  • Additionally - 1passwordanywhere does not work with my iPhone 6 running iOS 8

  • I use 1 PasswordAnywhere quite a bit and I've never had an issue until today at work. I mean at least 2 years (probably more) w/o issue.

    Chrome/Yosemite. Got the "Problem loading 1Password data file" message. Reset things, cleared the Chrome cache, rebooted - nothing fixed it. iOS - no issue (at least I could get at my passwords).

    Safari: NO ISSUE.

    At home on my Mac (Chrome/Yosemite): Same problem.

    So I deleted the keyfile from Dropbox and re-sync'd (had to pretend to delete what was already deleted - I digress...)
    Sync'd and tried again. Same problem.

    Safari - no problem.

    But I work in Chrome all of the time and would prefer 1PasswordAnywhere just worked as it always has.

    (And yes, I checked permissions - no issue - it is read-write in the Dropbox).

    Why would this suddenly bork on two separate computers ....

  • Hey Guys,

    Same issue for me. It just stopped working. Chrome OS & Dropbox. Please help! The desktop 1Password app is the only thing I miss about my Macbook. Please make a Chrome OS app.

  • edited September 2015

    This is happening to me as well. The path to the url is correct. I went into dropbox and downloaded the encryptionKeys.js file and saw > that the url was the same except there were added parameters after the ? defining the following parameters:

    It seems as if removing these parameters (which is what the 1password everywhere html page seems to be doing) makes Dropbox return a 403 error

    That is exactly my conclusion as well.

    This is a seriously annoying issue for me right now, because as of a year ago my primary home computer runs Linux. I've been tolerating the hassle of only read-only access to my passwords on Linux through 1Password Anywhere, because I don't create new user accounts very often, but if I can't even get read access to my passwords anymore through Linux then maybe it's time to abandon 1Password for a competitor which takes Linux support seriously.

  • Another vote - Dropbox related-1Password Anywhere while using Chromebook. Same error as above.

  • brentybrenty

    Team Member

    @BitGuy: I'm sorry for the inconvenience. Hopefully we'll be able to find some solution or workaround, but at this stage it's hard to say when that might be. We'll continue to update here.

  • brentybrenty

    Team Member

    Merging everyone into a single thread in Lounge about this cross-platform issue, since it doesn't pertain to 1Password for Mac, Windows, etc., and also so folks who posted three months ago aren't suddenly getting notifications. ;)

    1PasswordAnywhere is still working in Safari on both OS X and Windows, but it no longer works in Firefox and Chrome.

    Additionally - 1passwordanywhere does not work with my iPhone 6 running iOS 8

    @Dr_Wayne: 1PasswordAnywhere didn't ever work in Mobile Safari, as it's always had tight security restrictions.

    I like how you used to be able to print an encrypted pdf of all your 1password content.

    To be clear, anything you print is no longer encrypted. But you can print out your data from the File menu in 1Password for Mac. It just isn't something we'll ever recommend, since even printers often store a copy of data that passes through them.

  • I'm seeing all of these same problems. 1Password continues to work great on my Macs, iPhone, and iPad, with the data synced by Dropbox, but I'm unable to use 1Password Anywhere on my Chromebook or Linux workstation. This is especially annoying on the Chromebook, as the entire point of that device is to access the web, but being unable to use my password vault means a lot of typing of difficult-to-type/impossible-to-remember passwords.

  • @brenty, Since 2008 or so, the PDF format has had the ability to be encrypted using strong encryption (Acrobat 8 did AES-128 and Acrobat 9 did AES-256). https://blogs.adobe.com/security/2008/12/acrobat_9_and_password_encrypt.html

    I think what @Dr_Wayne is asking for is for PDFs secured that way to be generated by 1Password. It looks like it might be possible on a Mac by using Print::Save as PDF... and clicking on the Security Options on the resulting dialog box. I don't know anything about the actual security of Mac PDFs saved in this way, earlier Acrobat PDF (version 5+?) appear to have used RC4 encryption.

  • Dr_WayneDr_Wayne
    edited September 2015

    Yes, thanks for clarifying for me @alanhoyle - I wasn't referring to paper printing (that would defeat the whole purpose of not writing passwords down, I would think), but rather making a PDF. But with something usable. The current export solution is messy (tab or comma delineated only). If there was something usable (prettier?) for situations like this - and I can encrypt it myself - that would be helpful. Especially as we only know when there is a problem with using the Dropbox html when we try to use it. Which is rare for me. What do I do if I'm traveling and lose my computer and phone? Scary. Which is why I went to check on my options and found the problem.

    Re safari - it is working now, interestingly. Erin's fix must have done the trick (changing master password). Thanks!

  • caeuscaeus
    edited September 2015

    Well, as I couldn't find any user final way to fix it, I fixed it myself, and I think It'd be a good idea to say how I did it.
    I opened the file 1password.html with a text editor and searched for a function called fullKeychainFilePath (line 2975) and added some stuff.
    It looked originally like this:

    function fullKeychainFilePath(filename) {
    return top.keychainFolder + "data/" + top.current_profile + "/"+filename;

    now it looks like this

    function fullKeychainFilePath(filename) {
    return top.keychainFolder + "data/" + top.current_profile + "/" + filename+window.location.search;

This discussion has been closed.