1PasswordAnywhere not working with Dropbox [Resolved: usage issues with Chrome 45, Firefox 41]



  • @caeus - I tried your solution, and it works!! Happily using it from Chrome browser, Chromebook and Linux box!

  • brentybrenty

    Team Member

    @brenty, Since 2008 or so, the PDF format has had the ability to be encrypted using strong encryption (Acrobat 8 did AES-128 and Acrobat 9 did AES-256).

    @alanhoyle: Indeed!

    Yes, thanks for clarifying for me @alanhoyle - I wasn't referring to paper printing (that would defeat the whole purpose of not writing passwords down, I would think), but rather making a PDF.

    @Dr_Wayne: Ah, understood! You're just trying to have a contingency plan. I'd thought you were trying to print everything out, but an encrypted PDF makes more sense. This is built into OS X, and can simply be used from the Print feature in 1Password (or any other app):

    1. Select All Items in the 1Password sidebar,
    2. then go to File > Print,
    3. click the dropdown in the lower lefthand corner,
    4. select Save as PDF,
    5. click the Security Options button,
    6. check Require password to open document,
    7. set a password and click OK,
    8. select a location and click Save.

    Well, as I couldn't find any user final way to fix it, I fixed it myself, and I think It'd be a good idea to say how I did it.

    @caeus: I'm going to continue testing it in various browsers to see if this might serve as a workaround across the board until we can issue an update. Thanks for sharing that! :)

  • alanhoylealanhoyle
    edited September 2015

    @caeus has a (the?) solution: add "+ window.location.search"to the fullKeychainFilePath function.

    The following diff works for me on OSX 10.10 (Chrome 45, Firefox 41, and Safari) and the current ChromeOS 46 (beta, haven't tested stable).

    $ diff 1Password.html 1Password\ original.html
    <   return top.keychainFolder + "data/" + top.current_profile + "/" + filename + window.location.search;

    return top.keychainFolder + "data/" + top.current_profile + "/" + filename;

    Thanks so much @caeus !

  • @brenty Before suggesting OSX's built-in Print to PDF function for encryption, there should really be some research done into the encryption used. I can't confirm for myself, and the latest things I've seen are from at least a couple years ago, but I've seen at least two references that indicate that the built-in encryption uses relatively weak RC4 encryption (which I think is considered deprecated if not actively insecure?).

  • brentybrenty

    Team Member

    @alanhoyle: Sorry for the confusion. I don't recommend exporting data out of 1Password at all. We don't have any control over the security of anything else. I was merely pointing out that the option is available, since it was requested. Of course it's possible to use other apps to encrypt data (PDF or otherwise) outside of 1Password, but that isn't something we can support.

  • Fantastic. It's been awhile since I checked this thread. I tried the suggested fix and it appears to work.

  • I use the following 1Password versions on the following devices:

    • 5.3.2 on iMac; OS X Yosemite 10.10.5
    • 6.0.1 on iPhone 6s; iOS 9.0.1

    As of today, I am unable to login to either one of my two 1Password vaults via the Dropbox website. The last time I successfully logged into the vaults via the Dropbox website was on Thursday, September 24th. When I attempt to login to either vault, I receive the following error:

    I clicked OK, attempted to login, and followed the troubleshooting steps. Everything checks out.

    I tried logging in using Chrome 45.0.2454.101 (64-bit) on Mac, Chrome 44.0.2403.157 m (64-bit) on Windows, and Firefox 41.0 on Windows. The same issue occurs in each browser.

    In an attempt to resolve the issue, I performed the following steps from 1Password for Mac:

    1. Disabled Dropbox sync and deleted the data for each vault.
    2. Enabled Dropbox sync for each vault.
    3. Waited for Dropbox to complete syncing.
    4. Synced 1Password for iOS with each vault.
    5. Confirmed everything was working on both the Mac and iPhone.
    6. Attempted to login to each 1Password vault via the Dropbox website and encountered the same error.

    1Password Version: 5.3.2 (Mac); 6.0.1 (iOS)
    Extension Version: Not Provided
    OS Version: OS X 10.10.5; iOS 9.0.1
    Sync Type: Dropbox

  • MeganMegan

    Team Member

    Hi @brucenye,

    I'm glad to hear that the fix worked for you! Thanks for letting us know.

  • "The" solution worked for me :) Thank you so much @caeus !

  • brentybrenty

    Team Member

    Thanks for letting us know! Hat tip to caeus. :pirate:

  • Drew_AGDrew_AG 1Password Alumni

    Hi @DavidLevine,

    I'm sorry you've been having trouble with 1PasswordAnywhere! I hope you don't mind, but I've merged your message into an existing thread about this issue. This problem started several days ago for everyone trying to use 1PasswordAnywhere from the Dropbox website in Chrome or Firefox. I don't know the exact cause, however it should be fixed as of last night (you won't need to try the workaround mentioned earlier in this discussion). If you haven't already done so, please try again, and it should work correctly for you now.

    Hopefully you're all set, but if you're still having a problem trying to use 1PasswordAnywhere (or if you need anything else), please let us know. Thanks! :)

  • Drew_AGDrew_AG 1Password Alumni

    @DavidLevine, I accidentally replied to your message before merging it with this thread, so I wanted to reply again just to make sure you get a notification that takes you to the right place. Sorry for any confusion! :)

  • @Drew_AG, Thanks for the update. I successfully logged into both of my vaults via 1PasswordAnywhere. Glad everything is working again.

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. I'm glad to hear all is well! :)

  • Working again! Thanks for fixing. Please make a real Chrome OS App. I would pay for that and be happy to do so.

  • sjksjk oversoul 1Password Alumni

    Thanks for confirming 1PasswordAnywhere works for you again, @BitGuy. Plus the 1Password for Chrome OS app vote. :+1:

  • 1PA is working fine for me now.

    Mac OS X 10.10.5 & Chrome Version 45.0.2454.101 (64-bit)

    Chromebook 7262.57.0 Swanky & Chrome Version 45.0.2454.98 (64-bit)

    Was this a fix by you guys or Dropbox?

  • Help! How do I unsubscribe to this thread? I keep getting emails for updates and I want to leave. What do I do?

  • brentybrenty

    Team Member
    edited October 2015

    @brucenye: Oh man, believe me, I know how that feels! ;)

    1. Login to your forum account
    2. Click on your username at the top to go to your profile
    3. Click the 'user' menu in the upper right corner
    4. Select Edit Profile
    5. Click Notification Preferences on the left
    6. Uncheck any email notifications you don't want to receive on the right

    I hope this helps! :)

    1PA is working fine for me now.
    Was this a fix by you guys or Dropbox?

    @weavermedia: We collaborated with Dropbox, but ultimately they were able to set the access permissions. I'm glad to hear it's working for you! :chuffed:

  • sjksjk oversoul 1Password Alumni

    Hi @brucenye,

    Help! How do I unsubscribe to this thread? I keep getting emails for updates and I want to leave. What do I do?

    I hope brenty's information about adjusting your forum Notification Preferences was helpful.

    I've actually made it even easier for you not to receive any further email or other notifications for this discussion simply by closing it. :)

    Now that 1PasswordAnywhere usage with Dropbox is working again this thread has run its course. Please start a new one, or comment in a related one, if we can provide assistance with anything else.

    Thanks to everyone for your reports, suggestions, and feedback here! :+1:

This discussion has been closed.