1Password on every desktop

Options
ss2k
ss2k
Community Member

How do I stop 1Password from appearing on every desktop on my Mac? When I move from one desktop to another, 1Password will pop up in the new desktop and steal the focus. Can this behaviour be changed?

Thanks!
Christopher


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • @ss2k Which 1Password app steals the focus? Is it the Mini one in the menu bar or the full app?

  • ss2k
    ss2k
    Community Member
    Options

    It's the full app. Its main window is stealing the focus. But the question is why does the app appear in all desktops? Is this a Mac setting or a 1Password setting?

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    @ss2k: Ah! That's an OS X setting, but it's kind of hidden. By default Mac apps only appear on one desktop — whichever one you launch them on or move them to — but you can right-click their Dock icons to set them to a specific desktop or...all:

    I hope this helps! :)

  • ss2k
    ss2k
    Community Member
    Options

    Thanks a lot Brenty! Much appreciated. I've used this setting before but have forgotten. As you said, the default is one desktop so I hardly needed to adjust it. Thanks again!

  • littlebobbytables
    Options

    Heck @ss2k, I'd forgotten about those settings too. I'm glad brenty was able to clear that up :smile:

This discussion has been closed.