Can run 1Password 4 from Mac OS X command line but not from GUI. Advice?

Options
barkingcatfarm
barkingcatfarm
Community Member

I upgraded to El Capitan (15A284) just after it was officially released. 1Password 4 has been working fine until yesterday. The only things that changed were I installed 2 new apps, Dr. Cleaner and Amphetamine, both from the App Store. What I first noticed was when I tried to use the Safari extension, I would get a message to the effect of that the App had to be installed before I could use the extension. I keep it running almost continuously, so when I would click on the icon in the Dock, I would get the twirling beachball and then nothing. When I'd change context to the app (Command-Tab), then try to quit it (Command-q), it would not quit. I could quit it only from Force Quit. Here are the steps I took, trying the app again after each step, to no avail:

  • uninstalled the 2 new apps, reboot for good measure;
  • uninstalled the extension, reboot;
  • reinstall the extension, reboot;
  • uninstall the extension again, reboot;
  • uninstall app, reboot;
  • reinstall app, reboot;
  • started combing the forums, trying different things recommended successfully to others;
  • finally tried opening from the command line (open -a "1Password 4"); this worked;
  • reinstalled the extension, and that works now as well; plus, I am now able to successfully quit and restart the app from the GUI.

Even though all seems to be well on the 1Password front, I am interested to understand if anybody else has seen this and if anybody can tell me what caused it? I just want to be sure to avoid doing whatever I did to break it again. Your help in this matter is greatly appreciated.

Comments

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hello @barkingcatfarm,

    Can I ask, why are you still using 1Password 4 if you're running El Capitan? 1Password 5 is a free upgrade to all of our 1Password 4 customers so if you have a valid 1Password 4 licence you can upgrade to 1Password 5.4 and it won't cost you a penny. I haven't had a chance to try 1Password 4 out on El Capitan but it's possibly because it never crossed my mind to. The following will allow you to manually move from 1Password 4 to 5:

    1. Quit both 1Password and 1Password mini. You can do this with the keyboard shortcut ⌃⌘Q when 1Password is open (it doesn't have to be unlocked).
    2. Drag the 1Password 4 application from your /Applications/ folder to the Trash. Please don't use an app cleaner.
    3. Reboot your Mac.
    4. Download 1Password 5 from our AgileBits Download page

    although I would have thought 1Password 4 would also offer to update for you. With a little luck this issue doesn't happen with 1Password 5 but if it does we'll certainly work with you to resolve it.

  • barkingcatfarm
    barkingcatfarm
    Community Member
    Options

    Hi littlebobbytables,

    I already upgraded to 1Password 5, after I got 4 working again. In fact, one of the things I tried when troubleshooting my problem was just installing v5, but it behaved the same way as 4. I just forgot to mention it in my initial post.

    I did a lot of tech admin for more years that I care to mention. What has always worked for me when troubleshooting a problem is to determined what has changed that precipitated the failure, back out of those changes until the problem goes away or until you determine that none of the changes caused the problem, and if that doesn't work start pursuing other leads. Since I'd been using 4 for so long with no issues, I was just trying to make as few changes as possible until I got it fixed. Once I got it working again, I updated seamlessly to v5. It's slick!

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @barkingcatfarm,

    I certainly can't argue with that approach :smile:

    Now it might be I'm simply misinterpreting your last statement but you say

    Once I got it working again, I updated seamlessly to v5. It's slick!

    and I keep reading that as you've solved the issue but I don't think you have. If you haven't can you do the following for me please.

    1. Launch 1Password using the prompt trick and make a note of the time.
    2. Quit 1Password and launch it normally so it beachballs and make a note of the time
    3. Launch 1Password using the prompt trick and make a note of the time.

    Can you then create a Diagnostic Report for us please. This guide will assist.

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is support+forum@agilebits.com.

    When sending the diagnostic report to the address above it would help immensely if you could include a link to this thread and your forum handle so we can connect the two.

    Once you've sent the report a post here with the ticket ID will help us to keep an eye out for it. I'm hoping the beach balling, sandwiched between two successful launches and with the timestamps you record will help us identify something that might explain this really odd behaviour. 10/10 for finding a way of still launching 1Password though, I'm not sure that would have been apparent to me to test.

This discussion has been closed.