Chrome Extension on Windows causes freezes [Related to owning a Logitech mouse and system drivers]

I'm new to 1Password. I notice that whenever I click on the 1Password extension in Chrome (current version: 46.0.2490.80 m (64-bit)), my mouse freezes for some 1-3 seconds and the computer becomes unresponsive.

I also see that after unlocking the 1Password vault on the Windows desktop application, there is a while for which the application switches to "not responding" mode. I've already tried checking Help > Advanced > Tune 1Password for max performance. What else can I try to remedy the situation?

P. S. My PC isn't a slow one. Dell, i7 processor, 6 GB RAM and Samsung SSD. It's almost always snappy, so it's clearly not a system-wide problem.


1Password Version: 4.6.0.592
Extension Version: 4.4.3.90
OS Version: Windows 10 (all latest updates installed)
Sync Type: Dropbox
Referrer: forum-search:chrome extension

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited October 2015

    Hi @rationaloutlook,

    I think it might be a system hook that's freezing the system, we use it to detect your activity for the auto-lock timer.

    Do you use a non-default mouse driver for your mouse?

    Please try this as a test:

    1. Open the main 1Password program, unlock and go to the File Menu > Preferences > Logins > Login Keyboard shortcut and delete the shortcut by focusing the field and pressing the backspace key. Press OK to save the changes.
    2. Restart 1Password Helper by going to the Help Menu > Restart 1Password Helper, now go to the File Menu > Exit and restart 1Password.

    Try restarting your browser, does this stop freezing the system?

  • Hi @MikeT,

    I do not use a non-default driver for my trackpad or Logitech mouse (which I use sometimes -- freeze occurs with both). Also, I realized that most probably it's just my mouse that freezes and not the whole system.

    I did try all the steps you listed and the time for which the mouse freezes has decreased a lot. Although I don't think it's completely eliminated. The freeze time now is like 0.2-0.4 seconds.

  • MikeTMikeT Agile Samurai

    Team Member
    edited October 2015

    Hi @rationaloutlook,

    We found out that this mostly happens with users that own a Logitech mouse, the driver for it was not making the system happy with our system hooks. Unfortunately, we have not been able to find a better solution for working around this, yet. The previous instruction I gave was for the keyboard hook, let's try the mouse hook:

    Only keep this setting for our tests, undo this if you need to afterward.

    1. In 1Password, go to the File Menu > Preferences > Security and uncheck the box next to Lock after X minutes of inactivity, press OK to save the change.
    2. See if that eliminates the freeze and if it does, return to the File Menu > Preferences > Logins > Login Keyboard shortcut to restore your keyboard shortcut of Control + \. Repeat the test to see if it is still freezing, if it is not freezing, then the issue is with your mouse driver installed.
    3. Make sure to undo the setting in step 1 if you need 1Password to auto-lock on its own when it detects your mouse and keyboard has not been touched.
  • Hi @MikeT,

    After I tried step 1, the freeze is completely gone. I did restore the keyboard shortcut (step 2). Didn't do step 3 because I'd rather not have the freeze. :) Thank you.

    Also, it seems that the slightly laggy/non-responsive/jerky behavior of the 1Password application (for a second or two) after I enter the password to unlock the vault (I use .opvault format) is unrelated to the problem fixed by step 1. It's not something I can't live with though.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @rationaloutlook,

    Please stay secure by locking your system down more often with the Windows Key + L since 1Password will lock with that and 1Password will not lock on its own with a timer.

    Also, it seems that the slightly laggy/non-responsive/jerky behavior of the 1Password application (for a second or two) after I enter the password to unlock the vault (I use .opvault format) is unrelated to the problem fixed by step 1.

    That's definitely not related, that sounds like the animation glitch that we have at the end of the unlock process. We will change this in the future to be as smooth as possible.

  • Ok, I will take care to lock my system more often. Thanks for your help, @MikeT.

    I hope the problem with Logitech mouse driver is fixed in the future. :)

  • MikeTMikeT Agile Samurai

    Team Member

    We hope so too, it's certainly annoying, and hard to fix.

    You're welcome!

This discussion has been closed.