Lost in Buggy-ness: Master Password Not Working and Sync Not Working Either

edited October 2015 in Mac

This program looked great and had a lot of positive reviews, but I'm finding that I'm losing a lot of time with 1Password 5. I was able to set it up on two Macs, and then sync the data between them via Dropbox, but now the Master Password on the second Mac is no longer responding. It seems that I can just forget about syncing the data to any IOS device. That simply isn't working via Dropbox or WiFi. Any and all attempts fail to recognize the (same) password on either computer -- even though it sees the computer over WiFi and accepts the secret code generated by the computer. Same for the DropBox: it sees the vault -- but no joy on syncing. :p Unfortunately, I downloaded the program from the main site, so I couldn't try the iCloud option, but one would think at least one of the other ways of syncing would work. Then I had the (mistaken) idea that possibly I needed to upgrade to Pro on my IOS devices to be able to see the vault -- though, as I understand it -- I should be able to sync the main vault with the free ios version. So, I upgraded. That didn't work either. . . . Roughly $80 later, I still can't use this on my ios devices or more than one computer.
Does anyone have any constructive suggestions? I'd like to continue to use the program, but am becoming a little frustrated when I know the password and it fails to work anyway.

Since this post, I lost the ability to use the MasterPassword on my first mac as well . . . . so now I can't log in anywhere.

1Password Version: 1Password 5 Version 5.4.1 (541003) Agile Web Store
Extension Version: ?
OS Version: 10.11.1 (15B42)
Sync Type: WiFi/Dropbox


  • brentybrenty

    Team Member

    @rjwalicki: All sync methods work, but Dropbox is my personal favourite. ;)

    To be clear, 1Password doesn't store your Master Password in your vault, so this isn't something that can change overnight, even by accident. However, if there is data corruption it could have the same effect, as it would no longer match to be decrypted properly. And of course if the vault is damaged on one device and you're syncing the data... Well, you get the idea. Please try the steps in this guide in case it's simply an input issue, as it may help you gain access again:

    Master Password not accepted

    Obviously there isn't much more you can say when the Master Password isn't working besides "the Master Password isn't working", but could you elaborate on where you're running into trouble syncing? Unfortunately without some basic information it's hard to say what might be going wrong and how we might right it! Please tell me all OS, 1Password, and device versions you're using, the exact steps you're taking, and what is (or is not) happening the way you expect so we can figure out the best plan of action.

    The more information you can give, the better. For instance, are you receiving some sort of error when you try to setup Dropbox Sync? I'm not anything special, so if it can work for me it can work for you. We'll get to the bottom of this! :)

  • First, the good news -- I am operational. :)
    Second, thanks for being willing to assist with this. It really was an exercise in frustration for me, particularly when I wasn't hearing back from anyone and most forum posts seemed to suggest that if your Master Password wasn't working, basically, you're out of luck.

    In the interest of helping out anyone else with a similar experience, here is what occurred. I'm not certain I understand all that happened, but there is a take-home lesson in this. The explanation is a tad long, but it may help someone else: ;)

    • I first set up 1Password on my laptop, then I set it up on my desktop (both Macs).
    • Both were running OS Version El Capitan 10.11.1 (15B42).
    • With respect to the 1Password version, I am using 1Password 5 for Mac.

    On my laptop -- the first computer on which I installed 1Password -- via Preferences>Sync I also created a folder in my Dropbox to sync my primary vault with Dropbox.
    On the desktop, I seem to recall that I selected the option for setting up a NEW account, rather than the second option. I created a login (a Master Password -- which was identical to the one I created on my laptop). Then I synced it with my Dropbox keychain in the folder I had created earlier.
    Then, I went back to my laptop and, just out of curiosity, selected File>Export>All Items. I inspected it and moved it to the trash.
    At this point, I had 1Password installed on the laptop and the desktop, using same Master Password. Both worked.
    Now, I wanted to be able to access my passwords from my IOS devices (iPhone and iPad).

    [Note to anyone who hasn't purchased 1Password, but is considering it -- you may want to download it from the AppStore versus the website -- you'll have one more option for syncing your data through iCloud.
    I downloaded it from the website, so my only options were to sync my data over WiFi or Dropbox.]

    Next, I went to the laptop: 1Password 5>Window>WiFi Sync>WiFi Server and checked off "Run a WiFi Server from this Mac..." Of course, this generates a "secret" that I then had to enter on my IOS devices in order to be able to sync.

    From my IOS devices, where I had installed 1Password, I attempted the WiFi sync. In short, it didn't work. I don't recall all the error messages, but the most frequent one was that the password was incorrect. I should note that my login on the IOS devices was different than what I had on the desktop and laptop. When attempting to sync, I entered the laptop/desktop Master Password (same). The most common message was that the password was wrong.

    At this point, I went to the desktop to test the Master Password and I could no longer log in. I could still log into the laptop, however. I attempted a restart and it didn't change anything. Then, I believe I restored the 1Password on the desktop computer from a backup. It worked once. I could log in again. But, after another restart, I could no longer do so. Later, and -- again, without changing any passwords -- I could no longer log into the laptop either.

    I sent in a report to AgileBits and was told that the laptop wasn't syncing at all.

    On the outside chance that I was mis-typing the password somehow (not likely but, hey, I was getting tired) I typed the password out into a notepad and pasted that into the login box. Nothing was working.

    At this point I became resigned to starting over. These were the instructions I followed:
    I did this on both computers. I created new Master Passwords for each.

    Here is the take home lesson though: I had over 225 passwords to re-enter, so creating a new vault didn't excite me.

    Then, I had a realization. I remembered that I had exported a .1pif file earlier, (for some unknown reason). I went over to the trash. It was still there! I dragged it to the desktop and restored both computers from this file.

    It should be stress that this is not an encrypted file -- so anyone creating such a file needs to protect it, especially if you plan to store it somewhere.
    Still, it enabled me to recover my data. Now, I can choose to either get rid of it or otherwise encrypt it as well.

    After creating the new vaults, my IOS devices synced via Dropbox without trouble. I don't know what changed.

    All I can gather is that the original Master Passwords were somehow corrupted. The only common denominator was my attempt to sync data via the IOS devices. I'm not computer wizard so I won't pretend to understand how this might have been possible. The bottom line: if you have a lot of data -- back it up or export it early and often, until you are sure everything else is working smoothly.

  • dancodanco Senior Member Community Moderator

    Just one point.

    You say "Note to anyone who hasn't purchased 1Password, but is considering it -- you may want to download it from the AppStore versus the website -- you'll have one more option for syncing your data through iCloud."

    Anyone who is unsure does better to download from the website. That way they get a thirty day free trial. From the App Store they have to pay immediately. It is always possible, with a small amount of effort, to change from the AgileBits trial version to the App Store version if wanted.

  • Greetings @rjwalicki,

    The sad part is we still don't know what happened and of course we don't want this to happen to anybody. These sort of issues are the hardest because you have to be extremely careful about what is logged. It's tough when there is little more that we can suggest other than what is contained in My Master Password is not being accepted. What should I do? :( I'm glad you story had a happy ending though and that you clearly understand what the 1PIF represents.

    What happened to you is terrible and while the desired number of these that I wish we saw was zero they do thankfully make up a very small portion of the troubles people experience. After all, a vault is only useful if it can be accessed.

  • Good point regarding the 30 day trial. And while I'm still not entirely sure of what happened, my speculation is that my attempts to sync via the IOS devices had something to do with the problem. I am now wondering whether another vault (from the IOS device) wasn't somehow installed, merged, or swapped out into the Dropbox folder that I created, causing the known password to not work because it was for a different vault. Still, there were only two Master Passwords used at any time and I tried to input both into the login box -- carefully and repeatedly. My desktop and laptop passwords were identical, as were the IOS passwords to each other. So I had one Master Password that I used to login from the laptop and desktop, and a different password that I used to login from the IOS devices. Neither responded. Then, of course, there was also the finding from my report submitted to AgileBits that suggested the laptop wasn't syncing at all. There was no further explanation for that either.
    It is clear that a good experience is desired for all users. And that is sincerely appreciated.
    It was just a stroke of good fortune that I ran an export of all items and hadn't wiped the file yet from my trash. So,
    "All's well that ends well." :)

  • All's well that ends well does seem fitting. Hopefully everything will run smoothly going forward but if not please do contact us.

  • brentybrenty

    Team Member

    @rjwalicki: I will add to make sure you backup your data — ideally to another drive entirely. The fact that you were able to restore from a backup, unlock, and then it stopped working again eerily mirrors some drive failures I've had in the past. And of course in the event that the same thing happens again, restore from a backup, export the data again, and that way even if you're unable to unlock again on subsequent attempts you'll have everything you need. Better safe than sorry. :blush:

  • Indeed. Good advice.

  • Drew_AGDrew_AG 1Password Alumni


This discussion has been closed.