What could have caused this to happen ?

Ok - first thing - I have fixed the problem - however I was more than slightly worried so I thought I had better ask why it happened.

First of all I have the latest version of 1Password which is downloaded from the website (not app store).

Today I upgraded from Yosemite to El Capitan 10,11,1 and everything worked fine. So maybe I was getting a little too adventurous but I thought I would change my 1Password password. I have about 9 vaults so I chose a less vital one and went through the option to change the password. All appeared to work ok. Before I did this I made a copy of the 1Password folder by copying it from dropbox into my downloads folder.

A while later (and I'm not sure if there had been a reboot or not) I tried to load the desktop part of 1Password and it just froze. I forced it to quit and repeated the process with no joy. I did a reboot and still no joy. It did not appear on screen or prompt for a password - just froze.

I did another reboot and tried again. At this point I recall the main program popped up a message saying that it could no connect to the 1Password Mini.

I did a full uninstall using the uninstructions from your website, rebooted, deleted all the trash, made sure there were no other versions on my machine and then did a reinstall again. Once more - no joy.

At this point I wondered if the password change had screwed up the files so I restored those. I also moved the backup of the files onto a network drive and removed them from my local machine in case the app was confused by which version to load.

Another reboot and another install and it finally works. I don't know what broke it and frankly I don't know what fixed it.

Any insight would be helpful. El Capitan - Password change - something else ?


1Password Version: 1Password 5 Version 5.4.1 (541003) Agile Web Store
Extension Version: 4.4.4
OS Version: 10.11.1
Sync Type: Dropbox


  • Hi @davegarratt,

    Depending on how much starting over you've done a diagnostic report may shed some light. This guide will assist.

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    When sending the diagnostic report to the address above it would help immensely if you could include a link to this thread and your forum handle so we can connect the two.

    Once you've sent the report a post here with the ticket ID will help us to keep an eye out for it. With access to the report we should be able to better assist you :smile:

  • I seems when I did a clean uninstall/reinstall I must have cleaned the logs - sorry.

  • brentybrenty

    Team Member

    @davegarratt: Ah, that makes sense. While we'll never know exactly what occurred, it sounds to me like one of two things: either the app was damaged, or OS X was having trouble launching mini (or both). I'm glad that all is well now, but don't hesitate to reach out if we can be of further assistance. :)

  • edited November 2015

    I have a Primary vault and about 8 others. At the moment they all have the same password. If I want to change the password for all of them is there a special procedure. From what I can tell I have to change to the vault then goto preferences - security and change it there - am I correct ?

    Also as I'm syncing via dropbox will my other devices automatically get the new password as well ?

  • Hi @davegarratt,

    You will have to change each vault's password separately and for that you do understand the procedure of switching to the requisite vault and use of the Security tab in 1Password's preferences.

    If these secondary vaults are also secondary vaults on other devices then you won't have to do anything on the other devices and I'll explain why. We don't actually encrypt your vault with the vault's password. The reason is cryptography is really complex and often unintuitive. The more data you encrypt with one key, the more information can be potentially revealed. So what do we do? we generate a number of encryption keys when you create the vault. We encrypt those keys with your password and while the keys are big the entire size is nothing compared to the size of your entire vault. So when you change your password we encrypt the keys using the new password as the key.

    What does this have to do with secondary vaults? 1Password for Mac and iOS both store the encryption keys for the secondary vaults in the primary vault, that's how unlocking your primary also unlocks your secondary vaults. Any attempt to add the secondary vault to another copy of 1Password would require the new password though - the old password is now gone. If you want to force existing copies of 1Password to require the new password to maintain access to the vault then it's a slightly bigger task but still doable. We'll wait to hear if this is what you want to do or if you're happy that the password change is stored in the Agile Keychain or OPVault and required for other copies to access the vault (in contrast to copies of 1Password that already know about the vault).

This discussion has been closed.