Read first: Previous version support information


Unable to put focus on master password field

bryanhelmsbryanhelms
Community Member

I looked to see if anyone else was experiencing this issue, but I couldn't find anything. Sorry if this has already been reported.

I updated this morning to the latest version of the Alpha (released Nov 17, I think) and got some weird behavior. Whenever I open the app, I am unable to select the Master Password field to enter it. Tabbing on the keyboard doesn't work, clicking on the field doesn't work. I recorded a short screencast to demonstrate the behavior in case you see anything that can tip you off as to what's going on. (I was attempting to type between the clicks in the video)

I'm running the latest Windows 10 inside of a VMWare Fusion VM, with OS X as the host. I'm using touchpads, and couldn't get it to work with my Macbook's touchpad or with the Magic Touchpad. I unfortunately don't have a mouse handy to see if it's just a case of pointer events not being registered correctly.

Let me know if you need any other info.

-- Bryan Helms


1Password Version: Windows Modern Alpha (Nov 17 update)
Extension Version: Not Provided
OS Version: Windows 10 (1511, Build 10586.3)
Sync Type: Dropbox

Comments

  • mohamedosmanmohamedosman
    1Password Alumni
    edited November 2015

    Hey @bryanhelms, this is the first time I've seen this issue. Since you were able to reach the unlock screen, I'm going to assume that you didn't experience any sort of trouble throughout the setup process. In your video, the app icon doesn't look like the 1Password one, can you try to get us a screenshot of the icon?
    Also, could you go to this directory and email us ([email protected]) your "post-mortem.txt" and "live log.txt" C:\Users\<username>\AppData\Local\Packages\DC5C6510.1PasswordAlpha_2v019pwa6amcg\LocalState\
    And just to be on the safe side, make sure you have this 1Password installed.
    Let us know how it goes :)

  • bryanhelmsbryanhelms
    Community Member

    The install was just fine, and I had been using the previous version without issue. This only started occurring after the update. Attached below is the app icon.

    Also, I do appear to have the correct version installed:

    Unfortunately, the two files you mention don't appear to exist in that directory (nor its subdirectories) for me:

    There is a file in crashes, but it's from 7 days ago (probably from when I was trying to set up Teams last week on the previous version). Let me know if I can get you any other info.

  • @bryanhelms if crashes folder is empty, then i'd check Windows for updates first. Personally I had some weird experiences today till I noticed that Windows is trying to install updates.

    Next step is try and update to R18, it's moved to released state few minutes ago. It may take a while for Store to propagate changes, but you can force it by "Check for updates" in Store app.

  • bryanhelmsbryanhelms
    Community Member

    So, I tried the update and was still getting the same behavior. And there were still no files in LocalState. I went ahead and uninstalled and blew all the data away to start fresh. After the re-install, I was finally able to get focus and enter my master password.

    My fault was still in the .agilekeychain format, so I went ahead and did the steps to convert to .opvault and hopefully I'll fare better this time around.

  • bryanhelmsbryanhelms
    Community Member
    edited November 2015

    Hmmm, new thing to report. I can make a different post if you'd prefer.

    It's not concealing passwords in the UI. I even toggled the setting off and on again, but all passwords are being shown in plain text.

    Edit: This is only happening for my personal vault (the .opvault). I joined my Team and all the passwords from that are being concealed properly. Weird.

  • mohamedosmanmohamedosman
    1Password Alumni

    @bryanhelms, we support both formats, but converting to .opvault is definitely the right move because of the increased security it offers.

    As for the un-concealed passwords, do the reveal/conceal buttons still work? Does the problem persist after a fresh restart for the app?

  • bryanhelmsbryanhelms
    Community Member

    Now that I paid more attention, I see the problem is that most of my passwords got converted to Secure Note instead of login. Do you have an article or forum topic handy that covers getting these things to convert properly? I'm sure part of the problem is that my vault started as an export from LastPass heh

  • bryanhelmsbryanhelms
    Community Member

    Actually, that's not the case either.

    1) Some of them do show up concealed as Secure Note:

    2) 1Password for Mac definitely shows these as Logins when I select the "Login" filter, so they look like they should be getting categorized properly.

    Not entirely sure where the wires are getting crossed, but signs point to it being the Windows Modern app. Also, sorry for such a meandering topic haha.

  • bryanhelmsbryanhelms
    Community Member

    Closing and re-opening the app made it lose track of everything, it looks like:

    On the plus side, live log.txt is finally there! Along a couple of crash logs from today. I'll go ahead and email them to the aforementioned address.

  • Thanks @bryanhelms, I foresee few fixes in the near future! :)

This discussion has been closed.