New 1Password Vault always fails

I already have a vault and wanted to add a new empty one.

When I use File > Add New 1Password Vault it always fails with the following error after I type a new master password :

"...\1password.agilekeychan" is not a 1Password Vault.
Changing your master password in the Mac version might correct this problem.

When I browse the directory, I found some files : there are 1Password.html, AgileKeychain.ico, desktop.ini, the data folder contains a default folder with 3 files : 1password.keys (containing an xml file), contents.js contains only 2 NUL bytes and encryptionKeys.js with a lot (288 bytes) of NUL bytes (0x00).

It seems that the new vault feature is buggy on windows.

1Password Version:
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Not Provided


  • brentybrenty

    Team Member

    @tbolon: Do you mean that simply clicking New 1Password Vault in the File menu causes this error? It sounds like that's what you're saying, but the description indicates that you already have a 1Password.agilekeychain in that location, so you're unable to create another with the same name.

    If you change the filename in the save dialog to something else that isn't already in use, are you able to create a new vault then? Please let me know what you find. I look forward to hearing back from you! :)

  • tbolontbolon
    edited December 2015

    I have already a vault, but in another location.

    When you select "Add New 1Password Vault" the save file dialog opens where you have to choose a location and a filename to save your new vault. By default it selects Documents folder (which is ok, since my main vault is in dropbox). Even if I choose another directory, it fails.

    Note that when I choose the folder, the files are created. But then a dialog is displayed to set my master password. After that (pressing OK), the error dialog is shown.

    save dialog

    master password dialog

    displayed error

    folder structure

  • PS: I have just tested with the new opvault format and everything was ok.

  • brentybrenty

    Team Member

    Even if I choose another directory, it fails.

    @tbolon: Thanks for clarifying. Try using a different filename. It looks like you already have one called "1Password.agilekeychain" there, so it makes sense that it wouldn't work in that case. It may also be some permissions issue. I'm able to create a new OPVault or AgileKeychain in both the stable and beta versions of 1Password for Windows, regardless of location, on both Windows 10 and Windows 8. Is there perhaps another factor particular to your setup that I should be testing for? Thanks in advance!

  • I have also tried to rename the file differently (1Password 2.agilekeychain, blabla.agilekeychain) without success. I have tried with a lot of other directories (desktop, documents, etc.) without success.

    I am using french regional settings and windows english display language. Nothing really particular. I have tested with another computer with all settings if French and it works.

    So it seems it's related to my specific configuration. Perhaps you have a log somewhere that I can send to you ?

    Otherwise, I have used the new opvault format as a workaround, so this problem is not really important anymore.

  • This is a rather strange issue and sending in a diagnostics report might make sense:

    Attach the Diagnostics Report to an email message addressed to [email protected].

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and ensure that it is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

This discussion has been closed.