My 1P icon not showing up in Firefox 5.0

I just got a new computer at work. I installed Firefox 5.0, then I installed was Dropbox (where I keep my 1Password data), finally I installed 1Password. I can bring up 1Password and see my stuff. I also checked the Firefox in the browser properties. When I bring up Firefox, I don't see the little "1P" icon. Any ideas?

Thanks

Comments

  • khadkhad Social Choreographer

    Team Member
    Hey ajahn,

    Please take a look at the Firefox troubleshooting guide:

    http://help.agilebits.com/1Password3/firefox.html#troubleshooting

    Have you tried adding the button to the toolbar manually? Ctrl-click the toolbar then select "Customize" from the menu. If you see the 1P icon there, simply drag it into your toolbar.

    I hope that helps. Please let me know.

    Thanks!
  • khad wrote:

    Hey ajahn,

    Please take a look at the Firefox troubleshooting guide:

    http://help.agilebits.com/1Password3/firefox.html#troubleshooting

    Have you tried adding the button to the toolbar manually? Ctrl-click the toolbar then select "Customize" from the menu. If you see the 1P icon there, simply drag it into your toolbar.

    I hope that helps. Please let me know.

    Thanks!


    I tried your advise, but I do not see the 1P icon in the list...
  • khadkhad Social Choreographer

    Team Member
    Often Firefox will cache some data from a previous version, causing the 1Password extension to not load. You can fix this by completely uninstalling the Firefox extension and reinstalling it:

    1. Make sure Firefox is not running.
    2. Launch 1Password from your /Applications folder
    3. Click 1Password > Preferences > Browsers
    4. Click the "Remove All Extensions" button
    5. Launch Firefox and click Tools > Add-ons > Extensions. Make sure that 1Password is not listed.
    6. The previous step is the most important step so we’re repeating it again here :) Launch Firefox and make sure 1Password is not there.
    7. If 1Password is appearing in the Extensions window, click the Uninstall button on the 1Password extension and quit Firefox.
    8. Return to your 1Password window and click the "Install All Extensions" button in Preferences.
    9. Restart Firefox and click Tools > Add-ons > Extensions. Make sure that 1Password is listed.


    After following these steps, the Firefox extension will have forgotten everything about previous versions and should work correctly.

    Please let me know how it turns out.
  • ajahnajahn
    edited July 2011
    khad wrote:

    Often Firefox will cache some data from a previous version, causing the 1Password extension to not load. You can fix this by completely uninstalling the Firefox extension and reinstalling it:

    1. Make sure Firefox is not running.
    2. Launch 1Password from your /Applications folder
    3. Click 1Password > Preferences > Browsers
    4. Click the "Remove All Extensions" button



    I do not see a "Remove All Extensions" button in Preferences > Browsers.

    I've uninstalled/reinstalled both Firefox and 1Password. I now have both of them in C:\MyApps\
    When I click on the firefox icon in 1Password, I keep getting the following error message:

    Firefox profile "C:\Documents and Settings\xxxxx\Application Data\Mozilla\Firefox\Profiles\snk2g6yp.default" does not exist.

    Any ideas? I did try to ad a profile originally so I could retain my old bookmarks and cookies. It didn't seem to work.
    I'm cripled without my 1P icon...

    I have to leave work now, but I will try again tomorrow morning.

    Thanks.
  • brentybrenty

    Team Member
    edited July 2011
    Hey there, ajahn!

    I am sorry for the confusion. I have moved your post to the 1Password Windows support forum, since you appear to be using Windows XP. khad was giving you instructions for the Mac version, since that was the forum where you had posted initially. :)

    It sounds like your profile might be corrupt (or missing?), as evidenced by error message, which explains why the 1Password extension isn't working properly. Please follow these directions to create a new profile.

    Once that is done, launch Firefox under the new profile to ensure that it is working. Then close Firefox and launch 1Password. Go to Preferences > Browsers, and check the box to install the Firefox extension, and then run Firefox and verify that it is working.

    I hope this helps. If you are still having trouble, could you please send us a Diagnostics Report? You can generate one in 1Password on your PC by going to Help > Diagnostics Report > E-mail to Agile... Just attach this to an email ([email protected]), and be sure to include any other details or screenshots you can as it will help us understand the problem better.

    Please let me know how it turns out. :)
  • DBrownDBrown 1Password Alumni
    edited July 2011
    It never hurts to try the tips in the user's guide:


    I'm thinking the second one might be most applicable, but they're all worth a look.
  • Well, I figured out what was going on. At one point, I had a profile named snk2g6yp.default, after reinstalling Firefox, I ended up with a new profile named ob0946gk.Default User. In 1Password, both were listed. I ended up deleting the old one in 1P and now it works. I still had to use Customize... to add the 1P icon, but it works now. Thanks so much for your help. I can't imagine not having my 1P icon in my browser. :-)
  • brentybrenty

    Team Member
    edited July 2011
    That is awesome! I am glad that it is working now. Thanks so much for sharing that. It may just help someone else in the future. :)
  • edited July 2011
    Oh noes!
    Facing the same issue, I tried all the steps in the FAQ and troubleshooter, to no avail. So I reinstalled Firefox, without deleting all my old data. Alas, the same problem just happened again. This suggests that the latest 1P update somehow does not play nicely with Firefox profiles, at least those with certain characteristics.

    Since I have dozens of extensions, as well as saved pwds (some not in 1P, shockingly!) and cookies that ID me, as well as a ton of exceptions, I am really loathe to do a clean install.

    Yes, I could back up my current profile and selectively try to copy stuff into the new profile. But I really don't know if that would work, as some things might be tied to a specific profile ID, and/or to a specific folder path. Recipe for disaster just to make one program work.

    I'll try uninstalling and reinstalling 1P. [UPDATE: Even with as clean a reinstall as I could do, still no luck.)

    Assuming that also fails...Is there any update on this issue??? Any thoughts on what I might do?
  • edited August 2011
    Here's an update, in the hope that may help others. Note that some steps may require you to follow instructions on the Firefox profile management help pages.
    1. Exit Firefox and back up the existing Firefox profile (see the profile management help page). I copied it to the desktop, but just put the backup somewhere easy to find
    2. In 1P, File...Preferences, uncheck the box for Firefox integration
    3. Create a new Firefox profile
    4. Delete the old Firefox profile
    5. Start Firefox if you want, just to make sure...or not
    6. In 1P, enable Firefox integration
    7. Start Firefox, right-click the toolbar area, select Customize, and drag the now-visible 1P icon to your toolbar
    8. Open two instances of Windows Explorer (or just get xplorer2 from Zabkat), pointing one instance at the new profile and one at the backup of the old profile
    9. Follow the help page instructions on moving whatever elements from the old backup profile to the new profile from this page BUT do not copy over anything from the backup profile's "extensions" folder
    10. Either reinstall extensions manually, or copy and paste from the backup profile's "extensions" folder to the new profile's "extensions" folder. *** MAKE SURE YOU DO NOT COPY THE BACKUP "[email protected]" FILE! ***
    11. Check for updates to extensions and restart Firefox to ensure everything is installed with the latest versions
    11. Reconfigure your look and feel as desired, configure options in your extensions as desired, add scripts back to greasemonkey as desired, etc., to get your Firefox to act like it used to a few days ago...DONE!

    Essentially, I had no problem, other than 2 hours of time suckage, by doing these steps. (I have A LOT of extensions that require option configuration, so it was a silly large amount of time. I figure most people only have a few, and it would take a lot less time.)

    I'm not a developer, so I can only speculate that it is not quite as simple as just deleting and replacing the "[email protected]" file. That's because multiple times I had uninstalled the 1P add-on, and the 1P app, both of which remove that file from the profile's folders and replace it with a new one. Instead, it may be something in the files that are auto-generated when making a new profile, or it may be a corruption somewhere else in the pointers to the profile name or folder structure, I don't know.

    Hopefully this helps both 1P track it down, and any other users who are suffering from this problem.

    P.S. For those of you who have extensions that say they will not work with this version of Firefox, just install the Nightly Tester Tools add-on. I've found that most extensions work fine, they are just coded with a "max version" too low for the current build number.
  • brentybrenty

    Team Member
    Oh my god, mark...blink.gif

    Thanks for the update. I am so glad to hear that it is working now, but so very sorry that it had to come to that. For some reason Firefox profiles become corrupt often enough that Google search is full of that.

    Thank you so much for sharing this. Hopefully it will help someone else who has to go through a similar ordeal. Well...hopefully in future versions of Firefox this becomes a thing of the past.
  • DBrownDBrown 1Password Alumni
    1Password users in the forum are so awesome! Where else does someone introduce himself by answering his own question with enough technical information to help his fellow users?

    Thanks, Mark, and welcome to the forum!
  • Glad to help. On a wide range of forums, I've certainly been the viewer many more times than I've been the contributor, so I owe it to others who have been helpful.
    And I did want to be specific, to make it as useful as possible.
    Plus, I'm glad 1P now works again, it makes life easier. :]
  • brentybrenty

    Team Member
    edited August 2011
    smile.gif

    That is awesome! Thanks for contributing knowledge and good cheer, Mark! I hope to see you around.cool.gif
This discussion has been closed.