I can't use 1Password to login to ATT Universal Card site

I am trying to set up 1Password by Agilebits to login to the ATT Universal Card website
https://accountonline.citi.com/cards/svc/OutsideView.do?forward=Index&siteId=AC&langId=EN

I have the correct username and password but the login fails and I get the incorrect information page, https://accountonline.citi.com/cards/svc/LoginIntNext.do?SYNC_TOKEN=a28265c4763caeb3d141a0ddca66d126

I am using 1Password 6.0.1 downloaded from the Mac App Store. I am using Mac OSX 10.11.3 El Capitan and Safari 9.0.3. I also tried using Chrome version 48 but had the same problem.


1Password Version: 6.01
Extension Version: Current version
OS Version: OS X 10.11.3
Sync Type: iCloud
Referrer: kb:save-login-manually, ug:mac/browser-preferences, kb:disable-autosubmit

Comments

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hello @fherr,

    I hope you don't mind but I've moved your query to our Saving and Filling in Browsers section of the forums given the nature of your request.

    So firstly, thank you for the URLs. Being able to see the page in question helps a lot as I can see what you're seeing and poke and prod. I won't be able to test as thoroughly as I don't have an account with AT&T but I'll give it good shot and if need be bring others in.

    So the first I notice is that after you've typed in your username AT&T use some JavaScript to change the name from say username to us****me so that when our extension sees you're trying to log in and asks "hey, would you like to create a Login item?" it only sees the us****me and not what you originally typed.

    So I don't know if it will solve all of the issues but can you try the following for us please.

    1. Open the main 1Password window.
    2. Locate your AT&T Login item and click the Edit button.
    3. You should see your username visible at the top of the item and it should look a little like us****me.
    4. Manually type your username so that us****me can be correctly read as username.
    5. Click the Save button.

    If you do this does the Login item work any better? If it doesn't we'll continue working with you but this will be at least one part of the issue that you're currently facing.

  • I tried your suggestion and it still does not work on the AT&T login page. I also tried to copy and paste the password with the same results. I subsequently found that the password being saved in 1Password was just the letter a. I found the password that was generated and edited the 1Password login but that did not work. However, it did work on the Citi login page.

    https://online.citi.com/US/JPS/portal/Index.do

    Go figure.

    Thanks for your help.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Greetings @fherr,

    Well I apologise that my assistance didn't resolve it but it's great to hear that with a little more investigation you found a URL that you can use. It's odd, when I tried to create a test Login it saved the password bit correctly for me, I wonder why it saved just the letter a for you. In the end though what really matters is you can log in so hopefully you're happy after you found that URL. If you find any other troublesome sites though please do reach out to us :smile:

This discussion has been closed.