Help!! Invalid Data File (problem syncing)

edited December 1969 in 1Password 3 – 7 for Mac

I really love 1password, but I'm having big problems and I'm hoping that someone can help.

Specifically, I am having trouble syncing my desktop mac and notebook mac.

This is the deal:

* I have 1password 3 on my desktop.

* I installed 1password 3 on my notebook

I sync through mobile me.

However, I just downloaded 1password 3 to my notebook and, when I open it, I am prompted to choose between "New Data file" or "Find Existing." I choose "find existing and navigate to library>Keychains> and select "1password.keychain" (this file is only 1 MB). I get the following error message: "Invalid Data File. .... Datafile . . . is incorrect or damaged. Please choose another file."

So, what can I do?

Thanks very much.


  • DBrown
    1Password Alumni
    edited December 1969
    CWM, if you're successfully using 1Password 3 on your desktop Mac, your 1Password data is stored in a file called 1Password.agilekeychain, which is typically located in the folder

    Users > your-name > Library > Application Support > 1Password

    The first step in sync'ing 1Password between your desktop Mac and your new laptop is to put the 1Password.agilekeychain file under the control of a sync program. There are several sync solutions, described here:

    Many of us, and many more of our users, use a third-party service called Dropbox. Instructions for setting up Dropbox sync'ing are here:

    The basic steps are to install Dropbox on your desktop Mac, move the 1Password.agilekeychain file on your desktop Mac to a Dropbox-monitored location, wait for Dropbox to finish uploading your data to the Dropbox web site, install Dropbox on your laptop Mac, associate it with the same Dropbox account, wait for Dropbox to finish downloading your data to the laptop Mac, install 1Password 3 on the laptop Mac, and tell 1Password to use the 1Password.agilekeychain file in the Dropbox-monitored location on your laptop Mac.

    See that second link for details.

    I hope that helps, CWM!
  • AJvK
    edited April 2010
    Well, I have that very same issue, while using Dropbox (0.7.110) - while 1PW3 on my iMac continues to work, I get the 'Data file incorrect or damaged' message if I open 1PW3 on my MacBook. Thing is, both iMac and MacBook were working fine until yesterday, I've been syncing using Dropbox for several months now without any problems. Both iMac and MacBook have been updated to the most recent version of 1PW3, and DropBox states all files are up to date.

    Any advice?
  • Nik
    1Password Alumni
    edited December 1969
    AJvK, welcome to the forums. I would suggest forcing a re-sync of the data file and/or restoring from a recent backup. Since 1Password is working fine on one computer, I would try the re-sync first:

    1. Make sure you're running the latest version of Dropbox on both computers and that the application is running. In the past I have updated Dropbox, forgotten to restart it, and then gotten confused when my data file didn't sync properly.

    2. Quit 1Password on both computers

    3. On the computer where 1Password is working fine, drag your 1Password.agilekeychain file from the Dropbox folder to the Desktop

    4. Make sure that this change propagates and that the file disappears from the Dropbox web site and from your other computer

    5. Follow the Dropbox setup instructions again:

    If you need to restore your data file from a backup, run 1Password and click File > Restore Data File from Backup.
  • AJvK
    edited December 1969

    sorry it's taken me awhile to try out your suggestion. Unfortunately, it didn't work... I removed the keychain from dropbox, verified that it was gone from the website and the laptop, then replaced the keychain, had it sync to the laptop, but 1PW still tells me the file is damaged or incorrect... Tried restoring from a recent backup, but no luck there either.
    I tried moving the keychain to a different folder in Dropbox, and while 1PW3 on the iMac would graciously submit to the change, 1PW3 on the laptop would not. In fact it would not even let me select folders from Dropbox anymore while searching for the keychain. I decided something had probably fouled up the 1PW3 install on the laptop, so I removed 1PW3 from my laptop using AppZapper, and reinstalled from a fresh download - lo and behold: it worked! Could select the keychain in it's proper Dropbox folder, and finally 1PW3 would open the file! Dunno what happened to the previous 1PW3 install, and I'm not too keen to find out, but I'm glad brute force helped in the end...
  • thightower
    Community Member
    edited December 1969
    Thanks for letting us know and were glad you are back to running.
This discussion has been closed.