Latest update is crashing on Windows 7 [Confirmed issue, investigating for a fix]

GregKet1GregKet1
edited July 2016 in Windows Beta

I just installed this mornings 1Password update and now 1Password Desktop won't open. "The program or background process quit unexpectedly". The main window then opens up but after entering my master-password I get 1Password for Windows desktop has stopped working".


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Windows 7
Sync Type: Teams

Comments

  • Ok, this is really not good. I've uninstalled 1password; downloaded the latest beta from HockeyApp; re-installed the beta; tried to open 1Password. Same crashes.

    how do I get this working again?

  • I renamed the SQLlite file in %LOCALAPPDATA% and restarted 1Password. After going through the authentication procedure I got:

    Problem signature:
      Problem Event Name:   CLR20r3
      Problem Signature 01: AgileBits.OnePassword.Desktop
      Problem Signature 02: 6.0.178.0
      Problem Signature 03: 578fd42f
      Problem Signature 04: System.Globalization.Extensions
      Problem Signature 05: 1.0.24212.1
      Problem Signature 06: 575cfa07
      Problem Signature 07: 4
      Problem Signature 08: 14
      Problem Signature 09: System.DllNotFoundException
      OS Version:   6.1.7601.2.1.0.256.27
      Locale ID:    1033
      Additional Information 1: 050d
      Additional Information 2: 050d0ad7d8e67fe3aad1df4c6bd7533a
      Additional Information 3: c08b
      Additional Information 4: c08b5268e3555ddaa1c54d64865cd56c
    
    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409
    
    If the online privacy statement is not available, please read our privacy statement offline:
      C:\Windows\system32\en-US\erofflps.txt
    

    Interesting thing is that I actually received an email stating their was a new login from my machine, but I still couldn't get in to the application without it crashing.

  • PilarPilar

    Team Member

    Hi @GregKet1

    I'm sorry to hear about the trouble that you're having installing 1Password! I just wanted to give you a head up that I moved your post to our Windows category so the right people will be able to see it and help you best. Someone will come along soon and help untangle all this. Thank you very much for being patient about this! :chuffed:

  • MikeTMikeT Agile Samurai

    Team Member
    edited July 2016

    Hi @GregKet1,

    Thanks for writing in. This is a known Windows 7 issue we're investigating, we've added a note about this in the 179d update that users with complex unicode passwords may experience crashes as soon as they unlock.

    The last log you've shows the version 178d, can you confirm you're already got the prompt to update to 179d and it is still crashing as soon as you unlock?

  • 1) All the characters of my password are standard ASCII characters.
    2) I did not get the prompt to upgrade and I installed the latest and greatest off HockeyApp just before I posted that error.
    3) I've checked this morning and saw .179 and have installed it. No improvement.

  • After upgrading to 179 it crashed once (as reported above); then the next time I tried to open it, it hung for a few minutes with the spinning hula-hoop before finally opening. Now it has opened a few times without error.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @GregKet1,

    That's great to hear. Do you have a proxy at work by any chance?

  • Public forum: can't talk about our internal infrastructure. Happy to chat if you want to call me. Info is in your client database.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @GregKet1,

    We understand. We'll follow up via email.

This discussion has been closed.