Minor issues with Firefox browser extension

I have noticed a couple of minor issues with the Firefox browser extension. One is new, the other has been around for a little while.

1) When you first click the extension icon/button it very briefly flashes in the left hand side of the page about half way. Then goes back to where it should coming off the button.

2) When you load a page with login required, and you have not used 1Password, it will prompt you for the password (no problem), then it does not display any logins. Then you need to click the button again & it will show the logins for that site. So you essentially need to press the button twice.

Hope these issues both make sense, if not I can try to explain more. Thanks.

1Password Version: 6.4.380
Extension Version: 4.6.1
OS Version: Windows 10
Sync Type: Not Provided


  • brentybrenty

    Team Member

    @Spaldo: Thanks for reaching out!

    1. I'm not seeing this behaviour. Please update to the latest version of the extension and also let me know which version of Firefox you're using, and if you're seeing this in other browsers.
    2. Do you experience the same issue if you use the keyboard shortcut (Ctrl \) instead? It also sounds like this happens to you because 1Password wasn't running. If you have it start with Windows (Settings > Options > General) does that help?
  • @brenty thanks for the reply.
    1) When I try to update the extension, it says I already have the latest version? Is 4.6.1 the latest for Firefox?
    2) 1Password is always running in the tray (yes that run on start is turned on). I haven't tried that shortcut before, I guess I can try it, but, I just liked the button.

  • brentybrenty

    Team Member
    edited March 2017

    @Spaldo: 4.6.1 is about 6 months old. The latest stable release is 4.6.3, but I guess I shouldn't be surprised you're running into this. Firefox is really weird about updating sometimes and I can never manage to force and update there. Better to remove the extension completely and then download the latest version directly from our site:

    1Password browser extensions

    Definitely update Firefox itself (latest is v52), restart Windows, and try the new extension. :)

  • Ah ok, yeah, Firefox is a pain as well with installing 1Password extension. I have removed it and when I install I always get:

    The add-on could not be downloaded because of a connection failure.

    I remember last time I had to install by downloading, but, I have just found this guide:


    I will try the alternate method for Bitdefender 2017

  • I have installed the new version and updated Firefox from v51 to v52.

    It appears to have fixed that minor graphical glitch in 1) however, I still had the same problem in 2) where I had to click the icon, enter the password, then it doesn't display any logins. Press the button again and then it displayed the login for the site.

  • brentybrenty

    Team Member

    @Spaldo: Nice. It sounds like you we're able to get the new extension installed at least. I'm not seeing what you describe in #2 though. Can you give me the exact steps you're taking?

  • The only way I could get it working was to reboot the PC (lock etc. wouldn't reset the issue).

    When you load the website that you want to fill the password on the first time after reboot, enter your password, then it shows no logins. Then you click away and click back and the logins appear. I made a video but would rather not post it here, do you have somewhere I can email it?

  • @Spaldo sorry about that, the filter by currently selected web page is not applied properly on the initial unlock. We are working to fix that along with few other annoying issues (like obsessive reset to All Vaults). We'll keep you updated here ;)

  • Noticed the same in Chrome so guessing it's all extensions?

  • @brandscill you are correct, it's not browser integration problem, it's 1Password UI issue to be fixed.

  • @SergeyTheAgile no problem. Thanks for saving me uploading the video :) Hopefully fixed soon.

  • brentybrenty

    Team Member

    @Spaldo: And I literally just came back to this discussion to mention that I just saw this behaviour in Vivaldi, so I think Sergey is right and it's an issue we need to fix in the app. Thanks again for reporting this!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    The 1Password 6.5 beta builds already have the fix for refreshing the Logins list after unlocking for the first time (after a reboot).


    Also, another behaviour, if you leave the browser open a log time ((I mean overnight as an example) with a page you want to login and select 1Password for the login autofil, the entry shows but will not fill. close the site you want to a access, re-open it and the fill works correctly.

    Just to confirm, this is in Firefox or which browser are you using? That sounds like a Chrome issue where the extension can die after a long period of inactivity and it cannot revive itself until you refresh the page.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @marksmyth,

    It might just be one site that has always worked but is not working now.

    Do you mean without waiting overnight, it is no longer filling on the site properly?

  • GregGreg

    Team Member

    @marksmyth: Could you give us an example, so we could check it properly on our side? Thanks!

  • GregGreg

    Team Member
    edited September 2017

    @marksmyth: No worries! I've just sent a follow-up to your email address. Let's continue our conversation there. Thanks! :+1:

    ref: NKS-47379-265

This discussion has been closed.