6.8.488 partly broke Windows' Aero-Snap for me [Fix planned in the next update]

IxofjeIxofje
edited December 2017 in Windows

"Aero Snap" is a feature of windows to auto-resize windows by dragging them to or from the edge of the screen.
See here for a explanatory video:

Installing 6.8.488 yesterday I immediately noticed, that undocking the maximized 1Password-Windows doesn't work anymore. Trying a few more things i can now say:

Undocking the windows works only by clicking and dragging the mouse beyond the red line. The default behaviour of a normal windows app is, that you can click and drag even at the outmost top of the screen which makes sense.

Can you reprocuce this? v 6.7.457 on my other Computer works as intended.

Thanks


1Password Version: 6.8.488
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @Ixofje: Hmm. I'm familiar with the feature, but I had no idea it was called "Aero Snap", so thank you for the video! :lol:

    Can you tell me more about what's broken for you? I'm not having any trouble "snapping" or "unsnapping" 6.8 to the top or sides. Have you tried restarting Windows?

  • Hi brenty,

    i did upload a video for my issue:

    • The first thing i do is maximizing the Window. This works as it should
    • Next i try to "unsnap" the Windows by clicking and dragging my mouse down to the middle. Note carefully where i put my cursor before dragging. I try this a few times
    • After that i am re-positioning my cursor on the lower edge of the blue bar - and voilà - i can drag it down.

    So to clarify: Dragging to "high" on the bar breaks the "unsnap", which is new behaviour and cannot be intended.

    ("")

  • SergeyTheAgileSergeyTheAgile

    Team Member
    edited January 2018

    @lxofje thanks for letting us know, indeed resize border seems to stay active (although mouse cursor is not changing) in maximized mode. Fix is coming with next update.

  • @SergeyTheAgile
    Sounds great - thanks!

  • MikeTMikeT Agile Samurai

    Team Member

    On behalf of Serg, you're welcome.

  • Hi there,

    i would like to check back on that issue.

    I seems to me that it has not yet been fixed.

    Can you tell me if it‘s on the roadmap for one of the next updates?

    Thanks so much

  • brentybrenty

    Team Member

    @Ixofje: I'm sorry to say that development has ceased in 1Password 6, so it will not be fixed there...

    ...because we've fixed it in version 7! Keep an eye out for updates. ;)

    ref: OPW-1716

  • Ok cool!

    V7 is still in Beta, right?

  • brentybrenty

    Team Member

    @Ixofje: 1Password for Windows version 7 is probably in beta for a few more hours, yes.

This discussion has been closed.