Windows not Syncing changes to my account [Should be improved in 6.8.491 update]

edited January 2018 in 1Password 4 for Windows


Writing this on behalf of my partner who has had issues with her 1Password not syncing with her Android phone.

She's on the subscription where you guys manage her vault but not a team one (she signs into my.1password) her passwords she has been entering on her Windows machine are not syncing to her Android phone. She has never had a dropbox/local file version of 1password and both her Windows machine and Android machine are logged into the same account (I logged out of mobile and used code from PC to re-sign in)

When I check the web client it matches the Android so it looks like the new passwords/updates are not being sent to the cloud your storing em in. I've sent a diag along with a link to this post to you guys, looking forward to your reply.

1Password Version: 6.8.488
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Cupcake,

    Thanks for reporting this. I found your email and have replied to it, it looks like the update from 1Password 6.2 to 1Password 6.8 didn't go well. It should be a quick fix though as explained in my reply.

    ref: FKU-93593-999

  • I'm having a similar issue with two Windows 10 computers. I changed a pretty important password on 12/24/2017 on the 1Password iPhone app, and it seems like the app on the iPad picked up the change instantly. However, when trying to access that password on a Windows 10 desktop yesterday, the password was not being updated - I tried exiting 1Password several times to hopefully force a re-sync; but, no luck. I had to go grab my phone and just typed in the password. Same issue today on a Surface running Windows 10; the password shows as last updated in late July, when it was updated a couple of days ago.

    Anyways, I think the issue might be fixed because in trying to submit this I had to create a password, so I used 1Password on Windows. After saving it, it seems like that forced a re-sync.

    Is there a way to cause a manual re-sync within the app?

  • bundtkatebundtkate

    Team Member

    @Carlos A Peralta : Locking 1Password, waiting 10 seconds or so, and unlocking again will usually force a sync, as will making a trivial change to an item. That said, 1Password should be syncing periodically regardless and definitely should sync up when you first unlock it if changes have been made. This may have been a hiccup, but I'd prefer to check real quick to confirm just in case. If you make a trivial change to an item on iOS (say, adding a note to an item, for example) while 1Password for Windows is locked, does it now sync up right away? Also, could you let me know what version of 1Password you're using on the PC? Thanks! :chuffed:

  • edited December 2017

    Thanks @bundtkate ; but, still having the issue on Windows 10. I'm running v6.8.488 and syncing it with Agilebit's cloud.

    I added a note to an item on the iPhone and saved it; the iPad picked it up within seconds - I searched for the item and there was the note. I logged into 1Password on the Windows desktop, and don't see the note. After exiting the app, and also locking/unlocking the vault 3 times and waiting about 10-20 seconds each time, still not seeing the note. It's been about 25 minutes since the change was made, and it still is not coming through. Tried it on the Surface as well (also on v6.8.488) and don't see the note.

    I made a change to another item and saved it (on the desktop) - that seems to have forced a re-sync and the updated note now shows. The Surface is not picking up the changes made to either entry. The iPad kept the change made to the original entry, and also picked up the change made to the other item on Windows.

  • brentybrenty

    Team Member

    @Carlos A Peralta: Thanks for letting us know! Indeed, editing an item in the Windows app should force it to connect to the server and also fetch changes there. If you're still having trouble, the best thing to do will be to generate a diagnostic report so we can look at the logs to determine exactly what is happening:

    Please send it to [email protected] and add the following Support ID (including the square brackets) to the subject of your diagnostics email before sending:


    If you’re reading this and you are not Carlos A Peralta, this Support ID is for Carlos A Peralta only. Please ask us for your own if you also need help.

    This will link your diagnostics to our current discussion. Let me know once you've sent it. Once we see it we should be able to better assist you. Thanks in advance!

    ref: UAM-37485-447

  • Thanks @brenty - I've sent the diagnostics report.

    Before creating the report, I made a change to two items on the other Windows computer, and this computer (where the report was generated) did not pickup either change.

  • Good morning everyone!

    I have the same bug. Sometimes (not always), an update made on my iphone does not arrive on my 1Password for Windows (home and work, both in 6.8). Exiting and restarting the application does not change anything. But when I access the site, the modification is present and then arrives in the application.

    If I do the manipulation when the application is open, it synchronizes well. If I do this while the application is closed, the modification does not arrive at the next opening. But it ends up happening if I connect to the site at the same time.

    Any changes made in the Windows application are well synchronized with the site and other applications.

    I confess I don't understand the correlation between the two.

    I hope this can help :-)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @Carlos A Peralta, we got the report and will reply as soon as possible. At first glance, there is no indication of any problems on that computer. The issue may be elsewhere but we'll reply with the next step ASAP.

    @Grishkaone, that sounds like the main interface isn't refreshing properly. That is a separate issue, could you email us your 1Password diagnostics report. Please use this guide to generate the report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • Hi @MikeT

    Juste sent the diagnostic report, looking forward for your answer :)

  • MikeTMikeT Agile Samurai

    Team Member

    Thanks, we got the email and will reply there as soon as possible.

    ref: HVM-38297-721

  • MikeTMikeT Agile Samurai

    Team Member

    Hey folks,

    Thanks for your help and for sending in the diagnostics reports. I was able to find the patterns and we figured out what happened as well. We're working on fixing this and will be issuing an update very soon once we finish testing it.

  • MikeTMikeT Agile Samurai

    Team Member

    We've shipped the 1Password 6.8.491 update today that'll fix the reported sync issues here. Please give it a try and let us know if it is working better now.

  • Hi @MikeT

    So far it's working, both @home and @work behind a proxy. Well done :-)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Grishkaone,

    That's great to hear.

    We had to do another update today to reduce the frequency of our sync attempts as it is causing 1Password to sync successfully too often. For now, in certain setups where 1Password cannot maintain a proper connection to our service, it will only start to try every ten minute to sync after an hour of no sync calls.

  • hey sorry your reply went into spam for some reason so I lost it. Doing the first replies steps has started the sync, my partner will now look to see if any logins stop working. If that happens it would indicate the sync lost data, if that happens we will restore the backup, take note of those passwords and re-apply fix.


  • brentybrenty

    Team Member

    Sounds good! We're here if you need us. :)

  • I'm having a similar issue, but I'm on 6.8.496. I use 1PW on my iPhone and multiple Windows PCs w/ a 1PW account. I often have trouble with new items showing up on my Windows PCs. If the item is created with iOS, it often doesn't show up on my Windows PCs. If the item is created with a Windows PC, it often doesn't show up on my other Windows PCs, but it shows up in iOS (and the website) just fine.

    Specifically, the items don't show up on Windows if that PC's 1PW was closed during their creation on another device. If 1PW is open but locked during this, it syncs fine. If it's open and unlocked, it syncs fine. It's only when 1PW is not open (usually because the PC is asleep) that I have issues with items showing up. Locking and unlocking doesn't make them show up. Restarting the application completely sometimes seems to work. Logging into the 1PW website makes the item show up in Windows immediately.

    No problem with items showing up on iOS or the website, it's just Windows. Don't know if I should create a new thread instead, but my issue seems very similar to Grishkaone's, so I figured I'd post here. In fact, I couldn't pin down when items were and weren't syncing. It seemed random, until I read his post and was able to figure out the pattern.

  • brentybrenty

    Team Member

    @Tetryl91: Thank you! Thats very helpful! While we've made some improvements in this area, the fact remains that the Windows app still has trouble receiving notifications for remote changes in some setups. It's something we're continuing to look into. It's interesting to me that you say it works fine if the app is open though, as others have had trouble even with that. If you aren't receiving changes on Windows and you make an edit in the 1Password app, do they sync then?

  • @brenty: Yeah, it syncs fine for me when it's open. I should note that when I tested it as "open but locked" 1PW had already been unlocked, and I used the lock button to lock it before testing. It seems a lot of the inconsistency when syncing comes when my Windows PC was asleep/off while creating items on other devices. I tried to do some further testing, but the results were sometimes a little inconsistent.

    Here's what I did:

    • Woke computer up from sleep (it had been sleeping all night), left 1PW locked, created item on iOS, unlocked on Windows: no sync
    • 1PW unlocked, locked it with lock button, did not put the PC to sleep, created item on iOS, unlocked 1PW: synced
    • Put the computer back to sleep, then immediately woke it up, but did not unlock 1PW, created item on iOS, unlocked 1PW: synced
    • 1PW open and unlocked, created item on iOS: synced
    • Put computer to sleep, created item on iOS, woke computer up from sleep, unlocked 1PW (tested 3 times): no sync twice, synced once

    In cases where it didn't sync, editing an item on either iOS or Windows caused everything to sync immediately.

  • brentybrenty

    Team Member

    Thanks so much for the extra details! We have a few improvements we're working on that should help. The feedback is greatly appreciated. :)

This discussion has been closed.