All extensions broken in 7-Beta 1

Options
mwdiers
mwdiers
Community Member
edited April 2023 in 1Password 3 – 7 for Mac

There is definitely something wrong with Beta 1 and extensions. I have deleted 1Password 6, and rebooted. I removed all existing Firefox and Chrome extensions. I then installed the beta extensions in Firefox and Chrome. No extensions work at all, Not in Safari, Chrome, or Firefox.

I am finding two problems:

First, according to the Browser Console in Firefox, even the Beta extension is still looking for 1Password 6:

File at path "/Applications/1Password 6.app/Contents/Library/LoginItems/2BUA8C4S2C.com.agilebits.onepassword4-helper.app/Contents/MacOS/OnePasswordNativeMessageHost" does not exist, or is not executable Subprocess.jsm:127
[CHROME:NM] Port <[object Object]> disconnected: An unexpected error occurred  global.min.js:238:122
[AGENT] Connection [object NativeMessagingConnection] disconnected.  global.min.js:99:201
1Password detected a high number of disconnections from the browser extension to the main application between Wed Mar 28 2018 15:13:45 GMT-0500 (CDT) and Wed Mar 28 2018 15:15:45 GMT-0500 (CDT)  global.min.js:238:471
[AGENT] Connection [object NativeMessagingConnection] disconnected.

Second, the 1Password Extension Helper.app is not launching. The crash reports shows:

Process:               1Password Extension Helper [2438]
Path:                  /private/var/folders/*/1Password Extension Helper.app/Contents/MacOS/1Password Extension Helper
Identifier:            2BUA8C4S2C.com.agilebits.onepassword7-helper
Version:               7.0.BETA-1 (70000001)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           1Password Extension Helper [2438]
User ID:               1895975915

Date/Time:             2018-03-28 15:09:01.701 -0500
OS Version:            Mac OS X 10.13.3 (17D102)
Report Version:        12
Bridge OS Version:     3.0 (14Y661)
Anonymous UUID:        B3F327EA-7FDA-926A-F434-0CED727D9019


Time Awake Since Boot: 420 seconds

System Integrity Protection: enabled

Notes:                 Translocated Process

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @rpath/AgileLibrary.framework/Versions/A/AgileLibrary
  Referenced from: /private/var/folders/*/1Password Extension Helper.app/Contents/MacOS/1Password Extension Helper
  Reason: image not found

The same thing happens when launching 1Password Updater: The AgileLibrary is not found.


1Password Version: Not Provided
Extension Version: Not Provided
_OS Version:10.3.3
_Sync Type:Dropbox and Vault

Comments

  • Ben
    Options

    Hi @mwdiers

    1Password must be in the /Applications folder in order to work properly. The installer should put it there, but if you downloaded the .zip file instead of the installer (the blog post initially linked to the .zip) you will need to do so manually.

    Thanks.

    Ben

  • Dianeoforegon
    Dianeoforegon
    Community Member
    Options

    @mwdiers I had a similar problem. Make sure that after you remove all extensions, you launch 1Password v7 then select to install the extensions.

    BTW, b3 has been released. Mine updated in the background overnight.
    @Ben posted a link in another discussion: https://c.1password.com/dist/1P/mac7/1Password-7.0.BETA-3.pkg

  • Ben
    Ben
    edited March 2018
    Options

    There is no need to use the install extensions option in v7 w/r/t Safari. That option is only for non-Safari browsers. Simply relaunching Safari while 1Password 7 is installed will install the extension in Safari.

    Installing the Safari extension from the install extensions option will actually be detremental in v7 as this installs the extension that only works with v6.

    Ben

  • rudy
    Options

    @mwdiers,

    For clarification, i see two things wrong in your logs.
    the NativeMessageHost JSON support file in your browser didn't get updated by 1Password 7 because 1Password 7 was AppTranslocated. AppTranslocation happens when you launch an application from the Downloads folder. Installing from the package installer or by moving the application to /Applications will remedy both of those conditions.

    Rudy

  • mwdiers
    mwdiers
    Community Member
    Options

    @rudy

    No, that wasn't it. I always had the .app in /Applications.

    The problem was that the initial link on the blog post for the Beta was not for the installer, but for a .zip file with just the .app binary. Because no installation process occurred, nothing was setup correctly if you just used the .app by itself. Later in the day, they corrected this to be the link for the .pkg installer. When I ran that, everything worked properly.

  • rudy
    Options

    @mwdiers,

    The installer doesn't actually set anything up, its sole purpose is to avoid people launching from Downloads and getting AppTranslocated by the OS (app gets copied to a read only disk image that the OS then mounts and launches the app from). You should have been fine to download the zip, move the binary to /Applications and launch it.

    Rudy

  • mwdiers
    mwdiers
    Community Member
    edited March 2018
    Options

    @rudy

    I don't know what to tell you. At no point did I ever attempt to run 1Password 7.app from anywhere but /Applications. I had even completely deleted every vestige of 1Password 6, and all of its config in ~/Library and set everything up from scratch.

    It's moot at this point. Except for the GUI glitches (I run in Dark mode), everything has been running fine after running the .pkg.

  • Ben
    Options

    Thanks for the update. :)

    Ben

  • 1puburap
    1puburap
    Community Member
    Options

    Hi,

    I cannot use the Firefox Extension with 1Password 7 Version 7.0.BETA-5 (70000005)
    The Extension is blinking and has no function.

    Firefox 59.0.2
    macOS 10.13.4

    Cheers
    Fritz

  • Stephen_C
    Stephen_C
    Community Member
    Options

    @1puburap I am running exactly what your are running (1Password version, FF version and macOS version) and the FF extension is working perfectly for me. What version of the FF extension are you running?

    Stephen

  • 1puburap
    1puburap
    Community Member
    Options

    4.7.0.90
    Fritz

  • Stephen_C
    Stephen_C
    Community Member
    Options

    The FF extension version I have is 4.7.1.2. Go to 1Password 7 > Install browser extensions... and see if a later version is offered.

    Stephen

  • 1puburap
    1puburap
    Community Member
    Options

    I just installed Version 4.7.1.3 - no success. ;(

  • Stephen_C
    Stephen_C
    Community Member
    Options

    Well, to some extent you've now done better than I have. If I go to 1Password 7 > Install browser extensions... that simply now directs to https://1password.com/! I'm certainly not offered any FF extension on that page.

    Sorry, but I'll have to leave your problem to someone more expert...and maybe they'll comment on this post at the same time.

    Stephen

  • Jacob
    Options

    @1puburap Sorry about the trouble with things. Could you try restarting your computer, and if the issue continues, create a Diagnostics Report?

    How to send a diagnostics report from your Mac

    Attach the Diagnostics Reports to an email, and send it to support+forum@agilebits.com.

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum username so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    You should receive an automated reply from our BitBot assistant with a confirmation number. Please post that number here so we can track down the report and ensure that it is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • 1puburap
    1puburap
    Community Member
    Options

    the Diagnostics Report is on the way.
    confirmation number: [#CNM-61952-838]

    cheers
    Fritz

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Thank you for the ticket ID @1puburap, I've located the diagnostic report and replied :smile:

    ref: CNM-61952-838

  • 1puburap
    1puburap
    Community Member
    Options

    With a fresh copy of Firefox (59.0.2) and the 1P-extension 4.7.1.3 everything is fine.
    Thanks
    Fritz

  • Ben
    Options

    Thanks for the uppdate @1puburap.

    Ben

This discussion has been closed.